Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-21-09, 01:10 PM   #1
cookiecaper
Registered User
 
Join Date: May 2007
Posts: 28
Default Defeating overscan

I just obtained an RCA L40FHD380 HDTV for use as a monitor for my computer. nVidia's Windows driver provides a feature that allows one to resize the display size of the desktop to compensate for overscan features in HD sets. I can't find service documentation for my model, so I can't disable overscan on the set, but I would really like to know f anyone has suggestions for defeating this. I've tried various modelines but the television is forced down to its next lowest resolution (720p) if I use an explicit modeline. Virtual doesn't seem to produce desired results either. Anyone have good suggestions for how to fix this?

Additionally, really would be nice if nVidia would port that feature from Windows to Linux. It's quite helpful and necessary. Please consider this a feature request in that regard.

If this can't be solved, I'll have to return the television and buy one with overt overscan disablement features in user menu, and that would be a huge hassle, so I'm really hoping that someone knows good stuff about this. : )

All help appreciated.
cookiecaper is offline   Reply With Quote
Old 02-21-09, 01:28 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Defeating overscan

Just search the internet and this forum for solutions. In case of composite you can use the tvoverscan option or else you can fix it by using a proper modeline.
Thunderbird is offline   Reply With Quote
Old 02-21-09, 01:34 PM   #3
cookiecaper
Registered User
 
Join Date: May 2007
Posts: 28
Default Re: Defeating overscan

Thanks for the reply. Every modeline I have tried makes it go to the next-lowest reported good resolution, which is 1280x720. Do I need to specify something to force it? Thanks again.
cookiecaper is offline   Reply With Quote
Old 02-21-09, 01:39 PM   #4
cookiecaper
Registered User
 
Join Date: May 2007
Posts: 28
Default Re: Defeating overscan

I also neglected to note that I have a 1680x1050 monitor connected via TwinView to the right. It seems to work fine, but I don't know if this will require any extra stuff in modelines or not. Also, should I use metamodes instead of modelines?

This is my Xorg.conf as it stands. You can see some things I've tried before commented out.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder62) Tue Jan 6 09:44:34 PST 2009

#Section "Modes"
# Identifier "HDM"
# ModeLine "HDM" 148.500 1848 2008 2052 2200 1016 1084 1089 1125 +hsync +vsync
#EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "ddc"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Tech. Concepts RCA"
HorizSync 39.0 - 49.0
VertRefresh 47.0 - 63.0
ModeLine "HDM" 156.03 1848 1960 2160 2472 1016 1017 1020 1052 -hsync +vsync
Option "DPI" "96 x 96"
Option "UseEdidDpi" "false"
Option "DPMS"
# UseModes "HDM"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7900 GT/GTO"
Option "DPI" "96 x 96"
Option "UseEdidDpi" "false"
EndSection

Section "Screen"

# Removed Option "TwinView" "1"
# Removed Option "metamodes" "DFP-0: 1680x1050_60 +1920+0, DFP-1: 1920x1080 +0+0; DFP-0: 1680x1050 +0+0, DFP-1: NULL; DFP-0: 1280x1024 +0+0, DFP-1: NULL; DFP-0: 1024x768 +0+0, DFP-1: NULL; DFP-0: 800x600 +0+0, DFP-1: NULL; DFP-0: 640x480 +0+0, DFP-1: NULL"
# Removed Option "TwinView" "0"
# Removed Option "TwinViewXineramaInfoOrder" "DFP-1"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "DPI" "96 x 96"
Option "UseEdidDpi" "false"
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: 1680x1050 +1920+0"
SubSection "Display"
# ViewPort x100 y100
# Virtual 1848 1016
Depth 24
EndSubSection
EndSection
cookiecaper is offline   Reply With Quote
Old 02-21-09, 06:04 PM   #5
cookiecaper
Registered User
 
Join Date: May 2007
Posts: 28
Default Re: Defeating overscan

OK, so I've been fiddling with it all day and have tried many different modelines to no avail. Most modelines fail to display any image -- I've been using gtf to generate them, but apparently it's faulty because even with UseEdidFreqs set to false, the screen doesn't accept the modelines that X feeds and displays a "Unusable Signal" message.

I've attached a screenshot that demonstrates what I'm seeing with nvidia-auto-select. It's really sad life.

I'm going to keep fiddling with modelines, but hopefully this data might help. Here's an updated Xorg:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder62) Tue Jan 6 09:44:34 PST 2009

#Section "Modes"
# Identifier "HDM"
# ModeLine "HDM" 148.500 1848 2008 2052 2200 1016 1084 1089 1125 +hsync +vsync
#EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "ddc"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
ModelName "Tech. Concepts RCA"
HorizSync 39.0 - 100.0
VertRefresh 40.0 - 100.0
#ModeLine "HDM" 116.30 1848 1944 2136 2424 1016 1017 1020 1043 -HSync +Vsync
#ModeLine "HDM" 136.42 1848 1952 2152 2456 1016 1017 1020 1048 -HSync +Vsync
Modeline "HDM" 143.34 1824 1936 2128 2432 1001 1002 1005 1034 -HSync +Vsync
#Modeline "HDM" 139.59 1872 1976 2176 2480 1030 1031 1034 1062 -HSync +Vsync
#ModeLine "HDM" 138.50 1848 1960 2160 2472 1016 1017 1020 1052 -hsync +vsync
Option "DPI" "96 x 96"
Option "UseEdidDpi" "false"
Option "DPMS"
# UseModes "HDM"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "ModeDebug" "true"
BoardName "GeForce 7900 GT/GTO"
Option "DPI" "96 x 96"
Option "UseEdidDpi" "false"
Option "ExactModeTimingsDVI" "True"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "DPI" "96 x 96"
Option "UseEdidDpi" "false"
# Option "UseEdidFreqs" "false"
# Option "ExactModeTimingsDVI" "True"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: 1680x1050 +1920+0"
# Option "metamodes" "DFP-0: HDM +0+0, DFP-1: 1680x1050_59 +1920+0"
SubSection "Display"
Depth 24
Option "ExactModeTimingsDVI" "True"
Option "ModeValidation" "NoDFPNativeResolutionCheck"

EndSubSection
EndSection
Attached Thumbnails
Click image for larger version

Name:	lamerca.jpg
Views:	124
Size:	238.4 KB
ID:	35629  
cookiecaper is offline   Reply With Quote
Old 02-22-09, 02:07 AM   #6
El1iP3S01D
Saleen s7 TT Rocks:-0
 
El1iP3S01D's Avatar
 
Join Date: Nov 2007
Location: nyc, NY
Posts: 34
Default Re: Defeating overscan

cookie, tell me if this works? http://analogbit.com/node/23 And explain if it does so that i can fix my Overscan problem as well....
__________________
Patiently, waiting for Death who is close and closer?
El1iP3S01D is offline   Reply With Quote
Old 02-22-09, 03:50 AM   #7
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Defeating overscan

If you have windows create hdtv modelines using powerstrip. It also allows you to export modelines to the same format as used by X in xorg.conf.
Thunderbird is offline   Reply With Quote
Old 02-22-09, 06:58 PM   #8
Overscanned
Registered User
 
Join Date: Feb 2009
Posts: 1
Default Re: Defeating overscan

It is true that PowerStrip will export a ModeLine to match your windows resolution and timings. Unfortunately, this really doesn't help since the 'Resize HDTV Desktop' feature of the nvidia windows driver does not actually change the resolution. You can verify this by generating a modeline from pstrip, resizing the desktop, and then generating a second modeline. From my testing, the modelines are identical. I suspect this is because the nvidia windows tool is actually setting some kind of 'Scale' parameter on the card.

Does anyone know of documentation for parameters that can be passed to the nvidia kernel module when it is being loaded? (i.e. param for the insmod)

Thanks,
Craig
Overscanned is offline   Reply With Quote

Old 01-18-10, 03:07 PM   #9
cookiecaper
Registered User
 
Join Date: May 2007
Posts: 28
Default Re: Defeating overscan

For the record, I eventually gave up and returned the set for one that allows the user to disable overscan from its menus. It's some kind of Samsung. I turned overscan off in the menus and everything was set up within a couple of minutes.

It's much, much better and the image is much clearer, so a good result to this is to get a set that exposes advanced options to users.

Against my better judgment, I thought I could get away with a purchase without having to do a lot of research beforehand, but it just increased my hassle.
cookiecaper is offline   Reply With Quote
Old 01-20-10, 10:45 AM   #10
sherbey
Registered User
 
Join Date: Jun 2006
Posts: 45
Default Re: Defeating overscan

As of (I think) 190.42 there is an overscan correction parameter in the nvidia driver; my telly is a bit old and has no adjustment for overscan. Works a treat!

Obviously you're far better off doing this directly on your telly rather than in the screen driver - I didn't have that option though
sherbey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removal of overscan options in 302.07... hikaricore NVIDIA Linux 12 01-05-13 04:30 PM
ViewPortOut instead of Overscan comp. I need help! C-J NVIDIA Linux 5 06-27-12 11:41 AM
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
HDMI overscan fix for multiple resolutions + Zod Engine Problem. cheechr1 NVIDIA Linux 0 06-11-12 02:27 PM

All times are GMT -5. The time now is 11:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.