Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-31-09, 06:06 PM   #1
costing
Registered User
 
Join Date: Dec 2009
Posts: 4
Default Overheating laptop when using the HDMI output

If I connect a screen via HDMI the powermizer frequency goes to maximum and doesn't come down at all, causing the GPU to go to 96C and the fans to scream. As soon as I disable the HDMI output it calms down again. The system is completely idle all this time.

Hardware is Asus G50 (GeForce 9700M GT), drivers 185 and even 190.53 (no difference in behavior).

Is there any setting that would prevent the frequency to go up? I've tried a lot of options in xorg.conf but nothing prevents the overheating.
costing is offline   Reply With Quote
Old 12-31-09, 06:17 PM   #2
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: Overheating laptop when using the HDMI output

If you are using dual-monitor mode, it probably has to keep the GPU memory frequency high in order to provide enough bandwidth for both monitors.
thefirstm is offline   Reply With Quote
Old 01-01-10, 11:01 AM   #3
costing
Registered User
 
Join Date: Dec 2009
Posts: 4
Default Re: Overheating laptop when using the HDMI output

It does the same even when it's in "clone" mode. And even so, it cannot jump from 100 to 800MHz just to support a second monitor. I'd understand a doubling of the frequency but it's much more than that. I've tested and it does the same over VGA too. And the resolution of the second monitor doesn't matter (320x240 to full hd).
costing is offline   Reply With Quote
Old 01-01-10, 11:48 AM   #4
tier
Registered User
 
Join Date: Sep 2007
Posts: 118
Default Re: Overheating laptop when using the HDMI output

This is a frequently asked question and it is common. The gpu stays in high performance state when more than one monitor is connected. There is no way to prevent that right now.

If you gpu gets that hot in high performance mode, it is clearly a faulty design of your laptop.
My quadro nvs 140 never gets hotter than 65C
tier is offline   Reply With Quote
Old 01-01-10, 12:11 PM   #5
costing
Registered User
 
Join Date: Dec 2009
Posts: 4
Default Re: Overheating laptop when using the HDMI output

Lucky you I hope that nvidia will fix this nice feature at some point...
costing is offline   Reply With Quote
Old 01-04-10, 09:13 AM   #6
costing
Registered User
 
Join Date: Dec 2009
Posts: 4
Lightbulb Re: Overheating laptop when using the HDMI output

I found a combination that works! 195.30 + the following settings in xorg.conf:

Code:
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3; PowerMizerLevel=0x3; PowerMizerLevelAC=0x3; PowerMizerHardLevel=0x3; PowerMizerHardLevelAC=0x3"
Option "OnDemandVBlankInterrupts" "true"
Option "Coolbits" "1"
Like this the frequency is locked to minimum even if two screens are connected.
costing is offline   Reply With Quote
Old 01-22-10, 05:37 PM   #7
Huk
Registered User
 
Join Date: Dec 2006
Posts: 12
Default Re: Overheating laptop when using the HDMI output

HOLY!! It really works!

For me this is the first time it ever worked (GF9100M) - I must say that performance drop in most apps is negligible, I mean REALLY NEGLIGIBLE like 1-5% on lowest powermizer settings - however vdpau suffers a lot - with lowest performance level it chocks even on some 720p while on max performance it can decode FullHD movies. Anyway I guess now we wait for Nvidia devs to add "Max powersaving" to powermizer's "Preffered modes" list.
Huk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:09 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.