Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-09-10, 05:56 PM   #49
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU 9400GT MPEG2 artifacts

64-bit users can now join in the testing fun; download http://avon.wwwdotorg.org/downloads/...a.so.195.36.03 and place it in /usr/lib64/vdpau (or wherever your existing 64-bit libvdpau_nvidia.so is).
Stephen Warren is offline   Reply With Quote
Old 02-09-10, 06:00 PM   #50
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU 9400GT MPEG2 artifacts

Oh, and if anyone who is experiencing this issue has an Intel CPU instead of an AMD CPU, I'd be interested in knowing that.
Stephen Warren is offline   Reply With Quote
Old 02-09-10, 09:32 PM   #51
plaengert
Registered User
 
Join Date: Dec 2007
Posts: 3
Default Re: VDPAU 9400GT MPEG2 artifacts

nvidia-bug-report.log.gz

cpuinfo.txt

I'm glad to help in any way I can. Here's my nvidia-bug-report, plus the output from cat /proc/cpuinfo.
plaengert is offline   Reply With Quote
Old 02-09-10, 11:35 PM   #52
rdriscoll
Registered User
 
Join Date: Dec 2009
Posts: 12
Default Re: VDPAU 9400GT MPEG2 artifacts

Quote:
Originally Posted by Stephen Warren View Post
It would be really helpful if everyone who's having this issue could attach an "nvidia bug report" here. I have reports from gator123 and bts1000 already.

Also, if you could post the output of "cat /proc/cpuinfo", that would help too.

Thanks.
Here is the info requested, will try the patch tomorrow -thnx.

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
stepping : 2
cpu MHz : 2700.243
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips : 5400.48
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
stepping : 2
cpu MHz : 2700.243
cache size : 512 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips : 5400.48
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps
Attached Files
File Type: gz nvidia-bug-report.log.gz (43.9 KB, 132 views)
rdriscoll is offline   Reply With Quote
Old 02-10-10, 03:25 AM   #53
bts1000
Registered User
 
Join Date: Aug 2009
Posts: 6
Default Re: VDPAU 9400GT MPEG2 artifacts

Unfortunately I'm not able to test the patch at the moment.

Here is the cpuinfo BUT I recompiled the kernel since the last test and changed some CPU related stuff...

Regards, Stefan

cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 35
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
stepping : 2
cpu MHz : 1000.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow extd_apicid pni lahf_lm cmp_legacy
bogomips : 1994.99
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 35
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
stepping : 2
cpu MHz : 1000.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow extd_apicid pni lahf_lm cmp_legacy
bogomips : 1994.99
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp
bts1000 is offline   Reply With Quote
Old 02-10-10, 11:46 AM   #54
rdriscoll
Registered User
 
Join Date: Dec 2009
Posts: 12
Default Re: VDPAU 9400GT MPEG2 artifacts

Quote:
Originally Posted by Stephen Warren View Post
64-bit users can now join in the testing fun; download http://avon.wwwdotorg.org/downloads/...a.so.195.36.03 and place it in /usr/lib64/vdpau (or wherever your existing 64-bit libvdpau_nvidia.so is).
I installed the 195.36.03 driver and then replaced the lib and rebooted. I still see the artifacts on 64bit MythTv mpeg2 playback.

Ron
rdriscoll is offline   Reply With Quote
Old 02-10-10, 12:17 PM   #55
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU 9400GT MPEG2 artifacts

rdriscoll, that's unfortunate.

Is there any effect at all on the artifacts; i.e. is there reduction if not complete solution?

Can you test MPlayer? If so, is there any effect there?

Also, can you double-check that you placed the modified file in the correct place; please run the following command:

md5sum /usr/lib*/{vdpau/}libvdpau_nvidia.so*

The correct version should have md5sum bd1cd17cd1ce8afa77dfad66d14b91b1. The original version was 6abe8b5f8035f48c57a370820f93d493.

Thanks very much!
Stephen Warren is offline   Reply With Quote
Old 02-11-10, 09:34 AM   #56
rdriscoll
Registered User
 
Join Date: Dec 2009
Posts: 12
Default Re: VDPAU 9400GT MPEG2 artifacts

Quote:
Originally Posted by Stephen Warren View Post
rdriscoll, that's unfortunate.

Is there any effect at all on the artifacts; i.e. is there reduction if not complete solution?

Can you test MPlayer? If so, is there any effect there?

Also, can you double-check that you placed the modified file in the correct place; please run the following command:

md5sum /usr/lib*/{vdpau/}libvdpau_nvidia.so*

The correct version should have md5sum bd1cd17cd1ce8afa77dfad66d14b91b1. The original version was 6abe8b5f8035f48c57a370820f93d493.

Thanks very much!

OK I replaced all the locations of the lib and it works! Sorry for the confusion and thanks

No more artifacts and I'm using advanced 1x de-interlacing. Does anyone know if the openGl vsync helps with mythTv?
rdriscoll is offline   Reply With Quote

Old 02-11-10, 10:29 AM   #57
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU 9400GT MPEG2 artifacts

Great! Thanks.
Stephen Warren is offline   Reply With Quote
Old 02-11-10, 10:29 AM   #58
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU 9400GT MPEG2 artifacts

OpenGL's sync-to-vblank setting will only affect MythTV if it uses OpenGL for its rendering. I don't believe it does.
Stephen Warren is offline   Reply With Quote
Old 02-11-10, 11:47 AM   #59
rdriscoll
Registered User
 
Join Date: Dec 2009
Posts: 12
Default Re: VDPAU 9400GT MPEG2 artifacts

Quote:
Originally Posted by Stephen Warren View Post
OpenGL's sync-to-vblank setting will only affect MythTV if it uses OpenGL for its rendering. I don't believe it does.

That's what I thought, OpenGL can be used for menu's but other than that I don't see a need for it.

Just curious, were the artifacts a frame buffer synchronization problem or alignment issue?
rdriscoll is offline   Reply With Quote
Old 02-22-10, 01:38 PM   #60
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU 9400GT MPEG2 artifacts

eamiller, I moved your posts to http://www.nvnews.net/vbulletin/showthread.php?t=148140, since I've confirmed they are a separate issue.
Stephen Warren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.