Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-18-10, 10:57 PM   #1
slightlystoopid
Registered User
 
Join Date: Feb 2010
Posts: 6
Exclamation twinview too wide

Card: FX5200
Driver: 173.14.25
Xorg: 1.7.5
Gnome: 2.28.2

One monitor is 1920x1080 and the other is 1024x768. The secondary (smaller) monitor has to be on the right currently because the size of the virtual screen is currently about a scroll bar width too big. This means, if I maximize something, I can't see any scroll bar if the window has one, or data otherwise, or the close button. This problem is more irritating because I'd really like for the secondary monitor to be on the left, but if I do that, I can't see anything on the far right in gnome panel, meaning the primary monitor would have the problems. There's no panning or anything, it just doesn't show it.

EDIT: This occurs in Windows XP SP3 as well running driver 175.19.

the virtual resolution appears correct:
Code:
[~]$ xvidtune -show
"2944x1080"    78.75   2944 1040 1136 1312   1080  769  772  800 +hsync +vsync
That's exactly 1920+1024=2944, so that looks good.

Here's the relevant parts of xorg.conf:
Code:
Section "ServerLayout"
	Identifier	"Twinview"
	Screen 0	"Screen2" 0 0
EndSection

Section "Device"
	Identifier	"Card2"
	VendorName	"nVidia Corporation"
	BoardName	"GeForce FX 5200 [NV34] (rev a1)"
	BusID		"PCI:1:0:0"
	Driver		"nvidia"
	Option	"NvAGP"			"1"
	Option	"Coolbits"		"1"
	Option	"RenderAccel"		"True"
	Option	"NoLogo"		"True"
	Option	"AllowGLXWithComposite"	"True"
	Option	"AddARGBGLXVisuals"	"True"
	Option	"TwinView"	"True"
	Option	"TwinViewXineramaInfoOrder"	"DFP-0"
	Option	"MetaModes" "CRT: 1024x768_75 +1920+0, DFP: 1920x1080_60 +0+0"
	Option	"HorizSync"	"CRT-0: 30-63"
	Option	"VertRefresh"	"CRT-0: 50-75"
	Option	"DPI"	"95 x 95"
	Option	"ModeValidation"	"DFP: NoMaxPClkCheck"
EndSection

Section "Monitor"
        Identifier      "Monitor4"
        Option  "DPMS"  "true"
EndSection

Section "Screen"
	Identifier	"Screen2"
	Device		"Card2"
	Monitor		"Monitor4"
	DefaultDepth	24
	SubSection "Display"
		Depth	24
		Viewport 0 0
	EndSubSection
EndSection
and the relevant part of Xorg.0.log:
Code:
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Option "RenderAccel" "True"
(**) NVIDIA(0): Option "TwinView" "True"
(**) NVIDIA(0): Option "MetaModes" "CRT: 1024x768_75 +1920+0, DFP: 1920x1080_60 +0+0"
(**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "DFP-0"
(**) NVIDIA(0): Option "HorizSync" "CRT-0: 30-63"
(**) NVIDIA(0): Option "VertRefresh" "CRT-0: 50-75"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "True"
(**) NVIDIA(0): Option "Coolbits" "1"
(**) NVIDIA(0): Option "DPI" "95 x 95"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Option "ModeValidation" "DFP: NoMaxPClkCheck"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): TwinView enabled
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(WW) NVIDIA(GPU-0): The EDID read for display device CRT-0 is invalid:
(WW) NVIDIA(GPU-0):     unrecognized EDID Header.
(II) NVIDIA(0): NVIDIA GPU GeForce FX 5200 (NV34) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.34.20.87.00
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:1:0:0:
(--) NVIDIA(0):     CRT-0
(--) NVIDIA(0):     ACI ASUS VH236H (DFP-0)
(--) NVIDIA(0): CRT-0: 350.0 MHz maximum pixel clock
(--) NVIDIA(0): ACI ASUS VH236H (DFP-0): 135.0 MHz maximum pixel clock
(--) NVIDIA(0): ACI ASUS VH236H (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Display Devices found referenced in MetaMode: CRT-0, DFP-0
(II) NVIDIA(0): Mode Validation Overrides for ACI ASUS VH236H (DFP-0):
(II) NVIDIA(0):     NoMaxPClkCheck
(II) NVIDIA(0): Assigned Display Devices: CRT-0, DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "CRT:1024x768_75+1920+0,DFP:1920x1080_60+0+0"
(II) NVIDIA(0): Virtual screen size determined to be 2944 x 1080
(**) NVIDIA(0): DPI set to (95, 95); computed from "DPI" X config option
(**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "CRT:1024x768_75+1920+0,DFP:1920x1080_60+0+0"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
slightlystoopid is offline   Reply With Quote
Old 02-19-10, 06:27 PM   #2
slightlystoopid
Registered User
 
Join Date: Feb 2010
Posts: 6
Default Re: twinview too wide

This seems to have been resolved by adding:
Code:
#	Option	"MetaModes" "CRT: 1024x768_75 +1920+0, DFP: 1920x1080_60 +0+0"
	Option	"MetaModes" "CRT: 1024x768_75 +0+0, DFP: 1920x1080_60 +1024+0"
Then reverting back to the original.

Similar process for Windows XP, switch from one back to the other.
slightlystoopid is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:51 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.