Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-28-09, 07:20 AM   #1
vitb
Registered User
 
Join Date: May 2008
Posts: 8
Question 96.43.13 & new X.org : resVgaShared missing

Hello,
I am still using legacy drivers with old mx440 and it seems to be incompatible with latest X in F12 alpha :

(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: resVgaShared
(EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

It is apparently the same I already seen for other driver series. Can this be addressed please?
vitb is offline   Reply With Quote
Old 10-11-09, 12:54 AM   #2
darenisaacs
Registered User
 
Join Date: Oct 2009
Posts: 1
Default Re: 96.43.13 & new X.org : resVgaShared missing

I am interested in seeing this addressed too. thx.
darenisaacs is offline   Reply With Quote
Old 10-11-09, 03:55 AM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 96.43.13 & new X.org : resVgaShared missing

The latest beta driver 190.36, has official support for xserver 1.7.0. While I can't make any concrete promises as to if or when, we do plan to backport support for that server to the 96.43.* legacy series eventually.
AaronP is offline   Reply With Quote
Old 10-15-09, 07:01 AM   #4
Kaboon
Registered User
 
Join Date: Dec 2008
Posts: 8
Question Re: 96.43.13 & new X.org : resVgaShared missing

AaronP, I guess you hear this at least a few times a day but I can't help it, I have to pop the question; do you've got any idea when (if?) this issue will be addressed? I'm having the exact same problem with Fedora 12 and the 173.14.20 drivers.

I can't wait for me desktop effects to work properly.

[edit] PS. I just noticed you wrote your post a few days ago, silly American dates. Forgive me my ignorance, I'll just sit down quietly in my corner again.
Kaboon is offline   Reply With Quote
Old 10-16-09, 07:23 AM   #5
glee1954
Registered User
 
Join Date: Oct 2009
Posts: 1
Default Re: 96.43.13 & new X.org : resVgaShared missing

I just wanted to note that this updated driver isn't just needed for desktop effects (Compiz).

The new Gnome 2.28 gnome-shell requires 3D drivers as well. As a result, any of the video cards requiring the proprietary legacy driver for 3D are not being tested with gnome-shell.
glee1954 is offline   Reply With Quote
Old 11-03-09, 12:31 PM   #6
breathe
Registered User
 
Join Date: Nov 2009
Posts: 1
Default Re: 96.43.13 & new X.org : resVgaShared missing

I don't want to be a pain in the neck... but, is there any progress in this issue?
What do you recommend... shall we stay with xorg-server-1.6-xx version or is it better to move to nv the opensource nvidia driver?
breathe is offline   Reply With Quote
Old 02-22-10, 07:50 AM   #7
RAMChYLD
Registered User
 
Join Date: Feb 2005
Location: Malaysia
Posts: 95
Default Re: 96.43.13 & new X.org : resVgaShared missing

Hi, please chalk me up as the latest casualty of the issue. I upgraded my Debian Sid install to the latest packages after leaving the world of linux for a few weeks due to real-world issues and found that 96.43.13 stopped working. Yes, I know, Sid is not for production use. Don't worry, I'm a hobbyist and Linux veteran. Any estimated date we can expect a new driver that supports XOrg 1.7 to be out? Going back to XOrg 1.6.xx is not feasible for me at the moment as it's time consuming and I'm probably better off leaving that machine alone and working in command line/fbdev/svgalib until the 1.7-compatible drivers are ready.

Edit: nevermind, please disregard, as usual I missed the fact that a new driver is out and should support 1.7...
__________________
Rigs:
  • "Edison" - Phenom II X4 925 AM3 (Deneb), M4N98TD-EVO (nForce980a SLI), ENGTS450 DirectCU 1GB (GeForce GTS450) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 8GB DDR3-1600
  • "Sally" - Athlon64 x2 5000+ AM2 (Brisbane), M4N72-E (nForce750a SLI), ENGTS250 Dark Knight 1GB (GeForce GTS250) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 4GB DDR2-1066
  • "Dongwa" - Phenom II X4 945 AM3 (Deneb), M4N75TD (nForce750a SLI), ENGTX260-216SP 896MB (GeForce GTX260 216SP) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Fatal1ty Champion, 8GB DDR3-1600
  • "Helen" - Athlon64 x2 6400+ AM2 (Windsor), M4N78 Pro (GeForce8300), ENGT520 1GB (GeForce GT520), integrated GeForce8300, AuzenTech Prelude X-Fi, 4GB DDR2-1066.
  • "Clementine" - Athlon64 x2 3800+ AM2 (Windsor), TF560A2+ (nForce560), V8402GL26 (GeForce 8400GS), SoundBlaster Live! 5.1, Sonnet Allegro FW400 PCIe, 2GB DDR2-800
RAMChYLD is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.