Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-09-10, 07:17 PM   #13
paoleary
Registered User
 
Join Date: Feb 2010
Posts: 37
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by doogs View Post
I have my Asus GT220 working!

Instructions are here:

http://xbmc.org/wiki/?title=HOW-TO_s..._Begin.2FNotes

in my case when looking for the card:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

I note that my motherboard's in built sound card is 0 so to test I used:
speaker-test -Dplughw:1,3 -c2

the '1' means card 1 the '3' means device 3 and the '2' means 2 channels i.e. stereo

you can change the '2' to '6' to try 5.1 audio and '8' to try 7.1 audio

Hope this helps,
Cheers
Doogs
Glad you got things going, doogs. Can you let me know if you're experiencing any problems? Most common are improperly mapped channels and occasional audio dropouts w/video slowdown on some media types. Thanks!
paoleary is offline   Reply With Quote
Old 02-17-10, 10:55 AM   #14
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Hi doogs,
Glad you got audio working on hdmi.

I have a gt210 running ubuntu 9.10 and alsa 1.0.22, 195.22 nvidia driver with the alsa nvidia patch installed based on your how-to (well written and easy to follow, thanks!). But no audio over hdmi when running a test with aplay. Appreciate any inputs on what I maybe missing.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

I unmuted the SPDIF for card 1 (nvidia hdmi one) using alsamixer.

───────────────────────────── AlsaMixer v1.0.22 ──────────────────────────────┐
│ Card: HDA NVidia F1: Help │
│ Chip: Nvidia NVIDIA G210 HDMI F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: S/PDIF Esc: Exit │
│ │

│ ┌──┐ │
│ │OO│ │
│ └──┘ │
│ < S/PDIF > │
│ │


Tested with aplay as follows.

Tried the default audio output and works.

$ aplay -Dplughw:0,0 /usr/share/sounds/alsa/Rear_Right.wav

Hear audio on my speakers.

The hdmi is connected to my panasonic tv and the audio is turned on. Video runs ok. Tried running hdmi audio as follows but no audio.

$ aplay -Dplughw:1,3 /usr/share/sounds/alsa/Rear_Right.wav

After checking in other postings, have added these into my asound.conf and sound.conf.

$ cat /etc/asound.conf
pcm.!default {
type hw
card 1
device 3
}

$ cat /etc/modprobe.d/sound.conf
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

Am I missing something in my setup?

I notice zim2dive and alanw's postings (Jan 12, Jan 13, 2010) indicating that nvidia driver may not support audio over hdmi. This confuses me. Did something change on the nvidia drivers since then?
rp_linux is offline   Reply With Quote
Old 02-17-10, 08:06 PM   #15
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by rp_linux View Post
I notice zim2dive and alanw's postings (Jan 12, Jan 13, 2010) indicating that nvidia driver may not support audio over hdmi. This confuses me. Did something change on the nvidia drivers since then?
Please ignore my post.. I was only trying to tie together what looked to be related threads. Based on the alsa pathches (which I have not tried yet with my 220), it looks like maybe it was at least an alsa issue which needed to be resolved.
zim2dive is offline   Reply With Quote
Old 02-18-10, 12:45 PM   #16
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by zim2dive View Post
Please ignore my post.. I was only trying to tie together what looked to be related threads. Based on the alsa pathches (which I have not tried yet with my 220), it looks like maybe it was at least an alsa issue which needed to be resolved.
Thanks for the clarification, zim2dive!

Dear nvidia developers,
Just to completely eliminate the nvidia drivers from this problem, can you confirm that there is no known issue with the 195.xx or 190.xx driver for hdmi audio on gt210.

Specifically Iam using 195.22 version.

I can then focus on making sure I setup my alsa patches and conf files correctly.
rp_linux is offline   Reply With Quote
Old 02-22-10, 06:29 AM   #17
Rodercot
Registered User
 
Join Date: Feb 2010
Location: Ottawa, Canada
Posts: 12
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Here is the Fix for your card. paoleary was kind enough to develop a patch against Alsa 1.0.22.1 and I have it working and tested on nvidia drivers

http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240

185 - 190 - 195 - and finally 195.36.03

I have one card in a Zotac IONITX-F-E with the ion chip disable and 512Mb still shared from the bios. The card here is a GT220 Asus that I made Passive via my Zalman VNF-100 it runs less than 50C all the time in an Antec Fusion 430 with only one of the 120mm fans hooked up. I also am running XBMC, Myth 9.10 and watching Blu Rays natively via makemkv with TrueHD and LPCM - DTS-HD of course is stripped down to the core.

The other is a GT240 in an Asus P5N7A-VM again wiht XBMC - Myth 9.10 - Blu-Ray all runs fine with multi-channel audio and hdmi of the card.

On-board sound is disabled on both boards but it did not have to be. Channel Mapping still seems to be my issues and 24Hz playback of VC1 encoded files is highly unwatchable via xbmc/ffmpeg all other formats are fine at 24Hz. ffmpeg and feature set C cards have a ways to go.

Regards,


Dave
Mythbuntu 9.10 - XBMC SVN27017 - NV 195.36.03 - NV GT220 - NVGT240.
Rodercot is offline   Reply With Quote
Old 02-22-10, 10:21 AM   #18
larophel
Registered User
 
Join Date: Nov 2009
Posts: 29
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Does this also work for M (laptop) cards?
I have a laptop with a GT 230M card and only have video over HDMI.
larophel is offline   Reply With Quote
Old 02-22-10, 11:05 AM   #19
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Rodercot - Thanks for your pointers and encouraged to hear your GT240 is working great!

I did setup my alsa 1.0.22 using paoleary's patch and following his write up (thanks to paoleary for putting this together).

http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240

One difference I can see between our setups is, I haven't disabled the onboard audio. I have hesitated to do so as it is the only working audio output I got but maybe worth a try.

Can you please point me how to do it. Should I disable it in bios or is there a simpler way to do it?

Is ion chipset same as GT210 (sorry, not familiar with ion)?

Do you see anything else that might be wrong in my setup?

Reading some other postings, I have heard mixed responses on what to enter in /etc/modprobe.d/sound.conf.

I have tried several combinations but no hdmi sound still. My nvidia card is card1.


options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

Gave some errors in dmesg with the probe_mask. Removing the probe_mask gets rid of the dmesg errors but no hdmi output.

Tried this also but no luck.
options snd-hda-intel enable_msi=0 index=1

I don't know if these make a difference for GT210. Can you post your working sound.conf?

If anyone has a working (from hdmi audio perspective) sound.conf for GT210, can you please post it.
rp_linux is offline   Reply With Quote
Old 02-23-10, 02:27 PM   #20
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

I tried playing with the /etc/modprobe.d/sound.conf. hdmi audio did not work in any of those combinations. Iam posting the dmesg and aplay info, hoping someone can point out what maybe wrong in my setup.

Trial 1: With this line in sound.conf
"options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2"

Both cards are recognized however dmesg shows some errors.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

$ dmesg | grep hda
[ 16.250616] hda_intel: codec_mask forced to 0xff
[ 17.296009] ALSA hda_intel.c:695: azx_get_response timeout, switching to polling mode: last cmd=0x000f0000
[ 18.300018] ALSA hda_intel.c:1397: Codec #0 probe error; disabling it...
[ 19.392234] ALSA hda_intel.c:1397: Codec #1 probe error; disabling it...
[ 20.432012] ALSA hda_intel.c:1397: Codec #3 probe error; disabling it...
[ 20.505135] hda_codec: ALC888: BIOS auto-probing.
[ 20.511242] hda_intel: codec_mask forced to 0xf2
[ 30.290445] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.


Trial 2: With this line in sound.conf
"options snd-hda-intel enable_msi=0"

dmesg doesn't show errors atleast.

$ dmesg | grep hda
[ 9.701302] hda_codec: ALC888: BIOS auto-probing.
[ 10.416091] ALSA hda_intel.c:1971: Invalid PCM device number 8
[ 10.416098] hda_codec: cannot attach PCM stream 8 for codec #2
[ 10.432051] ALSA hda_intel.c:1971: Invalid PCM device number 9
[ 10.432058] hda_codec: cannot attach PCM stream 9 for codec #3
[ 33.268937] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.


Trial 3: With this line
options snd-hda-intel enable_msi=0 index=-2


dmesg is clean

$ dmesg | grep hda
[ 16.172994] hda_codec: ALC888: BIOS auto-probing.
[ 17.094058] ALSA hda_intel.c:1971: Invalid PCM device number 8
[ 17.094062] hda_codec: cannot attach PCM stream 8 for codec #2
[ 17.112033] ALSA hda_intel.c:1971: Invalid PCM device number 9
[ 17.112038] hda_codec: cannot attach PCM stream 9 for codec #3
[ 28.711242] hda-intel: IRQ timing workaround is activated for card #0. Sugges


$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

Still no sound in hdmi.
rp_linux is offline   Reply With Quote

Old 02-23-10, 02:32 PM   #21
Rodercot
Registered User
 
Join Date: Feb 2010
Location: Ottawa, Canada
Posts: 12
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by rp_linux View Post
Rodercot - Thanks for your pointers and encouraged to hear your GT240 is working great!

I did setup my alsa 1.0.22 using paoleary's patch and following his write up (thanks to paoleary for putting this together).

http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240

One difference I can see between our setups is, I haven't disabled the onboard audio. I have hesitated to do so as it is the only working audio output I got but maybe worth a try.

Can you please point me how to do it. Should I disable it in bios or is there a simpler way to do it?

Is ion chipset same as GT210 (sorry, not familiar with ion)?

Do you see anything else that might be wrong in my setup?

Reading some other postings, I have heard mixed responses on what to enter in /etc/modprobe.d/sound.conf.

I have tried several combinations but no hdmi sound still. My nvidia card is card1.


options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

Gave some errors in dmesg with the probe_mask. Removing the probe_mask gets rid of the dmesg errors but no hdmi output.

Tried this also but no luck.
options snd-hda-intel enable_msi=0 index=1

I don't know if these make a difference for GT210. Can you post your working sound.conf?

If anyone has a working (from hdmi audio perspective) sound.conf for GT210, can you please post it.

Hi rp_linux,

you are not alone, there seems to be several who cannot get the 210 cards to output hdmi. Not sure if you posted but what type of card is it. The other one I see is MSI, on another note - Is there anyone that has audio working on there 210 card.

as for the on-board sound, in the bios under integrated devices I think it was; I just disabled the audio and then under chipset - southbridge I think you should have an option for disabling on-board gpu if ext gpu is present and then I disabled the buffer this then allows you to allocate some shared memory to the card via the box below it, I set this at 512 - not even sure if the new cards need this any longer. This is if you have on-board video of-course. Ion is just a 9300/9400M chipset if I recall.

My sound.conf file is simply

options snd-hda-intel enable_msi=0 probe_mask=0xfff2

This is because I have disabled my on-board sound card making the nvidia hdmi card 0 and no longer card 1 so I do not need the first 0xffff. I could be wrong but I am sure that some had there cards working prior to adding the msi=0 option - you may want to try without that option just too test it. Also if you disable the on-board sound card your dmesg errors will go away at least they do for me, you will still see the probing but no errors.

Regards,

Dave
Rodercot is offline   Reply With Quote
Old 02-23-10, 03:11 PM   #22
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Hi Dave,
This is the video card I have, PNY GeForce 210 512MB DDR2 PCIe 2.0 x16 Graphics Card.

http://www.microcenter.com/single_pr...uct_id=0320940

Thanks, will try your suggestions also - remove the "enable_msi", disable the on board audio.
rp_linux is offline   Reply With Quote
Old 02-24-10, 09:49 AM   #23
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Hi Dave
Removing the "enable_msi" in the sound.conf did not make a difference.

For some reason I couldn't get into bios to disable the on board audio card. Tried to disable it in the /etc/modprobe.d/blacklist.conf file, not sure Iam doing it correctly as both cards still show up in alsa. Should I do it differently?

"blacklist snd_hda_nvhdmi"

After removing the blacklist line, this is my alsa-info.sh output.
http://www.alsa-project.org/db/?f=73...ffa46e9a6f65db

Anything else I can try?
rp_linux is offline   Reply With Quote
Old 02-24-10, 01:06 PM   #24
Rodercot
Registered User
 
Join Date: Feb 2010
Location: Ottawa, Canada
Posts: 12
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

I believe it would be snd_hda_intel.

to enter your bios it should be just hit delete on initial screen I usually just tap the delete key from power on and it finds it's way in there. What type of mainboard do you have.

regards,

Dave
Rodercot is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.