Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-10-08, 10:27 AM   #1
lyle
Registered User
 
Join Date: Jul 2008
Posts: 3
Default Complete lock-up after startx

lyle@bowman:~$ /sbin/lspci | grep VGA
05:00.0 VGA compatible controller: nVidia Corporation GeForce 8500 GT (rev a1)

Momboard is Mach Speed MSNV-939. No bios update is available.

Distro is Slackware 12.1. NVIDIA driver version is 169.12.

I've tried idle=poll and maxcpus=1 and both at the same time. None of the other bullet points on http://www.nvnews.net/vbulletin/showthread.php?t=58498 apply to me.

When I run startx the computer locks up and cannot be logged into remotely (although I can use the SysRq key combinations to reboot.) Consequently, I can't provide nvidia-bug-report.log. The monitor goes to sleep as if I've turned the computer off.

I'll attach Xorg.0.log (logverbose 6), but the only interesting line in there that I can see is:
(WW) ****INVALID MEM ALLOCATION**** b: 0xce000000 e: 0xce000000 correcting^G

The weirdest part is the ^G at the end of the line. Using the od command, I can see the last two characters are "bel nl". It seems very strange that the bel (ASCII character 7) appear in a log file.

The last line in Xorg.0.log is:
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.

Is that as far as it should get?

Please ask if I've left anything out. I'd love to see that NVIDIA logo come up someday!

Thanks,
Lyle.
Attached Files
File Type: log Xorg.0.log (20.6 KB, 110 views)
lyle is offline   Reply With Quote
Old 07-10-08, 11:55 AM   #2
memeyou
Registered User
 
Join Date: May 2008
Posts: 74
Default Re: Complete lock-up after startx

Have you tried 173.14.09?
memeyou is offline   Reply With Quote
Old 08-11-08, 05:26 PM   #3
lyle
Registered User
 
Join Date: Jul 2008
Posts: 3
Default Re: Complete lock-up after startx

Thanks, I finally got a chance to try 173.14.09.

No change though--everything is almost exactly the same as my previous post. I'm attaching the new Xorg.0.log, but the only significant difference is a new line:

(II) PCI: 00:0a:0: chip 10de,0057 card 1565,2501 rev a3 class 06,80,00 hdr 00 85,86d85

That bel character is still in there. it's so weird to have a non-printable character in there; it suggests some kind of memory corruption.

I'm going to submit this to the nvidia linux-bugs e-mail address. How am I going to send them the output of nvidia-bug-report.sh if startx crashes the machine?

Thanks,
Lyle.
Attached Files
File Type: log new.Xorg.0.log (21.1 KB, 92 views)
lyle is offline   Reply With Quote
Old 02-27-10, 09:58 PM   #4
lyle
Registered User
 
Join Date: Jul 2008
Posts: 3
Default Re: Complete lock-up after startx

Happiness!!

I got a new monitor and I decided to try again and it works!

I don't know if it's the new monitor or the hard work of the Nvidia/linux kernel people.

Thanks to anybody who read this over the years.

Lyle.
lyle is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 05:12 AM
Daily Deal - Spore Complete and Darkspore, 75% off! News Gaming Headlines 0 06-13-12 06:30 PM
Daily Deal - Far Cry Complete, 75% off! News Gaming Headlines 0 06-06-12 01:50 PM
RH7.3 + nForce 420-D + startx = FROZEN ctaggart NVIDIA Linux 7 10-04-02 01:48 AM
Undefined Device Error - Can't startx linuxdave NVIDIA Linux 2 08-07-02 03:28 PM

All times are GMT -5. The time now is 10:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.