Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-17-03, 07:26 PM   #1
schbond
Registered User
 
Join Date: Sep 2003
Posts: 5
Default nvidia drivers in Gentoo

I have successfully installed the nvidia drivers before with other distros, but I am having trouble this time around with Gentoo.

My working XF86Config (relevant) is:
-------------------------
Load "glx"

# without the nvidia drivers, X tends to "shift" display to the right. this adjusts for that.
ModeLine "1024x768" 94.50 1024 1088 1184 1376 768 769 772 808 +hsync +vsync

Identifier "nVIDIA GeForce4 Ti4400"
Driver "nv"
#VideoRam 131072
# Insert Clocks lines here if appropriate
-------------------------

I have kernel sources/headers installed. I install drivers successfully. Edit XF86Config to nvidia's readme specs. Logout, startx, and my screen is blank. I let it sit for 20 minutes becuase nvidia claims it sometimes takes a while, but nothing....

Here is my edited (non-working) XF86Config (relevant) file:
-----------------
Identifier "nVIDIA GeForce4 Ti4400"
Driver "nvidia"
#VideoRam 131072
# Insert Clocks lines here if appropriate
Option "NoLogo" "true"
Option "NvAGP" "1"

# I read on another forum that adding the following line sometimes solves my problem, which it didn't:
Option "IgnoreDisplayDevices" "DFP,TV"
------------------------

/var/log/XFree86.0.log shows these errors (with non-working xf86config):

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(EE) NVIDIA(0): Failed to obtain a shared memory identifier.
(WW) NVIDIA(0): Failed to verify AGP usage

My system info:
chip: NVIDIA GeForce4 Ti4400
driver: NVIDIA-Linux-x86-1.0-4496-pkg2.run
distro: Gentoo 1.4

video bios:
# cat /proc/driver/nvidia/cards/0
Model: GeForce4 Ti 4400
IRQ: 11
Video BIOS: ??.??.??.??.??
Card Type: AGP

CPU: AMD Athlon Thunderbird 1.33 GHz
motherboard: Soyo SY-K7V Dragon Plus!

thanks in advance
schbond is offline   Reply With Quote
Old 09-18-03, 02:29 AM   #2
Pwipwi
Registered User
 
Join Date: Sep 2003
Posts: 15
Default

Try with Option "NvAGP" "0"
Pwipwi is offline   Reply With Quote
Old 09-18-03, 06:50 AM   #3
schbond
Registered User
 
Join Date: Sep 2003
Posts: 5
Default

I tried with Option "NvAGP" "0" and the screen still stays blank -- once again I left it for several minutes.

This did resolve the "Failed to verify AGP usage," in XFree86.0.log of course. However, in the end, I'd like to use AGP. For now, we can just get the nvidia driver working.

I still see:
"(EE) NVIDIA(0): Failed to obtain a shared memory identifier"

Also, how do I enable APM for XFree?
"(WW) Open APM failed (/dev/apm_bios) (No such file or directory)". I have APM enabled BIOS and kernel. Thanks.
schbond is offline   Reply With Quote
Old 09-18-03, 07:38 AM   #4
Pwipwi
Registered User
 
Join Date: Sep 2003
Posts: 15
Default

You'll automatically use AGPGART if you have it compiled. The NvAGP is the AGP driver by nvidia, which you disabled. That's all

For your other problem, well, I don't know :[
Pwipwi is offline   Reply With Quote
Old 09-18-03, 09:14 AM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Make sure your kernel and XFree86 were built with CONFIG_SYSVIPC and HAVE_SYSV_IPC respectively.
zander is offline   Reply With Quote
Old 09-18-03, 12:50 PM   #6
schbond
Registered User
 
Join Date: Sep 2003
Posts: 5
Default

Quote:
Make sure your kernel and XFree86 were built with CONFIG_SYSVIPC and HAVE_SYSV_IPC respectively.
AHA! Zander, I did not have CONFIG_SYSVIPC in my kernel, but I will recompile ASAP. How do I check if XFree86 uses HAVE_SYSV_IPC? Should I add this flag to Gentoo's make.conf file and recompile XFree86?
schbond is offline   Reply With Quote
Old 09-18-03, 01:33 PM   #7
schbond
Registered User
 
Join Date: Sep 2003
Posts: 5
Default got it!

well zander, thank you! I compiled CONFIG_SYSVIPC into my kernel and the nvidia drivers work now! Thanks to all who posted!
schbond is offline   Reply With Quote
Old 09-18-03, 02:57 PM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

You're welcome.
zander is offline   Reply With Quote

Old 10-21-03, 11:00 AM   #9
Infernall
Registered User
 
Join Date: Oct 2003
Posts: 6
Default

Gentoo?
su to root and emerge the packages.

Code:
emerge nvidia-kernel
Code:
emerge nvidia-glx
Code:
opengl-update nvidia
that will take care of the drivers. Just make sure Xfree is using nvidia, and not nv.
Infernall is offline   Reply With Quote
Old 10-22-03, 09:56 PM   #10
patrik1982
Registered User
 
Join Date: Oct 2003
Posts: 1
Default Re: got it!

Quote:
Originally posted by schbond
I compiled CONFIG_SYSVIPC into my kernel and the nvidia drivers work now!
How do I "compile CONFIG_SYSVIPC into my kernel"??

(Yes, I'm a newbie...)
patrik1982 is offline   Reply With Quote
Old 10-24-03, 08:21 AM   #11
p0lden
Registered User
 
Join Date: Oct 2003
Posts: 1
Default

Quote:
Originally posted by zander
Make sure your kernel and XFree86 were built with CONFIG_SYSVIPC and HAVE_SYSV_IPC respectively.
Just how do i build XFree with HAVE_SYSV_IPC?
p0lden is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 06:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.