Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-25-03, 03:53 AM   #1
Liontooth
GeForce4 420 Go 32M
 
Join Date: May 2003
Posts: 17
Question camcoder through s-video

I'm trying to set up my camcorder to record screen events. I've succeeded in getting the camcorder to display the screen --
it will even do it at a 1024x768 resolution, or more crisply at 800x600. Kind of weird to run your computer through your cam.
So far I've lost my normal screen to get the camcorder to display.

What I need, though, is to have my usual screen and the camcorder at the same time, in mirror mode. My question is, can I
do that with xinerama or do I have to use twin view?

If anyone has done this, I'd appreciate a copy of their XFree config file.

Cheers,
David
Liontooth is offline   Reply With Quote
Old 10-25-03, 04:12 AM   #2
Liontooth
GeForce4 420 Go 32M
 
Join Date: May 2003
Posts: 17
Default Followup: hard freeze

This configuration gives me a hard freeze every time -- the nVidia logo displays on the main (laptop) screen, and then the fan starts going crazy:

Section "ServerLayout"
Identifier "Layout[0]"
Screen 0 "Screen[0]"
Screen 1 "Screen[1]" LeftOf "Screen[0]"
InputDevice "Default Keyboard"
InputDevice "Mouse[0]" "AlwaysCore"
InputDevice "Mouse[1]" "CorePointer"
EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection

Section "Files"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/75dpi"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "dbe"
Load "glx"
Load "extmod"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Default Keyboard"
Driver "keyboard"
Option "CustomKeyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse[0]"
Driver "mouse"
Option "Name" "ALPS GlidePad"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Name" "USB wheel mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
Option "SendCoreEvents" "yes"
EndSection

Section "Device"
Identifier "nVidia[0]"
Driver "nvidia"
BoardName "NV17 GeForce4 420 Go 32M"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "nVidia[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x854" "1080x720" "1024x768" "800x600" "720x480" "640x480"
EndSubSection
EndSection

Section "Monitor"
Identifier "Monitor[0]"
Option "UseEdidFreqs"
ModeLine "1280x854" 85.3 1280 1296 1552 1792 854 854 861 892 -hsync -vsync
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia[1]"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Monitor"
Identifier "Monitor[1]"
Option "HorizSync" "30-60"
Option "VertRefresh" "60"
Option "TV" "yes"
Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "SVIDEO"
Option "TVOverScan" "1.0"
EndSection

Section "Screen"
Identifier "Screen[1]"
Device "nVidia[1]"
Monitor "Monitor[1]"

DefaultDepth 24
Subsection "Display"
Depth 8
Modes "1080x720" "1024x768" "800x600" "720x480" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1080x720" "1024x768" "800x600" "720x480" "640x480"
EndSubsection

SubSection "Display"
Depth 24
Modes "1080x720" "1024x768" "800x600" "720x480" "640x480"
EndSubSection
EndSection

Here how it stalls -- it tries to get both monitors going under nvidia(0) first (big mistake), and then it fails half way into nvidia(1):

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "On"
(**) NVIDIA(0): Option "UseEdidFreqs"
(--) NVIDIA(0): Linear framebuffer at 0xEC000000
(--) NVIDIA(0): MMIO registers at 0xE9000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce4 420 Go 32M
(--) NVIDIA(0): VideoBIOS: 04.17.00.57.66
(--) NVIDIA(0): VideoRAM: 32768 kBytes
(II) NVIDIA(0): Connected display device(s): DFP-0, TV-0
(--) NVIDIA(0): Detected TV Encoder: NVIDIA
(--) NVIDIA(0): Display device TV-0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display device TV-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device TV-0: maximum pixel clock at 32 bpp: 350 MHz
(--) NVIDIA(0): Display device DFP-0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display device DFP-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device DFP-0: maximum pixel clock at 32 bpp: 350 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(WW) NVIDIA(0): Failure reading EDID parameters for display device TV-0
(WW) NVIDIA(0): Unable to use EDID frequencies for display device TV-0 (no
(WW) NVIDIA(0): EDID found)
(WW) NVIDIA(0): Monitor[0]: Using default hsync range of 28.00-33.00kHz
(WW) NVIDIA(0): Monitor[0]: using default vrefresh range of 43.00-72.00Hz
(II) NVIDIA(0): Clock range: 12.00 to 350.00 MHz
(**) NVIDIA(0): Validated modes for display device TV-0:
(**) NVIDIA(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NVIDIA(0): Monitor[0]: Using hsync range of 29.00-48.00 kHz
(II) NVIDIA(0): Monitor[0]: Using vrefresh range of 0.00-60.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 350.00 MHz
(**) NVIDIA(0): Validated modes for display device DFP-0:
(**) NVIDIA(0): Mode "1280x854": 85.3 MHz, 47.6 kHz, 53.4 Hz
(**) NVIDIA(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(**) NVIDIA(0): Default mode "512x384": 32.5 MHz, 48.4 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 18.0 MHz, 35.2 kHz, 56.3 Hz (D)
(**) NVIDIA(0): Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(WW) NVIDIA(0): Unable to find mode "1280x854" for display device 0 in
(WW) NVIDIA(0): MetaMode "1280x854"
(II) NVIDIA(0): Attempting to find the next largest mode for Display 0 for
(II) NVIDIA(0): mode "1280x854"
(II) NVIDIA(0): Found mode "640x480" for display device 0 to use instead of
(II) NVIDIA(0): mode "1280x854"
(WW) NVIDIA(0): Unable to find mode "1080x720" for display device 0 in
(WW) NVIDIA(0): MetaMode "1080x720"
(WW) NVIDIA(0): Unable to find mode "1080x720" for display device 1 in
(WW) NVIDIA(0): MetaMode "1080x720"
(WW) NVIDIA(0): Unable to find mode "1024x768" for display device 0 in
(WW) NVIDIA(0): MetaMode "1024x768"
(II) NVIDIA(0): Attempting to find the next largest mode for Display 0 for
(II) NVIDIA(0): mode "1024x768"
(II) NVIDIA(0): Found mode "640x480" for display device 0 to use instead of
(II) NVIDIA(0): mode "1024x768"
(WW) NVIDIA(0): Unable to find mode "800x600" for display device 0 in MetaMode
(WW) NVIDIA(0): "800x600"
(II) NVIDIA(0): Attempting to find the next largest mode for Display 0 for
(II) NVIDIA(0): mode "800x600"
(II) NVIDIA(0): Found mode "640x480" for display device 0 to use instead of
(II) NVIDIA(0): mode "800x600"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 854
(++) NVIDIA(0): DPI set to (100, 100)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Reloading /usr/X11R6/lib/modules/libvgahw.a
(**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(1): RGB weight 888
(==) NVIDIA(1): Default visual is TrueColor
(==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(1): Option "NoLogo" "On"
(**) NVIDIA(1): Option "TVStandard" "NTSC-M"
(**) NVIDIA(1): Option "TVOutFormat" "SVIDEO"
(**) NVIDIA(1): Option "TVOverScan" "1.0"
(**) NVIDIA(1): Forcing SVIDEO output
(**) NVIDIA(1): TV Standard string: "NTSC-M"
(--) NVIDIA(1): Linear framebuffer at 0xEC000000
(--) NVIDIA(1): MMIO registers at 0xE9000000
Liontooth is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 05:40 PM
Video: HPC Analyst Crossfire from ISC'12 News Archived News Items 0 06-23-12 12:00 AM
NVIDIA's Exclusive 3D Video with Doggfather of Hip-Hop News Archived News Items 0 06-13-12 06:30 PM
Video: The Golden Age of Supercomputing News Archived News Items 0 05-27-12 03:00 PM
Best video card for running dual displays? nutsnbolts NVIDIA GeForce 7, 8, And 9 Series 10 09-03-02 02:02 PM

All times are GMT -5. The time now is 03:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.