Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-21-10, 03:57 PM   #1
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default 195.36.15 weird MSI behaviour

Hello,

I have done quite interesting experiment:
I usually have #options nvidia NVreg_EnableMSI=1 commented out in /etc/modprobe.d/options.conf because it freezes Linux permanently in a short time.

Today I loaded nvidia as usual without MSI. Then I exited X, rmmod nvidia, uncommented EnableMSI in options.conf. Then loaded X again. In /proc/interrupts I see nvidia uses MSI. The older irq nvidia module used before is empty, it is listed on interrupts list but with empty name. Nvidia module is present on MSI interrupt.
xrender tests passed oK and glxgears too. Only VDPAU and Xv refused to work - mplayer hangs.

Then I rebooted PC. Nvidia jumped in to MSI. This time there is no empty remaining place where nvidia usually loads. X become frozen right after loading KDE4. I was unable to move mouse cursor.

Summary:
If nvidia loads as MSI only it freezes machine.
If nvidia loads as default, then removed and loaded as MSI it works except Xv and VDPAU because after removal something with empty name is still registered at IRQ nvidia was using before.

According to findings on the Internet only Geforce 8200 can not work in MSI mode. All recent add on Geforces work great in MSI mode.
Can you please fix MSI for Geforce 8200?
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.6 KB, 105 views)
zbiggy is offline   Reply With Quote
Old 03-21-10, 06:13 PM   #2
Milena
Registered User
 
Join Date: Mar 2009
Posts: 36
Default Re: 195.36.15 weird MSI behaviour

Hi

Just a quick question about MSI,

if it doesn't cause trouble is it recommend to make use of it and if so how do i enable it properly ?
There is no /etc/modprobe.d/options.conf on my Fedora 12 installation. Creating this file with the entry
Code:
options nvidia NVreg_EnableMSI=1
is all i have to do ? I asked about this recently on my distributions forum > http://forums.fedoraforum.org/showthread.php?t=242523

Best Regards
Milena is offline   Reply With Quote
Old 03-21-10, 06:25 PM   #3
Milena
Registered User
 
Join Date: Mar 2009
Posts: 36
Default Re: 195.36.15 weird MSI behaviour

Well I just added an options.conf file and it seems to work as intended.

before:

Code:
          CPU0       CPU1       CPU2       CPU3       
 17:          5          4          0         52   IO-APIC-fasteoi   firewire_ohci
 19:          0          0     188043        857   IO-APIC-fasteoi   nvidia
 20:      51279      23962          1         59   IO-APIC-fasteoi   ohci_hcd:usb3
 23:          0          0          0          0   IO-APIC-fasteoi   ohci_hcd:usb4
 27:          1      27922      14110       6741   PCI-MSI-edge      ahci
 28:      23770     106265          2        135   PCI-MSI-edge      eth0
after:

Code:
bash-4.0$ cat /proc/interrupts
           CPU0       CPU1       CPU2       CPU3       
 17:          0          0          0         10   IO-APIC-fasteoi   firewire_ohci
 20:          0          1          1      16930   IO-APIC-fasteoi   ohci_hcd:usb3
 21:          1        406       2379       3638   IO-APIC-fasteoi   ehci_hcd:usb2, HDA Intel
 22:          0          0          0          4   IO-APIC-fasteoi   ehci_hcd:usb1
 23:          0          0          0          0   IO-APIC-fasteoi   ohci_hcd:usb4
 27:          1      10205         16       7515   PCI-MSI-edge      ahci
 28:       5432          0          3        154   PCI-MSI-edge      eth0
 29:          0          2      24344      10982   PCI-MSI-edge      nvidia
NMI:          0          0          0          0   Non-maskable interrupts
Compiz, XV, VDPAU work without problems so far and no X crash but it's a GTX275 here.
Milena is offline   Reply With Quote
Old 03-22-10, 06:29 PM   #4
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 195.36.15 weird MSI behaviour

Yes you are using MSI now.

I would love to use MSI too. But I can't - MSI on Geforce 8200 hangs terribly. System is so frozen that only hard reset can help. After freeze and reboot the disk may become corrupted. It happened to me after few seconds of X use. That is why I do not test MSI often. Just hope from time to time Nvidia will fix this - integrated GPUs are a little bit different than addon GPUs.

MSI is working great for me in SATA, Eth and integrated audio driver.
You can move your HDA Intel audio which is shared on INT 21 according to your logs also to MSI. This way you will avoid IRQ sharing which may make some troubles under load and improve overall performance a little bit.


Code:
options snd_hda_intel enable_msi=1
zbiggy is offline   Reply With Quote
Old 03-22-10, 06:47 PM   #5
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 195.36.15 weird MSI behaviour

Quote:
Originally Posted by Milena View Post
Just a quick question about MSI,
if it doesn't cause trouble is it recommend to make use of it and if so how do i enable it properly ?
There is no /etc/modprobe.d/options.conf on my Fedora 12 installation. Creating this file with the entry
Code:
options nvidia NVreg_EnableMSI=1
is all i have to do ? I asked about this recently on my distributions forum > http://forums.fedoraforum.org/showthread.php?t=242523

Best Regards
The answer to all question is yes. Moving devices to MSI frees APIC or PIC interrupts. This way you can avoid IRQ sharing and can connect more devices. More advantages here:
http://en.wikipedia.org/wiki/Message...led_Interrupts

My Geforce 8200 (MCP78S) is treated very badly by Nvidia:
- enabling MSI for integrated GPU freezes my computer
- USB 1.1 OHCI hangs in APIC mode since I bought this mainboard.
Nvidia says they quit chipset business. After ongoing chipset success since year 2000 the last one is so crappy. How I can recommend their hardware seeing how crappy it is.
I hope they do something with these 2 ugly bugs.
zbiggy is offline   Reply With Quote
Old 03-22-10, 07:10 PM   #6
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 195.36.15 weird MSI behaviour

You can list all devices on your system with MSI capability:
(execute this command as root or use sudo in ubuntu like systems):
Code:
lspci -vvv | grep 'Message Signalled Interrupts'
The result will be like this:
Code:
        Capabilities: [b0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/3 Enable+
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
        Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Enable+ means MSI is enabled and in use
Enable- means MSI is disabled and can be enabled (if driver supports MSI) in options.conf for example.

As you see I use MSI for everything except Geforce 8200.
zbiggy is offline   Reply With Quote
Old 03-22-10, 09:14 PM   #7
Milena
Registered User
 
Join Date: Mar 2009
Posts: 36
Default Re: 195.36.15 weird MSI behaviour

Thank you zbiggy for the info

The command lspci -vvv | grep 'Message Signalled Interrupts' gives no output at all on Fedora 12, not as user nor root. Also thanks for the hint with snd_hda_intel but its the onboard soundchip of my ASUS M4N82 (Nvidia chipset) and it stays in IO-APIC-fasteoi mode regardless what setting, i tried to add it to options.conf as well as boot option for the kernel. My GTX275 card works fine with MSI and very stable, i hope Nvidia will fix the issue for older models soon.

Best Regards
Milena is offline   Reply With Quote
Old 03-23-10, 04:25 AM   #8
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 195.36.15 weird MSI behaviour

Quote:
Originally Posted by Milena View Post
Thank you zbiggy for the info

The command lspci -vvv | grep 'Message Signalled Interrupts' gives no output at all on Fedora 12, not as user nor root.
Strange. I tried this on RedHat EL 5.4 and works on root. Indeed when I tried as normal user it returned 'command not found'. Will try on Fedora when come back home. Maybe you do not have lspci command installed.

Quote:
Originally Posted by Milena View Post
Also thanks for the hint with snd_hda_intel but its the onboard soundchip of my ASUS M4N82 (Nvidia chipset) and it stays in IO-APIC-fasteoi mode regardless what setting, i tried to add it to options.conf as well as boot option for the kernel. My GTX275 card works fine with MSI and very stable, i hope Nvidia will fix the issue for older models soon.
snd_hda_intel is only driver name common for IHDA itegrated audio in new chipsets from Nvidia/AMD/Intel. I have AMD CPU and mainboard and use snd_hda_intel. Do
Code:
lsmod | grep snd_
and send me the output. Maybe you use AC97 instead of IHDA.

MSI for snd_hda_intel driver is present since alsa 1.0.13 if your alsa is older you do not have MSI support yet.
zbiggy is offline   Reply With Quote

Old 03-23-10, 08:52 PM   #9
Milena
Registered User
 
Join Date: Mar 2009
Posts: 36
Default Re: 195.36.15 weird MSI behaviour

Well the output of lsmod | grep snd_ is:

Code:
bash-4.0$ lsmod | grep snd_
snd_hda_codec_realtek   279457  1 
snd_hda_intel          23712  2 
snd_hda_codec          71956  2 snd_hda_codec_realtek,snd_hda_intel
snd_seq                52773  0 
snd_usb_audio          85310  1 
snd_usb_lib            16364  1 snd_usb_audio
snd_pcm                78375  3 snd_hda_intel,snd_hda_codec,snd_usb_audio
snd_rawmidi            20374  1 snd_usb_lib
snd_seq_device          6151  2 snd_seq,snd_rawmidi
snd_hwdep               6446  2 snd_hda_codec,snd_usb_audio
snd_timer              19840  2 snd_seq,snd_pcm
snd                    62376  17 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_seq,snd_usb_audio,snd_usb_lib,snd_pcm,snd_rawmidi,snd_seq_device,snd_hwdep,snd_timer
snd_page_alloc          7389  2 snd_hda_intel,snd_pcm
It is the snd_hda_intel module, a few kernels ago i had to pass snd_hda_intel.powersave=0 to the grub kernel options to avoid crackling sounds and that worked too. I will try again to set it up for MSI.
Milena is offline   Reply With Quote
Old 03-25-10, 03:06 AM   #10
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default Re: 195.36.15 weird MSI behaviour

Thanks for bringing the NVreg_EnableMSI option to my attention. I was struggling with SATA timeout/exception issues on my M1330 equipped with a GeForce 8400M GS from the beginning.I tried all recipes I found so far but none worked. Since this option was activated in /etc/modprobe.d/options no more timeouts were encountered (with driver 195.36.15). There seem to be quite a number of people facing this problem. For those having NVIDIA graphics cards a hint on this option in the driver README to enable MSI would perhaps be helpful.
stecklum is offline   Reply With Quote
Old 03-25-10, 06:00 AM   #11
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 195.36.15 weird MSI behaviour

I hope in future Nvidia driver releases I will also be able to use MSI on my Geforce 8200. I hope this may fix or make less frequent my OHCI usb 1.1 timeouts/hangs/crashes. I'm glad I could help you.
zbiggy is offline   Reply With Quote
Old 04-15-10, 02:09 PM   #12
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default Re: 195.36.15 weird MSI behaviour

Again, I was too hastily with my conclusion. The timeouts are not gone but less frequent (still an improvement). Further googling brought this to my attention which keeps my hope alive that sometime soon the problem will be solved

LKML: Linus Torvalds: Re: [git patches] libata updates for 2.6.34
http://lkml.org/lkml/2010/3/9/345
stecklum is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:58 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.