Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-18-10, 02:48 PM   #1
crash2393
Registered User
 
Join Date: Jan 2009
Posts: 4
Default can't build kernel module with 195.36.15 + 2.6.33

kernel built debian way, with realtime patches applied.

log output in attachment.

190.53+2.6.32 worked like a charm with same kernel configuration.

i appreciate all suggestions, thanks in advance
Attached Files
File Type: log nvidia-installer.log (26.8 KB, 115 views)
crash2393 is offline   Reply With Quote
Old 03-18-10, 06:51 PM   #2
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: can't build kernel module with 195.36.15 + 2.6.33

Is the kernel source in /usr/src/linux the source of your currently running kernel?

Is the .config file in that directory the .config for your currently running kernel?

Last edited by danix; 03-18-10 at 06:52 PM. Reason: edit for clarity
danix is offline   Reply With Quote
Old 03-18-10, 07:18 PM   #3
crash2393
Registered User
 
Join Date: Jan 2009
Posts: 4
Default Re: can't build kernel module with 195.36.15 + 2.6.33

1. yes

2. i'm not exactly shure what you mean, before compilation i've copied .config from /boot/ as i always did to source directory (in my case /usr/src/linux-2.6.33), patching and compiliation went fine, no errors etc.

i'm not a linux guru, but i compile almost any new kernel, hoping that it will finally support suspension for my notebook. i use debian, so i reinstall nvidia drivers manually every time after updating kernel and i never had any issues with installation of drivers, that is the reason i ask here for help. btw thanks for reply

Last edited by crash2393; 03-18-10 at 07:22 PM. Reason: typos
crash2393 is offline   Reply With Quote
Old 03-19-10, 03:39 PM   #4
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: can't build kernel module with 195.36.15 + 2.6.33

If you copied your .config from an older kernel, you should run "make oldconfig" first before building a newer one.

It will keep all options from your old .config that still apply, and will ask you how you want to configure any new options that were introduced with the new kernel revision. As long as you're not looking to enable a particular new feature, it's generally safe to accept all of the defaults.
danix is offline   Reply With Quote
Old 03-27-10, 06:36 PM   #5
crash2393
Registered User
 
Join Date: Jan 2009
Posts: 4
Default Re: can't build kernel module with 195.36.15 + 2.6.33

okay i've found a solution

i had to patch nv-linux.h with slightly modified file found in this thread:

http://www.nvnews.net/vbulletin/showthread.php?t=148509

i've just edited first lines of file, with directory paths proper for my nvidia installer directory.
driver is up and running without any problems so far.

kernel configuration had nothing to do with it, but anyway thanks for suggestions.
crash2393 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.