Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-27-10, 09:34 PM   #1
fataliste
Registered User
 
Join Date: Mar 2010
Posts: 5
Default GeForce 7900 GS / 195.36.15 / 2.6.34-rc2: X crash w/ signal 11

When I try to configure X, using sax2 -r -m 0=nvidia, the nvidia module loads
and no fatal errors appear in Xorg.0.log. But the server immediately
dies. There is clearly some communication with the card: the fan is turned on
at full speed, and the screen briefly flashes, before going to black. Finally
sax2 exits and the system is again responsive.

There are two monitors attached to the 7900 GS, and trying to configure
Xinerama fails in the same way.

The card functions fine using the "nv" module on one monitor, but of course
without any 3D acceleration or Xinerama which I would very much like to have.

I also have a Quadro FX 1500 too, and 195.36.15 fails to work with this card
installed in place of the 7900 GS.

Both of these cards worked well with older kernels and (I suppose) older
versions of the nvidia drivers. I've installed them in a new system. Are older
versions of the nvidia drivers available for download?

I've attached the bug report with the 7900 GS installed.
Attached Files
File Type: gz nvidia-bug-report.log.gz (52.7 KB, 73 views)

Last edited by fataliste; 03-27-10 at 09:39 PM. Reason: fix line length
fataliste is offline   Reply With Quote
Old 03-28-10, 01:05 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: GeForce 7900 GS / 195.36.15 / 2.6.34-rc2: X crash w/ signal 11

It looks like something is corrupting the data on the way to the GPU, triggering error recovery. However, there's a bug in the error recovery if it happens during X server startup, which causes the X server to crash. Does the problem happen with older drivers? Also, would it be possible to try it with an older, non -rc kernel?
AaronP is offline   Reply With Quote
Old 03-28-10, 02:20 AM   #3
fataliste
Registered User
 
Join Date: Mar 2010
Posts: 5
Default Re: GeForce 7900 GS / 195.36.15 / 2.6.34-rc2: X crash w/ signal 11

Thanks for your quick reply! The problem did not occur on
my former system, which was running opensuse 11.2 if I
remember correctly, and possibly an older version of the
nvidia driver. But I've installed a new mainboard and had to
re-install the OS, so I can't say for sure what version of
the driver was working. And it's completely new hardware,
of course.

I can easily revert to the stock opensuse 11.2 kernel, I
installed the -rc in the hope it would fix that problem and
a problem with the onboard broadcom ethernet. I'll
post that bug report, too, in case the stack traceback
reveals more information. I'm willing to try older drivers
too, if I can find where to download them.
fataliste is offline   Reply With Quote
Old 03-28-10, 04:05 AM   #4
fataliste
Registered User
 
Join Date: Mar 2010
Posts: 5
Default Re: GeForce 7900 GS / 195.36.15 / 2.6.34-rc2: X crash w/ signal 11

Bug report running kernel 2.6.31.12-0.2-desktop with the nvidia 195.36.15 driver:
Attached Files
File Type: gz nvidia-bug-report.log.gz (45.5 KB, 65 views)
fataliste is offline   Reply With Quote
Old 03-28-10, 04:51 AM   #5
fataliste
Registered User
 
Join Date: Mar 2010
Posts: 5
Default Re: GeForce 7900 GS / 195.36.15 / 2.6.34-rc2: X crash w/ signal 11

I found, judging by the version number - 173.14.25 - a very old version of the nvidia driver and installed it under the stock opensuse 11.2 kernel: 2.6.31.12-0.2-desktop. Running sax2 -r -m 0=nvidia still fails to work, probably not surprisingly since this is a very old version. But the failure is quite different. X doesn't crash. Instead, a screen is opened, but with corrupted data. The mouse and keyboard are responsive, and the mouse cursor has a perfect image. One can terminate X using the keyboard.

Bug report:
Attached Files
File Type: gz nvidia-bug-report.log.gz (45.0 KB, 60 views)
fataliste is offline   Reply With Quote
Old 03-28-10, 05:27 AM   #6
fataliste
Registered User
 
Join Date: Mar 2010
Posts: 5
Angry Re: GeForce 7900 GS / 195.36.15 / 2.6.34-rc2: X crash w/ signal 11

I tried also 185.18.31 which is available in the archives in x86_64 version. The behaviour is similar to that of 173.14.25.
Attached Files
File Type: gz nvidia-bug-report.log.gz (39.3 KB, 60 views)
fataliste is offline   Reply With Quote
Old 03-28-10, 06:45 PM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: GeForce 7900 GS / 195.36.15 / 2.6.34-rc2: X crash w/ signal 11

Hmm, okay. The behavior you're seeing with older drivers also sounds like data is getting corrupted between the CPU and the GPU, so I'll bet they're symptoms of the same problem. It would probably be worth checking your motherboard vendor's web site to see if an updated system BIOS is available. Also, you could try poking around in the BIOS configuration menu to see if anything is set incorrectly. Opening it up and choosing the "reset system defaults" option would be a good place to start.

If you still can't get it to work, I'd suggest contacting your motherboard vendor for support, since it fails with two different graphics cards in the same way.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:22 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.