Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-27-10, 03:55 AM   #13
hermier
Registered User
 
Join Date: Dec 2005
Posts: 26
Default Re: How to enable composite in Fedora/KDE

After some investigation it seems that xorg-server, is not the direct culprit. It seems that rebuilding 1.7.5 on current system make it also fails. So it might be related to one header that may affect the way xorg-server works.
If I look the chain of changes since xorg-server-1.7.5 on my distro, the only things that may affect the build are dri2proto-2.3, libdrm-2.4.1{7,8}, libxt-1.0.8.
Any thought on this ? (My best guess for now is the dri2proto changes without prouf)
hermier is offline   Reply With Quote
Old 03-28-10, 03:28 PM   #14
hermier
Registered User
 
Join Date: Dec 2005
Posts: 26
Default Re: How to enable composite in Fedora/KDE

I finally found a partial solution. It seems that xorg server is lacking some space to register all the events. The attached patch should help, but is incomplete because I think we should add some log message just in case we fall down in the same situation (took me 3 days to understand the base source of the problem), and therefore I did not submitted to xorg-server yet.
But now I am facing another problem, composition works again, but all the contents are rendered void/empty/translucent. And I was wondering if it was nvidia driver not understanding damage/composing latest protocols versions, or at least checking them to strictly ? Can nvidia devel confirm ?
Attached Files
File Type: txt extension.diff.txt (331 Bytes, 85 views)
hermier is offline   Reply With Quote
Old 03-28-10, 07:53 PM   #15
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: How to enable composite in Fedora/KDE

Ah yes, this problem. You can't just increase the extension event limit like that, because events above 127 will be handled incorrectly. Your best bet is to disable an extension you don't use, such as DRI2 or XFree86-DGA.

I thought there was a thread about this on the xorg-devel@lists.x.org mailing list, but I can't find it. I'll bring it up there again.
AaronP is offline   Reply With Quote
Old 03-29-10, 03:28 AM   #16
hermier
Registered User
 
Join Date: Dec 2005
Posts: 26
Default Re: How to enable composite in Fedora/KDE

Then is it possible to make nvidia-xconfig disable such extensions ? The user was troubled to not have a working configuration after running it.
hermier is offline   Reply With Quote
Old 03-29-10, 01:42 PM   #17
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: How to enable composite in Fedora/KDE

I'd like to reach a consensus with the rest of the X community before we go and change nvidia-xconfig.

I thought it was related to a specific version of the X server, but it looks like the number of events used by DRI2 is actually controlled by the dri2proto package. If your X server was compiled with dri2proto-2.1 or older, then the DRI2 extension will not use any events. The difference between xorg-server 1.7.5 and 1.7.6 for you is probably which version of the dri2proto package your distribution used.

It looks like the xserver 1.7 branch doesn't actually support the DRI2 events, so you (or your distro) should be able to safely rebuild the server against dri2proto-2.1.

You can follow the discussion here: http://lists.x.org/archives/xorg-dev...ch/006716.html
AaronP is offline   Reply With Quote
Old 03-29-10, 06:49 PM   #18
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: How to enable composite in Fedora/KDE

Julian Cristau pointed out that the Generic Events extension itself registers an extension event that isn't actually used. Could you please give this patch a try? http://people.freedesktop.org/~jcris...on-events.diff
AaronP is offline   Reply With Quote
Old 03-30-10, 06:00 AM   #19
hermier
Registered User
 
Join Date: Dec 2005
Posts: 26
Default Re: How to enable composite in Fedora/KDE

Will test the diff as soon as the user is available. But since we are a rolling distro we plan to go to xorg-server 1.8 few days after it is available, so reverting dri2proto is a no go (unless a more serious issue is found).
Since you are in touch with the xorg guys could you ask them to add a warning/debug message in AddExtension when no more X events are available (http://cgit.freedesktop.org/xorg/xse...ix/extension.c line 87). Since it is a runtime limitation, and that some/most builtin extensions are expected to register cleanly (and therefore don't warn when they fails to register, ex damage), it was hard to understand/guess the problem source (I lost 4 days for that)
hermier is offline   Reply With Quote
Old 03-30-10, 10:43 AM   #20
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: How to enable composite in Fedora/KDE

Quote:
Originally Posted by hermier View Post
Will test the diff as soon as the user is available. But since we are a rolling distro we plan to go to xorg-server 1.8 few days after it is available, so reverting dri2proto is a no go (unless a more serious issue is found).
Since you are in touch with the xorg guys could you ask them to add a warning/debug message in AddExtension when no more X events are available (http://cgit.freedesktop.org/xorg/xse...ix/extension.c line 87). Since it is a runtime limitation, and that some/most builtin extensions are expected to register cleanly (and therefore don't warn when they fails to register, ex damage), it was hard to understand/guess the problem source (I lost 4 days for that)
Actually, there was a proposed patch on the mailing list to do just that: http://lists.x.org/archives/xorg-dev...ch/006174.html

It has yet to be merged into the server, but that ought to do what you suggest.

Out of curiosity, which extensions are failing to register for you? The other user who saw this problem was enabling the MULTI-BUFFER extension, which was putting it over the limit by exactly one event. In that case, fixing XGE to not register any events would fix the problem. I'm curious to know if your configuration is the same, or if it's some other extension that's putting it over the limit. There doesn't seem to be anything interesting in your xorg.conf file that would enable any unusual extensions.
AaronP is offline   Reply With Quote

Old 03-30-10, 11:39 AM   #21
hermier
Registered User
 
Join Date: Dec 2005
Posts: 26
Default Re: How to enable composite in Fedora/KDE

Quote:
Originally Posted by AaronP View Post
Actually, there was a proposed patch on the mailing list to do just that: http://lists.x.org/archives/xorg-dev...ch/006174.html

It has yet to be merged into the server, but that ought to do what you suggest.
Cool, I hope to see it soon, it may help user experience

Quote:
Out of curiosity, which extensions are failing to register for you? The other user who saw this problem was enabling the MULTI-BUFFER extension, which was putting it over the limit by exactly one event. In that case, fixing XGE to not register any events would fix the problem. I'm curious to know if your configuration is the same, or if it's some other extension that's putting it over the limit. There doesn't seem to be anything interesting in your xorg.conf file that would enable any unusual extensions.
Notice that I'm not the original reporter, but that doesn't matter since the faillure log is exactly the same (with a near blank xorg.conf).
In the log, you see that:
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE

DAMAGE does not register events, so obviously it started at COMPOSITE, since the user was complaining not being able to run compiz but I didn't checked randr.
hermier is offline   Reply With Quote
Old 03-30-10, 12:27 PM   #22
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: How to enable composite in Fedora/KDE

Okay, thanks. I guess in that case I'd need to see a log with that patch applied, since those extensions themselves shouldn't be near the limit.

What I'm trying to determine is whether I need to push to get DRI2 fixed to use XGE, or if just fixing XGE by itself to not register an event will be enough.
AaronP is offline   Reply With Quote
Old 03-30-10, 05:56 PM   #23
hermier
Registered User
 
Join Date: Dec 2005
Posts: 26
Default Re: How to enable composite in Fedora/KDE

Seems that it did the trick. Here are some logs made with an xorg.conf made of an empty module section. Will push that patch to frugalware-current for a wider test.
Attached Files
File Type: txt xdpyinfo.txt (22.9 KB, 60 views)
File Type: txt Xorg.0.log.txt (10.1 KB, 66 views)
hermier is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.