Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-10-10, 10:45 AM   #1
Eithel
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Tearing in all video with driver 195.36.15

Hi everyone!

I have a nvidia gt 240 card and in all video (using totem or mplayer) I have tearing problem.
I haven't compiz or compositing manager actives.
When I use vdpau with mplayer the tearing is worse.

How can I solve ?

I attach xorg and Xorg.0.log
Attached Files
File Type: gz nvidia-tearing.tar.gz (4.0 KB, 95 views)
Eithel is offline   Reply With Quote
Old 04-10-10, 11:01 AM   #2
P.Kosunen
Registered User
 
Join Date: Jan 2009
Posts: 57
Default Re: Tearing in all video with driver 195.36.15

Code:
Section "Extensions"
     Option         "Composite" "Disable"
EndSection
Add this to xorg.conf.
P.Kosunen is offline   Reply With Quote
Old 04-10-10, 11:34 AM   #3
Eithel
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Re: Tearing in all video with driver 195.36.15

ok now it works...

But if i want compositing manager actives and no tearing ?
(i don't use compiz, only metacity compositing manager)
Eithel is offline   Reply With Quote
Old 04-10-10, 01:57 PM   #4
Eithel
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Re: Tearing in all video with driver 195.36.15

I have made more tests...

if i add this :
Code:
Section "Extensions"
     Option         "Composite" "Disable"
EndSection
in xorg.conf, totem still have tearing but the problem is present on the upper part of monitor (mplayer is fine).

So i have removed Composite Option in Xorg and i have played some video.
Well, the problem is always present if video is on upper part of monitor (totem and mplayer).

If i enabled "compositing manager" in metacity problem is in all video (everywhere in the monitor).

Any ideas to solve the problem ?
Eithel is offline   Reply With Quote
Old 04-11-10, 07:28 AM   #5
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Tearing in all video with driver 195.36.15

Do not use metacity's compositing manager. It is a software-based solution unlike compiz. It kills video playback.
Compiz on the other hand can be configured to le video playback bypass it - when i used vdpau with compiz i had no tearing (also make sure in compiz that the "sync to vblank" option is selected). Without compiz (not installed) i had tearing that was solved only by disabling the compositing extension altogether.

If you use xv for output (totem, vlc etc), do the following:

launch gstreamer-properties either in a terminal or by pressing alt+f2. Go to the video tab and select the "x window system (x11/xshm/xv)" plugin and select device "nv17 video texture" and make sure in nvidia-settings that you have selected "sync to vblank" in "xserver xvideo" settings.

Bottom line: best video playback and performance is obtained with disabling the composite extension.
gradinaruvasile is offline   Reply With Quote
Old 04-11-10, 10:13 AM   #6
franzf
Registered User
 
Join Date: Dec 2007
Posts: 6
Default Re: Tearing in all video with driver 195.36.15

Same here
GT220, latest nvidia-drivers. Using KWin (kde-4.4.2), Compositing enabled.
In both KWin-configuration and nvidia-settings, VSync is enabled.
mplayer with vdpau shows tearing on the upper ~3cm of the video, same with vlc.
I tried several Video Outputs - all with tearing
franzf is offline   Reply With Quote
Old 04-11-10, 10:31 AM   #7
Eithel
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Re: Tearing in all video with driver 195.36.15

Using compiz (following gradinaruvasile's suggestions ) or without any effects video playback is ok only in video is not on upper part of monitor.

So the problem is: why does the tearing present only on upper part of monitor ?
Eithel is offline   Reply With Quote
Old 04-11-10, 12:51 PM   #8
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Tearing in all video with driver 195.36.15

I had the same tearing line (on all 3 computers i use), but it seems it is not related to the video's height, but to the total screen height - i had a wide screen movie that had no tearing, yet the others that were higher had the tearing line, almost in the same position.

Anyways, i solved it by disabling the xservers composite extension in xorg.conf.
It worked on all 3 computers - Nvidia 210, Nvidia 8200 IGP, Nvidia Quadro 135M cards running 195.36.15 driver on Debian Squeeze (Gnome). Note that i never installed Compiz on these Debian running boxes.
I tested vdpau with compiz a while back, using Ubuntu 9.04 and older drivers. I did not have the 210 card back then.
gradinaruvasile is offline   Reply With Quote

Old 04-12-10, 05:56 AM   #9
theDOC
Registered User
 
Join Date: Jan 2004
Posts: 21
Default Re: Tearing in all video with driver 195.36.15

The only way I got a tear free experience when in compiz was using xbmc. It can alter the video speed slightly, so that its framerate matches the refreshrate of the monitor.
theDOC is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.