Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-09-10, 09:53 PM   #1
kisielk
Registered User
 
Join Date: Apr 2010
Posts: 4
Default NVRM: failed to register with the ACPI subsystem!

When I try to launch /opt/cuda/sdk/C/bin/linux/release/deviceQuery
I get the following output:


/opt/cuda/sdk/C/bin/linux/release/deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).
There is no device supporting CUDA

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 4248659, CUDA Runtime Version = 0.0, NumDevs = 0
PASSED

Press <Enter> to Quit...



The errors from dmesg are:

NVRM: failed to register with the ACPI subsystem!
NVRM: RmInitAdapter failed! (0x12:0x2b:1718)
NVRM: rm_init_adapter(0) failed
NVRM: failed to unregister from the ACPI subsystem!



I can see the cards just fine in lspci, and the appropriate device nodes exist etc.

Please see the attachment for more details.
Attached Files
File Type: gz nvidia-bug-report.log.gz (17.3 KB, 80 views)
kisielk is offline   Reply With Quote
Old 04-10-10, 01:08 AM   #2
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: NVRM: failed to register with the ACPI subsystem!

root=/dev/nfs ip=dhcp nfsroot=10.2.128.56:/mnt/project/netboot/node3.0.0

Could have something to do with it....
Dizzle7677 is offline   Reply With Quote
Old 04-10-10, 03:54 AM   #3
kisielk
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Re: NVRM: failed to register with the ACPI subsystem!

Um, I think not. The machines are PXE booted and have an NFS-mounted root filesystem. I highly doubt this has anything to do with the video driver problem.
kisielk is offline   Reply With Quote
Old 04-11-10, 12:43 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: NVRM: failed to register with the ACPI subsystem!

The ACPI error message is unrelated to the problem that's preventing initialization of your GPU:
(...)
NVRM: RmInitAdapter failed! (0x12:0x2b:1718)
NVRM: rm_init_adapter(0) failed
(...)
It's unfortunate that deviceQuery only yields a cryptic error message in this case; I'll file a bug about that. If you had attempted to start X, it would have printed an error message of the form:
(EE) NVIDIA(0): The NVIDIA kernel module does not appear to
(EE) NVIDIA(0): be receiving interrupts generated by the NVIDIA graphics
(EE) NVIDIA(0): device PCI:x:x:x. Please see the COMMON PROBLEMS
(EE) NVIDIA(0): section in the README for additional information.
Please see http://us.download.nvidia.com/XFree8...nproblems.html.
zander is offline   Reply With Quote
Old 04-11-10, 12:50 PM   #5
kisielk
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Re: NVRM: failed to register with the ACPI subsystem!

Quote:
Originally Posted by zander View Post
The ACPI error message is unrelated to the problem that's preventing initialization of your GPU:
(...)
NVRM: RmInitAdapter failed! (0x12:0x2b:1718)
NVRM: rm_init_adapter(0) failed
(...)
It's unfortunate that deviceQuery only yields a cryptic error message in this case; I'll file a bug about that. If you had attempted to start X, it would have printed an error message of the form:
(EE) NVIDIA(0): The NVIDIA kernel module does not appear to
(EE) NVIDIA(0): be receiving interrupts generated by the NVIDIA graphics
(EE) NVIDIA(0): device PCI:x:x:x. Please see the COMMON PROBLEMS
(EE) NVIDIA(0): section in the README for additional information.
Please see http://us.download.nvidia.com/XFree8...nproblems.html.
Alright, I will try some more combinations of the options recommended there, but I am fairly sure I have tried most if not all.

The card in question is a Tesla S1070, so there's no X to be started here.
kisielk is offline   Reply With Quote
Old 04-12-10, 12:40 PM   #6
kisielk
Registered User
 
Join Date: Apr 2010
Posts: 4
Default Re: NVRM: failed to register with the ACPI subsystem!

I managed to resolve the problem by removing 'acpi=off' from the boot parameters. None of the workarounds in the linked FAQ are required once acpi is allowed to be on.
kisielk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:32 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.