Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-13-10, 11:57 PM   #1
leptogenesis
Registered User
 
Join Date: Apr 2010
Posts: 5
Default Your system is too SLOW to play this!

I'm starting a video using the following command:

mplayer -vo vdpau -vc ffh264vdpau <video name>.mp4

The Mplayer I'm using is the default ubuntu mplayer. The video is a 60fps, 1024x576 h264, with video bitrate around 675kbps--shouldn't be hard at all for mplayer+vdpau (though it doesn't even come close to working with the codec mplayer picks by default). The output I get is this:

Code:
MPlayer UNKNOWN-4.4.1 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing <video name>.mp4.
libavformat file format detected.
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
VIDEO:  [avc1]  1024x576  24bpp  59.940 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: ...
 author: ...
 comments: ...
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[pulse] working around probably broken pause functionality,
        see http://www.pulseaudio.org/ticket/440
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
VDec: vo config request - 1024 x 576 (preferred colorspace: H.264 VDPAU acceleration)
VDec: using H.264 VDPAU acceleration as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1024x576 => 1024x576 H.264 VDPAU acceleration 
A:  48.2 V:  47.7 A-V:  0.491 ct: -0.013   0/  0  0% 100%  0.4% 2313 0 

           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

A:  53.8 V:  53.3 A-V:  0.544 ct: -0.016   0/  0  0% 99%  0.4% 2636 0 
Exiting... (Quit)
It takes about 30 seconds for the 'system is too slow' message to appear; the whole time, the A-V number is increasing--the number increases faster when the video is more complicated (and of course, the audio-video sync gets worse the whole time, too). So it seems like vdpau can't keep up.

My card is an Nvidia GTX 260M, and I'm using the CUDA driver 190.18 (though iirc I got the same behavior using whatever nvidia driver was default in Ubuntu).
leptogenesis is offline   Reply With Quote
Old 04-14-10, 05:36 AM   #2
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: Your system is too SLOW to play this!

Do you have a 60 Hz display? If so you're probably hitting one of the limitations in svn MPlayer's VDPAU support; it can't play video with FPS higher than display refresh rate (and in practice near-equal values already cause problems).

Compiling a player from
git://repo.or.cz/mplayer-build.git
should avoid that problem. There are also working Ubuntu packages available at least at
https://launchpad.net/~ripps818/+archive/coreavc
(the "coreavc" name is there because the PPA was originally created for CoreAVC support in MPlayer, but you don't have to use that functionality).
uau is offline   Reply With Quote
Old 04-14-10, 09:53 AM   #3
leptogenesis
Registered User
 
Join Date: Apr 2010
Posts: 5
Default Re: Your system is too SLOW to play this!

Thanks for the response uau--you guessed correctly that my monitor's refresh rate was 60hz.

Quote:
Originally Posted by uau View Post
Compiling a player from
git://repo.or.cz/mplayer-build.git
should avoid that problem.
Tried this, and now the video tends to lock up after a while. Otherwise, it seems to be playing correctly (i.e. when it plays, the video keeps up with the audio). The lockups seem to happen at random intervals (usually a few seconds to a minute of solid playback before the lockup), and once it's locked i can sometimes back up in the video and it'll play for another little while before locking up again. Any ideas? Would that coreavc link be likely to do anything different?
leptogenesis is offline   Reply With Quote
Old 04-14-10, 11:22 AM   #4
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by leptogenesis View Post
Thanks for the response uau--you guessed correctly that my monitor's refresh rate was 60hz.
Would you mind also testing latest svn?

Thank you, Carl Eugen
cehoyos is offline   Reply With Quote
Old 04-14-10, 11:25 AM   #5
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by leptogenesis View Post
Tried this, and now the video tends to lock up after a while. Otherwise, it seems to be playing correctly (i.e. when it plays, the video keeps up with the audio). The lockups seem to happen at random intervals (usually a few seconds to a minute of solid playback before the lockup), and once it's locked i can sometimes back up in the video and it'll play for another little while before locking up again. Any ideas?
My first guess would be this kind of symptoms (playback suddenly freezes, but the process doesn't completely hang and you can still seek etc) are caused by an audio output problem. You don't explicitly say it, but I assume audio playback also stops when "video locks up"? Your above paste shows you're using pulseaudio, which is known to have some problems.

Do things work if you use -nosound? Does this happen with all videos? Did it ever happen with the Ubuntu default player? If not, do you get the same audio output in both cases (I don't know whether Ubuntu has modified the defaults or if you have custom configuration)? No pulseaudio vs ALSA-to-pulseaudio difference for example?
Quote:
Would that coreavc link be likely to do anything different?
Probably not.
uau is offline   Reply With Quote
Old 04-14-10, 11:26 AM   #6
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by cehoyos View Post
Would you mind also testing latest svn?
Why should he do that? You should know that doesn't work.
uau is offline   Reply With Quote
Old 04-14-10, 11:56 AM   #7
leptogenesis
Registered User
 
Join Date: Apr 2010
Posts: 5
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by uau View Post
My first guess would be this kind of symptoms (playback suddenly freezes, but the process doesn't completely hang and you can still seek etc) are caused by an audio output problem. You don't explicitly say it, but I assume audio playback also stops when "video locks up"? Your above paste shows you're using pulseaudio, which is known to have some problems.

Do things work if you use -nosound?
Interesting suggestion...I tried it with -nosound, and now the behavior is slightly different--now the video freezes for about a second, then continues. You were right that the audio was also freezing.

Looking more closely, I noticed that what tends to happen (when audio is enabled) is that the video and audio will freeze for around a second, then the video will start going again for around a quarter of a second with no sound, and then everything stops again. This makes it seem like a pause in vdpau is screwing up the audio, which then causes the final freeze.

Quote:
Originally Posted by uau View Post
Does this happen with all videos?
Thus far, I've only been able to reproduce this with my 60fps videos.

Quote:
Originally Posted by uau View Post
Did it ever happen with the Ubuntu default player?
No--with the default mplayer, with specifying vdpau, the video would lag unless I used framedropping. If I used framedropping, the lagging still occurred, but mplayer would skip bits of the video to catch up.

Quote:
Originally Posted by uau View Post
No pulseaudio vs ALSA-to-pulseaudio difference for example?
Well, I tried using the -ao alsa option with the mplayer from git and I got the same behavior. (not sure whether that actually means it's actually using alsa directly...ubuntu audio is confusing)
leptogenesis is offline   Reply With Quote
Old 04-14-10, 12:02 PM   #8
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by uau View Post
Why should he do that?
Somebody reported in another thread it works fine.
cehoyos is offline   Reply With Quote

Old 04-14-10, 12:18 PM   #9
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by leptogenesis View Post
Looking more closely, I noticed that what tends to happen (when audio is enabled) is that the video and audio will freeze for around a second, then the video will start going again for around a quarter of a second with no sound, and then everything stops again. This makes it seem like a pause in vdpau is screwing up the audio, which then causes the final freeze.
A video problem, even if there is one, should not be able to completely stop audio playback unless it completely freezes the player (which doesn't happen here) or causes general memory corruption. Of course it's possible that timing variations could trigger an audio bug; but the audio would have to be buggy to begin with.
Quote:
Well, I tried using the -ao alsa option with the mplayer from git and I got the same behavior. (not sure whether that actually means it's actually using alsa directly...ubuntu audio is confusing)
Was was the ao used when you did NOT specify that? Pulse?

AFAIK Ubuntu by default forwards ALSA output to PulseAudio. It's probably possible to test disabling PulseAudio somehow, but I don't know how (I don't use Ubuntu myself).
uau is offline   Reply With Quote
Old 04-14-10, 12:47 PM   #10
leptogenesis
Registered User
 
Join Date: Apr 2010
Posts: 5
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by uau View Post
A video problem, even if there is one, should not be able to completely stop audio playback unless it completely freezes the player (which doesn't happen here) or causes general memory corruption.
Then what do you think is going on when I use the -nosound option? I actually just noticed something else. When I'm playing with -nosound, and the video freezes temporarily, it's actually my *entire desktop* that freezes, including the mouse. This reminds me of a similar behavior I saw a few weeks back while I was using virtualbox--essentially exactly the same thing happens, where the entire desktop froze for around a second, stopping everything including sound. In that case, I actually did try completely disabling pulseaudio, and the problem persisted. I can't guarantee the problems are related, but who knows.

Quote:
Originally Posted by uau View Post
Of course it's possible that timing variations could trigger an audio bug; but the audio would have to be buggy to begin with.
Wouldn't surprise me, given that it's pulseaudio in ubuntu.

Quote:
Originally Posted by uau View Post
Was was the ao used when you did NOT specify that? Pulse?
That's what the error message seems to suggest--and afaik that's the default in ubuntu. I'm certainly no expert in ubuntu's audio hierarchy.

Quote:
Originally Posted by uau View Post
AFAIK Ubuntu by default forwards ALSA output to PulseAudio. It's probably possible to test disabling PulseAudio somehow, but I don't know how (I don't use Ubuntu myself).
Unfortunately I can't really try disabling pulseaudio as I can't restart my computer at the moment...something is running that I'd rather not restart. But still, we can at least try to get mplayer working with -noaudio, right? In that case, the audio system shouldn't make a difference...
leptogenesis is offline   Reply With Quote
Old 04-14-10, 01:03 PM   #11
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by leptogenesis View Post
Then what do you think is going on when I use the -nosound option? I actually just noticed something else. When I'm playing with -nosound, and the video freezes temporarily, it's actually my *entire desktop* that freezes, including the mouse. This reminds me of a similar behavior I saw a few weeks back while I was using virtualbox--essentially exactly the same thing happens, where the entire desktop froze for around a second, stopping everything including sound.
That sounds like a problem in a system driver, most likely the NVIDIA graphics driver.
Quote:
In that case, I actually did try completely disabling pulseaudio, and the problem persisted. I can't guarantee the problems are related, but who knows.
I'd guess the system freeze causes an audio buffer underrun or something like that, and there's a PulseAudio bug that prevents audio playback from recovering after it.
uau is offline   Reply With Quote
Old 04-15-10, 07:11 AM   #12
sherbey
Registered User
 
Join Date: Jun 2006
Posts: 45
Default Re: Your system is too SLOW to play this!

It is possible in ubuntu to completely remove pulseaudio and only use alsa. I've got an asus eeepc which I use for skype, removing pulseaudio has made skype useable again. I think you need to enter
sudo apt-get purge pulseaudio

This certainly worked on 9.04 - I haven't upgraded as the 4Gb flash disk is too full to allow it
sherbey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.