Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-23-09, 05:38 AM   #1
mrmr
Registered User
 
Join Date: Oct 2009
Posts: 4
Default 1920x1080 mode not available?

Why is the 1920x1080@60Hz native mode of my monitor not recognized?

Driver version: 190.42-pkg2 x86_64
Card: Quadro NVS 295

Snippet from the log:
....
(WW) No valid modes for "1920x1080"; removing.
(WW) Oct 23 12:27:01 NVIDIA(0):
(WW) Oct 23 12:27:01 NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) Oct 23 12:27:01 NVIDIA(0): "nvidia-auto-select".
(WW) Oct 23 12:27:01 NVIDIA(0):
(II) Oct 23 12:27:01 NVIDIA(0): Validated modes:
(II) Oct 23 12:27:01 NVIDIA(0): "nvidia-auto-select"
(II) Oct 23 12:27:01 NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) Oct 23 12:27:01 NVIDIA(0): DPI set to (61, 86); computed from "UseEdidDpi"
......

This is a Dual boot system, the Windows driver does recognize the display.
Attached Files
File Type: gz nvidia-bug-report.log.gz (29.4 KB, 136 views)
mrmr is offline   Reply With Quote
Old 10-23-09, 10:47 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 1920x1080 mode not available?

Please generate a verbose mode validation log by running "startx -- -logverbose 6" or by running "nvidia-xconfig --mode-debug" and restarting X, then generate and attach a new bug report.

It's possible that you're running into the same problem described in this thread: http://www.nvnews.net/vbulletin/showthread.php?t=140165
AaronP is offline   Reply With Quote
Old 10-28-09, 04:54 AM   #3
mrmr
Registered User
 
Join Date: Oct 2009
Posts: 4
Default Re: 1920x1080 mode not available?

This is the debug mode logfile
Attached Files
File Type: gz nvidia-bug-report.log.gz (53.3 KB, 115 views)
mrmr is offline   Reply With Quote
Old 10-28-09, 07:52 AM   #4
mrmr
Registered User
 
Join Date: Oct 2009
Posts: 4
Default Re: 1920x1080 mode not available?

Quote:
Originally Posted by mrmr View Post
This is the debug mode logfile
Btw, it looks like the same issue as in the thread below:

This looks OK
....

(--) Oct 28 10:44:36 NVIDIA(0): Connected display device(s) on Quadro NVS 295 at PCI:2:0:0:
(--) Oct 28 10:44:36 NVIDIA(0): DELL G2410 (DFP-2)
(--) Oct 28 10:44:36 NVIDIA(0): DELL G2410 (DFP-2): 330.0 MHz maximum pixel clock
(--) Oct 28 10:44:36 NVIDIA(0): DELL G2410 (DFP-2): Internal DisplayPort
(--) Oct 28 10:44:36 NVIDIA(0):
(--) Oct 28 10:44:36 NVIDIA(0): --- EDID for DELL G2410 (DFP-2) ---
(--) Oct 28 10:44:36 NVIDIA(0): EDID Version : 1.3
(--) Oct 28 10:44:36 NVIDIA(0): Manufacturer : DEL
(--) Oct 28 10:44:36 NVIDIA(0): Monitor Name : DELL G2410
(--) Oct 28 10:44:36 NVIDIA(0): Product ID : 16458
(--) Oct 28 10:44:36 NVIDIA(0): 32-bit Serial Number : 1096041557
(--) Oct 28 10:44:36 NVIDIA(0): Serial Number String : W222K932ATDU
(--) Oct 28 10:44:36 NVIDIA(0): Manufacture Date : 2009, week 10
(--) Oct 28 10:44:36 NVIDIA(0): DPMS Capabilities : Standby Suspend Active Off
(--) Oct 28 10:44:36 NVIDIA(0): Prefer first detailed timing : Yes
(--) Oct 28 10:44:36 NVIDIA(0): Supports GTF : No
(--) Oct 28 10:44:36 NVIDIA(0): Maximum Image Size : 530mm x 300mm
(--) Oct 28 10:44:36 NVIDIA(0): Valid HSync Range : 30.0 kHz - 83.0 kHz
(--) Oct 28 10:44:36 NVIDIA(0): Valid VRefresh Range : 56 Hz - 76 Hz
(--) Oct 28 10:44:36 NVIDIA(0): EDID maximum pixel clock : 180.0 MHz
.....

But then this happens:

(II) Oct 28 10:44:36 NVIDIA(0): --- Building ModePool for DELL G2410 (DFP-2) ---
(II) Oct 28 10:44:36 NVIDIA(0): Validating Mode "1920x1080":
(II) Oct 28 10:44:36 NVIDIA(0): 1920 x 1080 @ 60 Hz
(II) Oct 28 10:44:36 NVIDIA(0): For use as DFP backend.
(II) Oct 28 10:44:36 NVIDIA(0): Mode Source: EDID
(II) Oct 28 10:44:36 NVIDIA(0): Pixel Clock : 148.50 MHz
(II) Oct 28 10:44:36 NVIDIA(0): HRes, HSyncStart : 1920, 2008
(II) Oct 28 10:44:36 NVIDIA(0): HSyncEnd, HTotal : 2052, 2200
(II) Oct 28 10:44:36 NVIDIA(0): VRes, VSyncStart : 1080, 1084
(II) Oct 28 10:44:36 NVIDIA(0): VSyncEnd, VTotal : 1089, 1125
(II) Oct 28 10:44:36 NVIDIA(0): H/V Polarity : +/+
(WW) Oct 28 10:44:36 NVIDIA(0): Mode is rejected: Mode exceeds available DisplayPort
(WW) Oct 28 10:44:36 NVIDIA(0): bandwidth.
(II) Oct 28 10:44:36 NVIDIA(0):
mrmr is offline   Reply With Quote
Old 10-28-09, 10:13 AM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 1920x1080 mode not available?

Quote:
Originally Posted by mrmr View Post
Btw, it looks like the same issue as in the thread below:
Yes it does. Thanks for confirming that. Please try the next driver release when it becomes available.
AaronP is offline   Reply With Quote
Old 10-28-09, 11:11 AM   #6
dclemen
Registered User
 
Join Date: Apr 2004
Posts: 49
Default Re: 1920x1080 mode not available?

I think I have same problem

http://www.nvnews.net/vbulletin/showthread.php?t=140522

Maybe?
dclemen is offline   Reply With Quote
Old 12-04-09, 03:20 AM   #7
mrmr
Registered User
 
Join Date: Oct 2009
Posts: 4
Default Re: 1920x1080 mode not available?

I can confirm that the NVIDIA-Linux-x86_64-195.22-pkg2 beta driver fixes this issue.
mrmr is offline   Reply With Quote
Old 04-22-10, 03:49 PM   #8
craiga
Registered User
 
Join Date: Apr 2010
Posts: 2
Default Re: 1920x1080 mode not available?

Asus M2NPV-VM motherboard - GeForce 6150 GPU/nForce 430 MCP. Max res 1280x1024

I installed NVIDIA-Linux-x86_64-195.36.15-pkg2.run which went very smoothly with the usual "init 3 ; ./NVIDIA-Linux-x86_64-195.36.15-pkg2.run ; init 5" sequence under OpenSUSE 10.3-64 as root.

Monitor is a Samsung SyncMaster P2370HD with native resolution of 1920x1080. I installed the "Monitor Setup" from the provided product CD. I tried driving both the DVI and VGA-PC connectors with the same result of max 1280x1024 resolution.

Is there a way to convince the GeForce 6150 GPU/nForce 430 MCP chipset/X to use the 1920x1080 mode of the monitor?

My primary use of the display is engineering/CAD/Programming and the extra resolution will really help.

Thanks,
Craig
craiga is offline   Reply With Quote

Old 04-22-10, 06:45 PM   #9
craiga
Registered User
 
Join Date: Apr 2010
Posts: 2
Default Re: 1920x1080 mode not available?

Quote:
Originally Posted by craiga View Post
Is there a way to convince the GeForce 6150 GPU/nForce 430 MCP chipset/X to use the 1920x1080 mode of the monitor?
I answered my own question and now have 1920x1080... nice and sharp, solid, CAD apps look great, even plays MythTV 720p programs fluidly (1080i jumps around like it's lacking horsepower somewhere on an Athlon 64 X2 5200+ w/8GB ram, maybe the 6150/430 chipset can't keep up?) The display is now a thing of beauty!

First as root: xmode -x 1920 -y 1080 -r 52
58
52
Modeline "1920x1080" 148.16 1920 2032 2240 2560 1080 1081 1084 1113


Then edit /etc/X11/xorg.conf:

Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 510 290
HorizSync 30-81
Identifier "Monitor[0]"
ModelName "SYNCMASTER P2370HD(DIGITAL)"
VendorName "SAMSUNG"
VertRefresh 56-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1920x1080" 148.00 1920 2008 2052 2200 1080 1084 1089 1125 +HSync +VSync
Modeline "1280x1024" 135.00 1280 1296 1440 1768 1024 1025 1028 1130
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1920x1080" "1280x1024" "1280x960" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1920x1080" "1280x1024" "1280x960" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1920x1080" "1280x1024" "1280x960" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1920x1080" "1280x1024" "1280x960" "1024x768" "800x600"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection



At this point as root I executed "init 3" followed by logging in as root and executing "init 5" After init 5, X started in 1920x1080 mode.


"xrandr" reports: usr/craig> xrandr

Screen 0: minimum 320 x 240, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
1920x1080 50.0* 55.0
1280x1024 51.0 62.0 63.0
1280x960 52.0
1024x768 53.0 66.0 67.0
800x600 54.0 69.0 70.0 71.0 72.0 73.0
1680x1050 56.0
1600x1024 57.0
1440x900 58.0 59.0
1400x1050 60.0 61.0
1280x800 64.0
1152x864 65.0
832x624 68.0
800x512 74.0
640x512 75.0 76.0
640x480 77.0 78.0 79.0 80.0 81.0 82.0
576x432 83.0
512x384 84.0 85.0 86.0
416x312 87.0
400x300 88.0 89.0 90.0 91.0
320x240 92.0 93.0 94.0



and /var/log/Xorg.0.log shows:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) Apr 22 15:36:07 NVIDIA(0): Enabling RENDER acceleration
(II) Apr 22 15:36:08 NVIDIA(0): NVIDIA GPU GeForce 6150 (C51) at PCI:0:5:0 (GPU-0)
(--) Apr 22 15:36:08 NVIDIA(0): Memory: 262144 kBytes
(--) Apr 22 15:36:08 NVIDIA(0): VideoBIOS: 05.51.22.33.07
(--) Apr 22 15:36:08 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Apr 22 15:36:08 NVIDIA(0): Connected display device(s) on GeForce 6150 at PCI:0:5:
0:
(--) Apr 22 15:36:08 NVIDIA(0): Samsung SyncMaster (DFP-0)
(--) Apr 22 15:36:08 NVIDIA(0): Samsung SyncMaster (DFP-0): 310.0 MHz maximum pixel clo
ck
(--) Apr 22 15:36:08 NVIDIA(0): Samsung SyncMaster (DFP-0): Internal Dual Link TMDS
(II) Apr 22 15:36:08 NVIDIA(0): Assigned Display Device: DFP-0
(II) Apr 22 15:36:08 NVIDIA(0): Validated modes:
(II) Apr 22 15:36:08 NVIDIA(0): "1920x1080"
(II) Apr 22 15:36:08 NVIDIA(0): "1280x1024"
(II) Apr 22 15:36:08 NVIDIA(0): "1280x960"
(II) Apr 22 15:36:08 NVIDIA(0): "1024x768"
(II) Apr 22 15:36:08 NVIDIA(0): "800x600"
(II) Apr 22 15:36:08 NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(--) Apr 22 15:36:08 NVIDIA(0): DPI set to (95, 94); computed from "UseEdidDpi" X confi
g
(--) Apr 22 15:36:08 NVIDIA(0): option
(==) Apr 22 15:36:08 NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xfdafe000 - 0xfdafe0ff (0x100) MX[b]
[5] -1 0 0xfdaf8000 - 0xfdafbfff (0x4000) MX[b]
[6] -1 0 0xfdaff000 - 0xfdaff7ff (0x800) MX[b]
[7] -1 0 0xfddfc000 - 0xfddfffff (0x4000) MX[b]
[8] -1 0 0xfe02b000 - 0xfe02bfff (0x1000) MX[b]
[9] -1 0 0xfe02c000 - 0xfe02cfff (0x1000) MX[b]
[10] -1 0 0xfe02d000 - 0xfe02dfff (0x1000) MX[b]
[11] -1 0 0xfe02e000 - 0xfe02e0ff (0x100) MX[b]
[12] -1 0 0xfe02f000 - 0xfe02ffff (0x1000) MX[b]
[13] -1 0 0xfc000000 - 0xfcffffff (0x1000000) MX[b](B)
[14] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[15] -1 0 0xfb000000 - 0xfbffffff (0x1000000) MX[b](B)
[16] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[17] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[18] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[19] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[20] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[21] -1 0 0x00009400 - 0x00009407 (0x8) IX[b]
[22] -1 0 0x00009800 - 0x0000981f (0x20) IX[b]
[23] -1 0 0x00009c00 - 0x00009cff (0x100) IX[b]
[24] -1 0 0x00008c00 - 0x00008cff (0x100) IX[b]
[25] -1 0 0x0000c800 - 0x0000c807 (0x8) IX[b]
[26] -1 0 0x0000cc00 - 0x0000cc0f (0x10) IX[b]
[27] -1 0 0x00000b60 - 0x00000b63 (0x4) IX[b]
[28] -1 0 0x00000960 - 0x00000967 (0x8) IX[b]
[29] -1 0 0x00000be0 - 0x00000be3 (0x4) IX[b]
[30] -1 0 0x000009e0 - 0x000009e7 (0x8) IX[b]
[31] -1 0 0x0000e000 - 0x0000e00f (0x10) IX[b]
[32] -1 0 0x00000b70 - 0x00000b73 (0x4) IX[b]
[33] -1 0 0x00000970 - 0x00000977 (0x8) IX[b]
[34] -1 0 0x00000bf0 - 0x00000bf3 (0x4) IX[b]
[35] -1 0 0x000009f0 - 0x000009f7 (0x8) IX[b]
[36] -1 0 0x0000f400 - 0x0000f40f (0x10) IX[b]
[37] -1 0 0x00004c40 - 0x00004c7f (0x40) IX[b]
[38] -1 0 0x00004c00 - 0x00004c3f (0x40) IX[b]
[39] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[40] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Apr 22 15:36:08 NVIDIA(0): Initialized GPU GART.
(II) Apr 22 15:36:08 NVIDIA(0): Setting mode "1920x1080"
(II) Loading extension NV-GLX
(II) Apr 22 15:36:08 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Apr 22 15:36:08 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(WW) NVIDIA(0): Option "usevnc" is not used
(WW) NVIDIA(0): Option "CalcAlgorithm" is not used
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
...
craiga is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.