Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-05-10, 07:33 AM   #1
evolve
Registered User
 
Join Date: May 2010
Posts: 3
Default Screen resolution problem with Nvidia 9600GT

Hello everyone. I have a problem with screen resolution, after rebooting once, screen resolution always started to be 640x480, and there is other available resolution - 320x240. Before that happened I didn't upgraded something, it just began suddenly. I didn't can imagine why it happened, all was fine before. I didn't upgraded or reconfigured something before this. Then I already tried to recompile/reconfigure Xorg, installed latest nvidia drivers, looked at kernel options - all seems fine... I just don't know what to do, maybe this is a hardware problem?

Here is my Xorg log:
Code:
...
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) May 05 16:23:18 NVIDIA(0): Enabling RENDER acceleration
(II) May 05 16:23:18 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) May 05 16:23:18 NVIDIA(0):     enabled.
(WW) May 05 16:23:19 NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(II) May 05 16:23:19 NVIDIA(0): NVIDIA GPU GeForce 9600 GT (G94) at PCI:1:0:0 (GPU-0)
(--) May 05 16:23:19 NVIDIA(0): Memory: 524288 kBytes
(--) May 05 16:23:19 NVIDIA(0): VideoBIOS: 62.94.3c.00.00
(II) May 05 16:23:19 NVIDIA(0): Detected PCI Express Link width: 16X
(--) May 05 16:23:19 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) May 05 16:23:19 NVIDIA(0): Connected display device(s) on GeForce 9600 GT at PCI:1:0:0:
(--) May 05 16:23:19 NVIDIA(0):     CRT-0
(--) May 05 16:23:19 NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) May 05 16:23:19 NVIDIA(0): Assigned Display Device: CRT-0
(==) May 05 16:23:19 NVIDIA(0): 
(==) May 05 16:23:19 NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) May 05 16:23:19 NVIDIA(0):     will be used as the requested mode.
(==) May 05 16:23:19 NVIDIA(0): 
(II) May 05 16:23:19 NVIDIA(0): Validated modes:
(II) May 05 16:23:19 NVIDIA(0):     "nvidia-auto-select"
(II) May 05 16:23:19 NVIDIA(0): Virtual screen size determined to be 640 x 480
(WW) May 05 16:23:19 NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) May 05 16:23:19 NVIDIA(0):     from CRT-0's EDID.
(==) May 05 16:23:19 NVIDIA(0): DPI set to (75, 75); computed from built-in default
(==) May 05 16:23:19 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) May 05 16:23:19 NVIDIA(0): Initialized GPU GART.
(II) May 05 16:23:19 NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) May 05 16:23:19 NVIDIA(0):     may not be running or the "AcpidSocketPath" X
(II) May 05 16:23:19 NVIDIA(0):     configuration option may not be set correctly.  When the
(II) May 05 16:23:19 NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
(II) May 05 16:23:19 NVIDIA(0):     try to use it to receive ACPI event notifications.  For
(II) May 05 16:23:19 NVIDIA(0):     details, please see the "ConnectToAcpid" and
(II) May 05 16:23:19 NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) May 05 16:23:19 NVIDIA(0):     Config Options in the README.
(II) May 05 16:23:19 NVIDIA(0): Setting mode "nvidia-auto-select"
(II) May 05 16:23:19 NVIDIA(0): Built-in logo is bigger than the screen.
(II) Loading extension NV-GLX
(II) May 05 16:23:19 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) May 05 16:23:19 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled
...
and xorg.conf (was generated by nvidia-xconfig)
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Thu Apr 22 20:35:23 PDT 2010


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Any help will be appreciated, thanks in advance!
evolve is offline   Reply With Quote
Old 05-05-10, 07:36 AM   #2
evolve
Registered User
 
Join Date: May 2010
Posts: 3
Default Re: Screen resolution problem with Nvidia 9600GT

Forgot to say: forcing normal (1680x1050) resolution at xorg.conf didn't helps, i get just bigger scaling.
evolve is offline   Reply With Quote
Old 05-05-10, 09:43 AM   #3
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Screen resolution problem with Nvidia 9600GT

Remove the driver, xorg.conf, ~/.nvidia-settings-rc file and reinstall the driver. This probably wont help in your case, but you never know.

The problem seems to be that you have a monitor that doesnt cooperate with the driver - i.e the EDID provided cannot be interpreted by the driver.

This part from your log:

23:19 NVIDIA(0): Virtual screen size determined to be 640 x 480
(WW) May 05 16:23:19 NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) May 05 16:23:19 NVIDIA(0): from CRT-0's EDID.

And your horizsync seems a bit low. I dont know what monitor you have, but i have a 22" Dell 228WFP LCD that runs at 1680x1050@60hz and my monitor section looks like this:

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL E228WFP"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection
Try increasing horizsync values and adding your modes to xorg.conf.

Here is another guy who had the same issue:

http://ubuntuforums.org/showthread.php?p=9235631

If this doesnt work, look for methods that permit extract the EDID to disk and it can be loaded from file from xorg.conf.
gradinaruvasile is offline   Reply With Quote
Old 05-05-10, 09:52 AM   #4
evolve
Registered User
 
Join Date: May 2010
Posts: 3
Default Re: Screen resolution problem with Nvidia 9600GT

Everything fine now. I just pulled cables, also added nvidia USE-flag and VIDEO_CARDS="nvidia" to make.conf (I am using gentoo) and recompiled xorg-server, and now it works again! But worked fine without it previous times.
Btw, thanks for response! Thread may be closed.
evolve is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.