Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-04-10, 04:36 PM   #1
Tares
Registered User
 
Tares's Avatar
 
Join Date: May 2010
Posts: 4
Default Twinview and Flash 10.0.45.2 amd64 on fullscreen

hello,

it's my first post here since I just recently bought nvidia card, so please be understanding

Currently I have two monitors set up using TwinView like this :


using this xorg.conf :
Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Configured Mouse"
    Option         "AIGLX" "on"
    Option         "Clone" "off"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"

#	Load  "GLcore"
#	Load  "dri"
    Load           "i2c"
    Load           "bitmap"
    Load           "extmod"
#	Load  "freetype"
    Load           "int10"
    Load           "vbe"
    Load           "dbe"
#	Load  "glx"
EndSection

Section "ServerFlags"
    Option         "DontZap" "False"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Name" "Logitech USB Gaming Mouse"
    Option         "ZAxisMapping" "4 5 6 7"
    Option         "Emulate3Buttons" "false"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL 2209WA"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 275"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DisableGLXRootClipping" "True"
    Option         "RenderAccel" "True"
    Option         "TripleBuffer" "True"
    Option         "DamageEvents" "True"
    Option         "Coolbits" "1"
    Option         "NoLogo" "true"
    Option         "TwinView" "1"
    Option         "TwinViewOrientation" "DFP-1 LeftOf DFP-0" 
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: 1680x1050, DFP-1: 1280x1024; 1680x1050,NULL"
    OPtion	   "UseDisplayDevice" "DFP-0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "RENDER" "Enable"
    Option         "DAMAGE" "Enable"
    Option         "Composite" "Enable"
EndSection
I have a little issue with playing flash videos on fullscreen :
http://i39.tinypic.com/2mcy3cw.jpg

My main LCD is the right one (1680x1050) so the smaller is the "extra" one. When I press fullscreen on flash player it scales on the entire screen, but leaves white borders on the right and bottom. Flash player thinks that he's playing on the smaller LCD.
Is there anyway to tell him that I want him to think that bigger LCD is my main screen ? So flashplayer would expand on whole 22" screen ?

ow yeah, I'm using ubuntu 10.4 amd64 with GTX275@195.36.24
Tares is offline   Reply With Quote
Old 05-05-10, 06:13 PM   #2
Pizzuco
Registered User
 
Join Date: Jul 2009
Posts: 4
Default Re: Twinview and Flash 10.0.45.2 amd64 on fullscreen

I use an Acer Aspire 8920 (dual core EM64T centrino with a GeForce 9500M GS with dedicated 512 Mbyte video memory).

I use an updated OpenSuSE 11.2 x86-64 with kernel 2.6.31.12 and with 195.36.24 nVidia x86-64 linux driver. Main desktop manager Gnome 2.30.0 (from build service) and sometimes KDE 4.4.2 mainly to go and see it ;-).

I have noted that "making NOT the primary display" the leftmost one, as soon as you press apply in the "NVIDIA X-Server settings" you get the gnome bar still in the leftmost display.

As soon as you run (without having made and set some changes) again the "NVIDIA X-Server settings" you get the gnome bar in the correct "primary display" (and only in it), but desktop icon still start to draw from left to right (of the whole virtual display) and so they will fit in the leftmost display.

For that behaviour, I suggest you to set the "primary display" as the leftmost one (the other ones are "right of" the primary display) even if it is not the physical leftmost one on your desktop or similar situation.

Hth,

Carlo
Pizzuco is offline   Reply With Quote
Old 05-05-10, 06:28 PM   #3
Pizzuco
Registered User
 
Join Date: Jul 2009
Posts: 4
Default Re: Twinview and Flash 10.0.45.2 amd64 on fullscreen

p.s. As lateral note, I am not able to set on 3D effect on the gnome control center.

As soon as I "enable visual effects" on "desktop effects" of gnome control center, I will get the following message:

"Desktop effects are not supported on your current hardware / configuration. Would you like to activate them anyway?"

Any suggestions?

My hardware is that described in the previous post and is not so weak to deal with compiz effect, is it?

I think some bad or ancient/old settings may be disorienting the effect manager?

Have a nice day,

Carlo
Pizzuco is offline   Reply With Quote
Old 05-07-10, 03:30 PM   #4
Tares
Registered User
 
Tares's Avatar
 
Join Date: May 2010
Posts: 4
Default Re: Twinview and Flash 10.0.45.2 amd64 on fullscreen

Quote:
Originally Posted by Pizzuco View Post
For that behaviour, I suggest you to set the "primary display" as the leftmost one (the other ones are "right of" the primary display) even if it is not the physical leftmost one on your desktop or similar situation.

Hth,

Carlo
Thanks for your replay, but this isn't even a workaround here. Setting primary display on the left one only moves gnome-panel to the left screen. Flash problem stays the same. Well, it works on windows :/ so I hoped it will work here too.
Tares is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.