Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-05-10, 09:03 AM   #1
DanKege
Registered User
 
Join Date: Nov 2008
Posts: 7
Default X crash when running 3DMark benchmarks in Wine

On Ubuntu 10.04 32 bit with the 195.36.15 drivers that come with Ubuntu,
I've been getting crashes like this:

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e937b]
1: /usr/bin/X (0x8048000+0x61c7d) [0x80a9c7d]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb77fd410]
3: /usr/bin/X (0x8048000+0x144488) [0x818c488]
4: /usr/lib/xorg/extra-modules/nvidia_drv.so (0xb55ef000+0x31db67) [0xb590cb67]
Segmentation fault at address 0x10
Caught signal 11 (Segmentation fault). Server aborting

when running the 3DMark2000, 3DMark2001, and 3DMark06 benchmarks
under Wine. It doesn't crash every time; I've had about five crashes in
100 runs.

I'll keep running to see if I can pin down how reproducible this is,
then switch to 195.36.24 to see if the latest drivers help.

I have tried running Wine with full logging on to see if I can pinpoint
which X call is making X fall over, but haven't had any luck with that yet.
DanKege is offline   Reply With Quote
Old 05-08-10, 09:31 AM   #2
TPG
Unregistered User
 
TPG's Avatar
 
Join Date: Apr 2006
Location: Poland, Warsaw
Posts: 203
Default Re: X crash when running 3DMark benchmarks in Wine

Try install debug packages and run wine and X under gdb so you could provide more info.

Anyways i doubt this is serious bug, because it's pointless to run 3D benchmarks for windows under emulator.

Wanna really benchmark your gear, use Unigine Benchmark.
__________________
mandriva > all
kthnxbai
TPG is offline   Reply With Quote
Old 05-12-10, 05:13 AM   #3
DanKege
Registered User
 
Join Date: Nov 2008
Posts: 7
Default Re: X crash when running 3DMark benchmarks in Wine

Quote:
Originally Posted by TPG View Post
Try install debug packages and run wine and X under gdb so you could provide more info.
I caught it in gdb this time; I think it's the same as this existing bug report:
https://bugs.launchpad.net/ubuntu/+s...rs/+bug/546525

gdb says

Program received signal SIGPIPE, Broken pipe.
0xb7769430 in __kernel_vsyscall ()
(gdb) bt
#0 0xb7769430 in __kernel_vsyscall ()
#1 0xb754ea61 in writev () from /lib/tls/i686/cmov/libc.so.6
#2 0x080ad40e in ?? ()
#3 0x080acb5f in ?? ()
#4 0x080a84d6 in ?? ()
#5 0x080a8f3f in FlushAllOutput ()
#6 0x080a8f71 in FlushIfCriticalOutputPending ()


Quote:
Originally Posted by TPG View Post
Anyways i doubt this is serious bug, because it's pointless to run 3D benchmarks for windows under emulator.
Not if you're working on improving Wine's performance, which I am.
But any X crash bug is a serious one, and it seems this bug can happen
under other circumstances, so it's well worth fixing.

Quote:
Originally Posted by TPG View Post
Wanna really benchmark your gear, use Unigine Benchmark.
That's one of the benchmarks I'm running under Wine.

See http://wiki.winehq.org/yagmark and
http://www.winehq.org/pipermail/wine...ay/083524.html
for more info and some results.
DanKege is offline   Reply With Quote
Old 05-12-10, 08:20 PM   #4
DanKege
Registered User
 
Join Date: Nov 2008
Posts: 7
Default Re: X crash when running 3DMark benchmarks in Wine

Got another SIGPIPE, probably would have been a crash?

Program received signal SIGPIPE, Broken pipe.
0xb7769430 in __kernel_vsyscall ()
(gdb) bt
#0 0xb7769430 in __kernel_vsyscall ()
#1 0xb754ea61 in writev () from /lib/tls/i686/cmov/libc.so.6
#2 0x080ad40e in ?? ()
#3 0x080acb5f in ?? ()
#4 0x080a84d6 in ?? ()
#5 0x080a6dbc in CloseDownConnection ()
#6 0x0806d73d in CloseDownClient ()
#7 0x08072308 in ?? ()
#8 0x08066d7a in _start ()
DanKege is offline   Reply With Quote
Old 05-12-10, 10:14 PM   #5
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: X crash when running 3DMark benchmarks in Wine

X Server Debugging
http://www.x.org/wiki/Development/Do...erverDebugging

It's easier to do with 2 machines via ssh but can be done with only one. Install the xserver debug symbols and get a full backtrace. https://bugs.freedesktop.org/
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Old 05-13-10, 12:26 PM   #6
ChrisDodd
Registered User
 
Join Date: Jul 2008
Posts: 7
Default Re: X crash when running 3DMark benchmarks in Wine

Ignore SIGPIPEs in the server -- they're normal and expected any time a client exits and should not cause a crash. Use
Code:
(gdb) handle SIGPIPE nostop noprint pass
ChrisDodd is offline   Reply With Quote
Old 06-21-10, 10:29 PM   #7
DanKege
Registered User
 
Join Date: Nov 2008
Posts: 7
Default Re: X crash when running 3DMark benchmarks in Wine

Hey, I can now reproduce this *every time* on my e8400 test box
with ubuntu 10.04 and the 195.36.15 drivers.

I guess I should try it with the latest beta drivers, but before I do,
is there any info nvidia wants gathered? I fear updating nvidia
drivers like the plague; it usually breaks my machine.
DanKege is offline   Reply With Quote
Old 06-22-10, 08:07 AM   #8
CME
Registered User
 
Join Date: Dec 2007
Posts: 20
Default Re: X crash when running 3DMark benchmarks in Wine

i'm using debian testing and had the same problem with X 1.7.6 (which ubuntu lucid seems to be using: http://packages.ubuntu.com/search?ke...id&section=all) , 1.7.7 fixed it for me, a friend with arch linux told me 1.8 is also fine
CME is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.