Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-12-09, 10:43 PM   #1
mathog
Registered User
 
Join Date: May 2006
Posts: 90
Default force screens 0 and 1 even when no display attached

180.37 driver, Xorg X11 server 1.5.2

Currently this this system is configured with:
screen 0: crt 1, a monitor
screen 1. tv-out
and both display devices are attached.

I want to force X11 to run both of these screens even if at boot time one or the other is not physically attached. They might be attached later, and that screen should already be running. Normally TV-OUT will be attached,but if something goes wrong, I want to be able to plug a monitor in (TV-OUT is just NTSC at 640x480 and is very hard to read text on). Similarly, there may be times when the TV is plugged into something else when the system comes up, but will be plugged back in again without an intervening reboot.

I am having a very hard time getting this to work. The latest attempt with

Option "UseEdid" "false"

on screen 0 failed miserably: the system came up, saw there was no display there (how did it do this if it didn't "Use Edid"???), dropped the CRT, made TV-OUT screen 0, and it was all downhill from there.

Surely there is some way to force this to happen by using the appropriate magic in xorg.conf. What is this incantation?

The current xorg.conf is below, and the Xorg.0.log for when both displays are connected, and when just the TV is connected, are attached. Use xxdiff on the two log files to see what happens clearly. Note that when only the TV is attached the BIOS and pre-X11 boot messages come over TV-OUT. That is fine. What isn't fine is that when X11 starts that screen becomes 0 instead of 1, and there is no screen 0 for the monitor.

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Sony CPD-420GS"
    HorizSync       30.0 - 96.0
    VertRefresh     48.0 - 120.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "TV-0"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          0
    Option         "UseEvents" "True"
    Option         "UseEdid" "False"
    Option         "NoLogo" "True"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          1
    Option         "UseEvents" "True"
    Option         "NoLogo" "True"
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: 1280x1024 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "TV: 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Attached Files
File Type: txt only_tv-out_connected_Xorg.0.log.txt (17.6 KB, 120 views)
File Type: txt both_connected_Xorg.0.log.txt (18.7 KB, 113 views)
mathog is offline   Reply With Quote
Old 03-13-09, 09:57 AM   #2
Tub
Registered User
 
Join Date: Nov 2006
Posts: 95
Default Re: force screens 0 and 1 even when no display attached

use "nvidia-settings" to dump the EDIDs to a file, then use something like this:
Code:
Section "Screen"
        [...]
        Option     "ConnectedMonitor"   "DFP-0,DFP-1"
        Option     "CustomEDID" "DFP-0:/etc/X11/245B.edid; DFP-1:/etc/X11/214T.edid"
        Option      "IgnoreDisplayDevices" "CRT, TV"
EndSection
I use this because sometimes my monitors aren't powered on during boot. It won't work when you're attaching different monitors to your outputs, unless they all support the same resolutions/timings.
Tub is offline   Reply With Quote
Old 03-13-09, 12:24 PM   #3
mathog
Registered User
 
Join Date: May 2006
Posts: 90
Default Re: force screens 0 and 1 even when no display attached

Quote:
Originally Posted by Tub View Post
use "nvidia-settings" to dump the EDIDs to a file, then use something like this:
Code:
Section "Screen"
        [...]
        Option     "ConnectedMonitor"   "DFP-0,DFP-1"
        Option     "CustomEDID" "DFP-0:/etc/X11/245B.edid; DFP-1:/etc/X11/214T.edid"
        Option      "IgnoreDisplayDevices" "CRT, TV"
EndSection
In the above example, did you have

option "UseEdid" "False"

in the Device section? What is the purpose of the IgnoreDisplayDevices option?

Anyway, the Xorg.0.log shows devices CRT-1 and TV-0, and I have two screen sections.
So maybe like this: (?)

Code:
Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "ConnectedMonitor"   "CRT-1"
    Option         "CustomEDID" "CRT-1:/etc/X11/crt1.edid"
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: 1280x1024 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "ConnectedMonitor"   "TV-0"
    Option         "CustomEDID" "TV-0:/etc/X11/tv0.edid"
    Option         "TwinView" "0"
    Option         "metamodes" "TV: 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Thanks.
mathog is offline   Reply With Quote
Old 03-13-09, 10:12 PM   #4
mathog
Registered User
 
Join Date: May 2006
Posts: 90
Default Re: force screens 0 and 1 even when no display attached

Why must this sort of thing always be so hard?

Anyway, first I pulled up "nvidia-settings" and there were no EDID options in the expected place. Then it hit me, with

option "UseEdid" "False"

in place there wouldn't be. Removed that, restarted X11. Was able to acquire EDID for CRT-1.
However, there was no option for this still in the TV-0 section. Rebooted. Still not present.
So no way to save an EDID for the TV (NTSC TV, connected by component-out, probably EDID makes no sense for that sort of display.). Set up xorg.conf as indicated below. The problem is that the two lines which are commented out in the Screen 0 section are toxic for tv-out. If either
or both of them is present, at reboot nothing at all shows up on the TV. Also Xorg.0.log then contains:

Code:
(--) NVIDIA(1): Interlaced video modes are supported on this GPU
(--) NVIDIA(1): Connected display device(s) on GeForce 8400 GS at PCI:1:0:0:
(--) NVIDIA(1):     CRT-1
(--) NVIDIA(1): CRT-1: 400.0 MHz maximum pixel clock
(EE) NVIDIA(1): Unable to find available Display Devices for screen 1.
Moreover, without those two lines CRT-1 doesn't start if the monitor isn't plugged in.
I will experiment some more, but presumably somebody has solved this problem already for this configuration. If so, please share your xorg.conf.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Thu Mar  5 18:47:52 PST 2009

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Sony CPD-420GS"
    HorizSync       30.0 - 96.0
    VertRefresh     48.0 - 120.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "TV-0"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
#    Option         "IgnoreDisplayDevices" "TV"
#    Option         "ConnectedMonitor" "CRT-1"
    Option         "CustomEDID" "CRT-1:/etc/X11/crt1_bin.edid"
    Option         "metamodes" "CRT: 1280x1024 +0+0"
    Option         "UseEvents" "True"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "TV: 640x480 +0+0"
    Option         "UseEvents" "True"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
mathog is offline   Reply With Quote
Old 03-13-09, 10:45 PM   #5
mathog
Registered User
 
Join Date: May 2006
Posts: 90
Default Re: force screens 0 and 1 even when no display attached

Check this out - it doesn't work, but it is interesting. The screen section from xorg.conf:

Code:
Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "ConnectedMonitor" "CRT-1"
    Option         "CustomEDID" "CRT-1:/etc/X11/crt1_edid.bin"
    Option         "IgnoreDisplayDevices" "TV-0"
    Option         "metamodes" "CRT: 1280x1024 +0+0"
    Option         "UseEvents" "True"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TVOutFormat" "SVIDEO"
    Option         "TVStandard" "NTSC-M"
    Option         "ConnectedMonitor" "TV-0"
    Option         "IgnoreDisplayDevices" "CRT-1"
    Option         "metamodes" "TV: 640x480 +0+0"
    Option         "UseEvents" "True"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Now look what shows up in Xorg.0.log when X11 tries to start, with both the CRT and TV attached and running. First it assigns CRT-1 to screen 0, which is correct. It then tries to assign the same device to screen 1, which of course fails. But look at the log, it says "don't do that", but it does anyway. Both CRT and CRT-1 were used with the IgnoreDisplayDevices option, with the same result.

Code:
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "ConnectedMonitor" "CRT-1"
(**) NVIDIA(0): Option "TwinView" "0"
(**) NVIDIA(0): Option "MetaModes" "CRT: 1280x1024 +0+0"
(**) NVIDIA(0): Option "CustomEDID" "CRT-1:/etc/X11/crt1_edid.bin"
(**) NVIDIA(0): Option "IgnoreDisplayDevices" "TV-0"
(**) NVIDIA(0): Option "UseEvents" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): ConnectedMonitor string: "CRT-1"
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 8400 GS (G98) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 62.98.29.00.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8400 GS at PCI:1:0:0:
(--) NVIDIA(0):     Sony CPD-420GS (CRT-1)
(--) NVIDIA(0): Sony CPD-420GS (CRT-1): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Display Device found referenced in MetaMode: CRT-1
(II) NVIDIA(0): Assigned Display Device: CRT-1
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "CRT:1280x1024+0+0"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(++) NVIDIA(0): DPI set to (100, 100); computed from -dpi X commandline option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(1): RGB weight 888
(==) NVIDIA(1): Default visual is TrueColor
(==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(1): Option "NoLogo" "True"
(**) NVIDIA(1): Option "ConnectedMonitor" "TV-0"
(**) NVIDIA(1): Option "TVStandard" "NTSC-M"
(**) NVIDIA(1): Option "TVOutFormat" "SVIDEO"
(**) NVIDIA(1): Option "TwinView" "0"
(**) NVIDIA(1): Option "MetaModes" "TV: 640x480 +0+0"
(**) NVIDIA(1): Option "IgnoreDisplayDevices" "CRT-1"
(**) NVIDIA(1): Option "UseEvents" "True"
(**) NVIDIA(1): Enabling RENDER acceleration
(**) NVIDIA(1): Forcing SVIDEO output
(**) NVIDIA(1): TV Standard string: "NTSC-M"
(II) NVIDIA(1): NVIDIA GPU GeForce 8400 GS (G98) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(1): Memory: 524288 kBytes
(--) NVIDIA(1): VideoBIOS: 62.98.29.00.00
(II) NVIDIA(1): Detected PCI Express Link width: 16X
(--) NVIDIA(1): Interlaced video modes are supported on this GPU
(--) NVIDIA(1): Connected display device(s) on GeForce 8400 GS at PCI:1:0:0:
(--) NVIDIA(1):     Sony CPD-420GS (CRT-1)
(--) NVIDIA(1): Sony CPD-420GS (CRT-1): 400.0 MHz maximum pixel clock
(EE) NVIDIA(1): Unable to find available Display Devices for screen 1.
mathog is offline   Reply With Quote
Old 03-13-09, 11:43 PM   #6
mathog
Registered User
 
Join Date: May 2006
Posts: 90
Default Re: force screens 0 and 1 even when no display attached

Figured it out!

The xorg.conf below starts both screens even when the CRT cable is not plugged into the PC, or when the TV is off. (I have not tested it with both off.)

The problem was that the ConnectedMonitor option must appear only one time. It seems not to matter where it appears, in either Display or Screen section. Also it must have both devices in it. Specifying the two devices in separate ConnectedMonitor option lines, in the corresponding screen or display sections, does not work. The example given by Tub fits this model, but since there was only a single Screen section in that example, there was enough rope to hang myself when extrapolating to a config with two Screen sections. I probably don't get a vote, but the driver should either merge multiple ConnectedMonitor options correctly, or give an EE when it sees it. Currently it does neither.

The suggested "IgnoreDisplayDevices" was apparently not needed in my configuration.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Thu Mar  5 18:47:52 PST 2009

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Sony CPD-420GS"
    HorizSync       30.0 - 96.0
    VertRefresh     48.0 - 120.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "TV-0"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          0
# The next line can apparently be in any Device or Screen section.
# However, it must appear only ONCE since it seems to be global. Splitting
# CRT-1 and TV-0 into two separate ConnectedMonitor lines does not work!
# At least with 180.37.
    Option         "ConnectedMonitor" "CRT-1,TV-0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "CustomEDID" "CRT-1:/etc/X11/crt1_edid.bin"
    Option         "metamodes" "CRT: 1280x1024 +0+0"
    Option         "UseEvents" "True"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TVOutFormat" "SVIDEO"
    Option         "TVStandard" "NTSC-M"
    Option         "metamodes" "TV: 640x480 +0+0"
    Option         "UseEvents" "True"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
mathog is offline   Reply With Quote
Old 05-15-10, 06:37 PM   #7
tim.rittman
Registered User
 
Join Date: May 2010
Posts: 1
Default Re: force screens 0 and 1 even when no display attached

Wow! You wouldn't believe how long it has taken me to find a solution for this problem. Many thanks!

Just using "ConnectedMonitors" "DFP-0,CRT-1" has enabled me to dual X screen using a GeForce 8600GTS with a DVI monitor and a second monitor using a DVI/VGA adaptor.

Many sincere thanks,

Tim
tim.rittman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Russian Masterpieces Put on Display Using NVIDIA GPU Technology News Archived News Items 0 06-25-12 04:10 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Suse 8.0 Dual display on Quadro 4 700XGL TheCowStir NVIDIA Linux 3 08-10-02 12:16 PM
Dual Display with main CRT, and secondary TV-out BlackDogg NVIDIA Linux 3 08-10-02 09:52 AM

All times are GMT -5. The time now is 09:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.