Go Back   nV News Forums > Graphics Card Forums > NVIDIA GeForce 400/500 Series

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-10-10, 08:21 PM   #1
Smee
Registered User
 
Join Date: Nov 2006
Location: SoCal
Posts: 1,099
Default Replaced my 5870 with a 480. WTF LOAD TIMES?

I'm writing this with a sick feeling in my stomach, I hope there is an easy fix.

I just swapped in a brand new EVGA 480 for my ATI 5870, My load times on BFBC2 quadrupled!! Bad drivers? 197.75 is what I loaded first.

What the hell happened?

EDIT* Ok, I found the DirectX file to edit, which cuts a big chunk off the load time.. The ATI card still loaded it 50% faster.
Smee is offline   Reply With Quote
Old 06-10-10, 08:36 PM   #2
Maverick123w
 
Join Date: Nov 2003
Location: Cincinnati, OH
Posts: 1,841
Send a message via AIM to Maverick123w
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Loads really fast with the beta drivers.
Maverick123w is offline   Reply With Quote
Old 06-10-10, 08:41 PM   #3
Smee
Registered User
 
Join Date: Nov 2006
Location: SoCal
Posts: 1,099
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Quote:
Originally Posted by Maverick123w View Post
Loads really fast with the beta drivers.
I'll give those a try, thanks.
Smee is offline   Reply With Quote
Old 06-10-10, 08:44 PM   #4
Rummy
 
Join Date: Mar 2004
Location: Under your bed
Posts: 1,685
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Yeah that was fixed with the 257.15
Rummy is offline   Reply With Quote
Old 06-10-10, 08:50 PM   #5
mailman2
Ducking & Dodging
 
Join Date: Mar 2008
Posts: 3,948
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Quote:
Originally Posted by Rummy View Post
Yeah that was fixed with the 257.15
+1, 275.15 fixed the slow load times. However, I still think the 5870 was smoother in BF BC2 than the GTX 480 though.
__________________
i7-2600k @ 4.6Ghz, Zotac GTX 680 (1310/7000), 16GB DDR3 1600, 2 x 1TB Samsung F3 RAID 0, Windows 7 x64, CPU and GPU custom watercooled

Quote:
Originally Posted by General Lee View Post
Oh, if the whole world had only one neck for me to squeeze in my hands...
mailman2 is offline   Reply With Quote
Old 06-10-10, 09:20 PM   #6
Smee
Registered User
 
Join Date: Nov 2006
Location: SoCal
Posts: 1,099
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Quote:
Originally Posted by mailman2 View Post
+1, 275.15 fixed the slow load times. However, I still think the 5870 was smoother in BF BC2 than the GTX 480 though.
It was The only reason I upgraded, was because my kids 260 crapped out, So I took it as an opportunity to upgrade... I may take it back, heh.
Smee is offline   Reply With Quote
Old 06-10-10, 09:53 PM   #7
mailman2
Ducking & Dodging
 
Join Date: Mar 2008
Posts: 3,948
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Quote:
Originally Posted by Smee View Post
It was The only reason I upgraded, was because my kids 260 crapped out, So I took it as an opportunity to upgrade... I may take it back, heh.
Well try 275.15. Everything else is faster with GTX 480 though.
__________________
i7-2600k @ 4.6Ghz, Zotac GTX 680 (1310/7000), 16GB DDR3 1600, 2 x 1TB Samsung F3 RAID 0, Windows 7 x64, CPU and GPU custom watercooled

Quote:
Originally Posted by General Lee View Post
Oh, if the whole world had only one neck for me to squeeze in my hands...
mailman2 is offline   Reply With Quote
Old 06-10-10, 10:42 PM   #8
ragejg
nV News Alumni
 
ragejg's Avatar
 
Join Date: Sep 2002
Location: Finger Lakes of Hell, NY
Posts: 5,399
Send a message via AIM to ragejg
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

I have a rig with a 5830 sitting right next to a similar one albeit with a 465. It's kinda funny how much quicker the NV system loads maps, Queen Trigger's already blowin' stuff up by the time I jump in.
__________________

2010-2011 Reviews: GTX 570 | GTX 580 | GTS 450 | GTX 460 | GTX 465
Pre-2010 Reviews: 6600 GT | XMS 4400 DDR | SilenX Cooler | 6800 | 5900 XT | Personal Cinema | 5900 NU


______________________________________________
Phenom II x6 1090t @ 4.0 ghz | Asus M498TD-EVO Am3 SLI nForce 980a | 2x EVGA GTX 560 SLI | 2x4gb DDR3-1333 | Antec EarthWatts EA650 PSU | 60gb Mushkin Calisto Enhanced Sandforce SSD | 2x WD2500KS RAID 0 | Sunbeam Tuniq 3 case | 24" Asus 19x10 LED LCD | 26" Panasonic 720p TV | Sidewinder X5 mouse | Logitech MX5500 & Revolution mouse | Altec Lansing 5.1 THX-Certified audio | Win 7 Ultimate | desk | couch


ragejg is offline   Reply With Quote

Old 06-10-10, 10:47 PM   #9
mailman2
Ducking & Dodging
 
Join Date: Mar 2008
Posts: 3,948
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Quote:
Originally Posted by ragejg View Post
I have a rig with a 5830 sitting right next to a similar one albeit with a 465. It's kinda funny how much quicker the NV system loads maps, Queen Trigger's already blowin' stuff up by the time I jump in.
Make sure you are using the drivers with the ATI fix for map load time. Hate to tell you this but ATI had that fixed about a month before Nvidia did.
__________________
i7-2600k @ 4.6Ghz, Zotac GTX 680 (1310/7000), 16GB DDR3 1600, 2 x 1TB Samsung F3 RAID 0, Windows 7 x64, CPU and GPU custom watercooled

Quote:
Originally Posted by General Lee View Post
Oh, if the whole world had only one neck for me to squeeze in my hands...
mailman2 is offline   Reply With Quote
Old 06-10-10, 10:55 PM   #10
Smee
Registered User
 
Join Date: Nov 2006
Location: SoCal
Posts: 1,099
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

Quote:
Originally Posted by mailman2 View Post
Well try 275.15. Everything else is faster with GTX 480 though.
I am running 275.15, It helped quite a bit, My 5870 still loads/runs this game better imo.
Smee is offline   Reply With Quote
Old 06-11-10, 01:29 AM   #11
Muppet
Registered User
 
Muppet's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 3,130
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

I'm using the 275.15 beta's and Bad Company is super smooth. I get around 90 FPS DX11 everything maxed and 4xaa. Plays really well and absolutely no hitching using SLI.
__________________
Asus Rampage IV Extreme Black Edition | Intel 4930k | SS Phasechange | 16GB Corsair Platinum DDR3 1866 | Asus GTX680 x2 SLI | Corsair AX1200 Watt PSU | Lian-Li PC-8NWX | Intel 520 120Gb SSD x2 | Samsung S27A950D 27" 120Hz | HP ZR24w 24" S-IPS x3 Nvidia Surround @6000x1200 | Xonar Essence STX
Muppet is offline   Reply With Quote
Old 06-11-10, 07:27 AM   #12
mailman2
Ducking & Dodging
 
Join Date: Mar 2008
Posts: 3,948
Default Re: Replaced my 5870 with a 480. WTF LOAD TIMES?

I find it funny how the nvidia only guys claim its so smooth. Coming from an HD5870 I think Smee and I are in agreement that no matter how smooth the GTX 480 plays it, the HD5870 played it much better. Thats the only game I really miss my HD5870 for though. The HD5870 was just alot smoother than the GTX 480 in BF BC2 even with 275.15.
__________________
i7-2600k @ 4.6Ghz, Zotac GTX 680 (1310/7000), 16GB DDR3 1600, 2 x 1TB Samsung F3 RAID 0, Windows 7 x64, CPU and GPU custom watercooled

Quote:
Originally Posted by General Lee View Post
Oh, if the whole world had only one neck for me to squeeze in my hands...
mailman2 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.