Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-22-10, 12:16 PM   #1
dbbolton
Registered User
 
Join Date: Jun 2009
Posts: 4
Default Failed to allocate primary buffer: out of memory

I recently did a fresh install of Debian squeeze. I have the stock 32 kernel along with the 34 from experimental (it is listed as stable by kernel.org). I installed version 195.36.24 of the Nvidia driver using the Nvidia installer, and after starting X the system became unresponsive.
Code:
grep '^(E' /var/log/Xorg.0.log
(EE) May 21 11:28:50 NVIDIA(0): Failed to allocate primary buffer: out of memory.
(EE) NVIDIA(0):  *** Aborting ***
I find this strange considering that I have used this driver with no problem on a 33 kernel and the same video card:
Code:
01:00.0 VGA compatible controller [0300]: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] [10de:01d7] (rev a1) (prog-if 00 [VGA controller])
		Subsystem: ASUSTeK Computer Inc. Device [1043:1212]
		Flags: bus master, fast devsel, latency 0, IRQ 16
		Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
		Memory at c0000000 (64-bit, prefetchable) [size=256M]
		Memory at fd000000 (64-bit, non-prefetchable) [size=16M]
		Expansion ROM at fcfe0000 [disabled] [size=128K
I believe it has 256MB of video memory, and I have 1GB of system memory.

I also built the driver for the stock 2.6.32-3-amd64 kernel and got the same error. I have tried 3 different configuration files:
- the generic "X -config" output, with "nv" substituted with "nvidia", http://paste.debian.net/74284/
- my old working one, http://paste.debian.net/74285/
- and the old one with a different metamode, http://paste.debian.net/74286/

Note that 1280x800 is the correct resolution.

Under "Common Problems" in the README, a similar error is mentioned:
Code:
(EE) NVIDIA(0): Failed to allocate primary buffer: failed to set CPU access
I am already using a 64-bit system, and I don't think I'm using a "large virtual desktop size".

Finally, here is my whole Xorg.0.log file: http://paste.debian.net/74289/
The relevant section:
Code:
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "TwinView" "0"
(**) NVIDIA(0): Option "MetaModes" "DFP: 1280x800 +0+0"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "true"
(**) May 21 18:21:36 NVIDIA(0): Enabling RENDER acceleration
(II) May 21 18:21:36 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) May 21 18:21:36 NVIDIA(0):	 enabled.
(II) May 21 18:21:37 NVIDIA(0): NVIDIA GPU GeForce Go 7300 (G72) at PCI:1:0:0 (GPU-0)
(--) May 21 18:21:37 NVIDIA(0): Memory: 524288 kBytes
(--) May 21 18:21:37 NVIDIA(0): VideoBIOS: 05.72.22.41.ac
(II) May 21 18:21:37 NVIDIA(0): Detected PCI Express Link width: 16X
(--) May 21 18:21:37 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) May 21 18:21:37 NVIDIA(0): Connected display device(s) on GeForce Go 7300 at PCI:1:0:0:
(--) May 21 18:21:37 NVIDIA(0):	 LPL (DFP-0)
(--) May 21 18:21:37 NVIDIA(0): LPL (DFP-0): 330.0 MHz maximum pixel clock
(--) May 21 18:21:37 NVIDIA(0): LPL (DFP-0): Internal Dual Link LVDS
(II) May 21 18:21:37 NVIDIA(0): Display Device found referenced in MetaMode: DFP-0
(II) May 21 18:21:37 NVIDIA(0): Assigned Display Device: DFP-0
(II) May 21 18:21:37 NVIDIA(0): Validated modes:
(II) May 21 18:21:37 NVIDIA(0):	 "DFP:1280x800+0+0"
(II) May 21 18:21:37 NVIDIA(0): Virtual screen size determined to be 1280 x 800
(--) May 21 18:21:37 NVIDIA(0): DPI set to (98, 96); computed from "UseEdidDpi" X config
(--) May 21 18:21:37 NVIDIA(0):	 option
(==) May 21 18:21:37 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) May 21 18:21:37 NVIDIA(0): Initialized GPU GART.
(II) May 21 18:21:37 NVIDIA(0): ACPI display change hotkey events enabled: the X server is new
(II) May 21 18:21:37 NVIDIA(0):	 enough to receive ACPI hotkey events.
(II) May 21 18:21:37 NVIDIA(0): ACPI brightness change hotkey events enabled.
(II) May 21 18:21:37 NVIDIA(0): Setting mode "DFP:1280x800+0+0"
(EE) May 21 18:21:38 NVIDIA(0): Failed to allocate primary buffer: out of memory.
(EE) NVIDIA(0):  *** Aborting ***

Fatal server error:
AddScreen/ScreenInit failed for driver 0
dbbolton is offline   Reply With Quote
Old 06-13-10, 04:46 AM   #2
dbbolton
Registered User
 
Join Date: Jun 2009
Posts: 4
Default Re: Failed to allocate primary buffer: out of memory

Solution: add nopat kernel parameter.

In /etc/default/grub
Code:
GRUB_CMDLINE_LINUX="nopat"
dbbolton is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:44 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.