Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-13-10, 04:08 PM   #1
deva1984
Registered User
 
deva1984's Avatar
 
Join Date: Jun 2010
Posts: 2
Default cann't start x after kernel upgrade to 2.6.32-5-686

hi guys,

i'm running debian squeeze. and updated my linux kernel to 2.6.32-5-686. After built nvidia driver. I found i couldn't start x server.

i suppose the driver installation is ok. though i uploaded install log, with xorg.conf and xorg log. Right now i am using nv driver instead. i also guess there's nothing to do with "nouveau". no such module found by "lsmod".

PS: geforce dirver version is 195.36.24. graphics card NVIDIA Quadro NVS 140M
Attached Files
File Type: log nvidia-installer.log (102.7 KB, 78 views)
File Type: log Xorg.0.log (15.1 KB, 80 views)
File Type: txt xorg.conf.txt (880 Bytes, 79 views)

Last edited by deva1984; 06-14-10 at 07:36 PM.
deva1984 is offline   Reply With Quote
Old 06-14-10, 12:53 PM   #2
deva1984
Registered User
 
deva1984's Avatar
 
Join Date: Jun 2010
Posts: 2
Default Re: cann't start x after kernel upgrade

drat. i've thought the problem was resolved.

since i updated xserver-xorg using "aptitude update/upgrade" this morning, i could start x server now.
but

Quote:
root:/var/log# glxinfo | grep render
Error: glXCreateContext failed
Quote:
root:/var/log# grep -n '^(EE)' Xorg.0.log
131: (EE) Jun 15 01:29:18 NVIDIA(0): Failed to initialize the GLX module; please check in your X
132: (EE) Jun 15 01:29:18 NVIDIA(0): log file that the GLX module has been loaded in your X
133: (EE) Jun 15 01:29:18 NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
134: (EE) Jun 15 01:29:18 NVIDIA(0): you continue to encounter problems, Please try
135: (EE) Jun 15 01:29:18 NVIDIA(0): reinstalling the NVIDIA driver.
i found xserver-xorg apparently replaced the libglx.so file with his own's
Quote:
root:/usr/lib/xorg/modules/extensions# ls -l
total 3492
-rw-r--r-- 1 root root 15168 Jun 3 18:14 libdbe.so
-rw-r--r-- 1 root root 10008 Jun 3 18:14 libdri2.so
-rw-r--r-- 1 root root 33944 Jun 3 18:14 libdri.so
-rw-r--r-- 1 root root 117296 Jun 3 18:14 libextmod.so
-rw-r--r-- 1 root root 332256 Jun 3 18:14 libglx.so
-rwxr-xr-x 1 root root 3014344 Jun 15 01:09 libglx.so.195.36.31
-rw-r--r-- 1 root root 24588 Jun 3 18:14 librecord.so
"glx" lines in Xorg.0.log file
Quote:
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
Then i updated nividia driver to version 195.36.31, and left nothing in xorg.conf file but
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Still meeting the same problem as yesterday, x server crashed.
I upload the both Xorg.0.log files
Attached Files
File Type: txt Xorg.0.log-nvidia.txt (14.9 KB, 88 views)
File Type: txt Xorg.0.log-xorg.txt (15.0 KB, 78 views)

Last edited by deva1984; 06-14-10 at 08:15 PM. Reason: update
deva1984 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.