Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-15-10, 10:02 AM   #1
cedricv
Registered User
 
Join Date: May 2010
Posts: 19
Unhappy Cannot load nVidia driver on U30JC (Optimus)

Hi,


I tried a lot of combinations but am totally unable to load the NVidia driver on a laptop with Optimus (Intel IGD + Nvidia G310M).

Tried every kernel from 2.6.31 up to 2.6.34, even after disabling i915, nouveau and all KMS stuff, irqpoll, the driver fails to load with :

NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:909)
NVRM: rm_init_adapter(0) failed


I guess the problem is related to the Optimus 'wiring' that the G310M
has to share/coordinate some IRQ/resources with the always-on IGD...
Does anyone have a workaround ? Or do I have to wait for a new driver release to fix this ?


Thanks!
cedricv is offline   Reply With Quote
Old 06-21-10, 12:26 AM   #2
cedricv
Registered User
 
Join Date: May 2010
Posts: 19
Default Re: Cannot load nVidia driver on U30JC (Optimus)

up
cedricv is offline   Reply With Quote
Old 06-21-10, 02:04 AM   #3
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Cannot load nVidia driver on U30JC (Optimus)

Read this first:

http://www.nvnews.net/vbulletin/showthread.php?t=46678

Attach xorg/nvidia logs and bug reports (as explained in the above sticky).
gradinaruvasile is offline   Reply With Quote
Old 06-21-10, 03:00 AM   #4
cedricv
Registered User
 
Join Date: May 2010
Posts: 19
Default Re: Cannot load nVidia driver on U30JC (Optimus)

Sorry about that, here they are with my latest attempts with just released 256.35 driver.

Interestingly I did not notice before these "Invalid ROM contents" messages before the rmInitAdapter failure :

nvidia 0000:01:00.0: Invalid ROM contents
nvidia 0000:01:00.0: Invalid ROM contents
nvidia 0000:01:00.0: Invalid ROM contents
nvidia 0000:01:00.0: Invalid ROM contents
NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:819)
NVRM: rm_init_adapter(0) failed



(maybe these messages were added in the .35 release?)


Regards,
Attached Files
File Type: gz nvidia-bug-report-rminitadapter.log.gz (37.5 KB, 131 views)
File Type: gz nvidia-bug-report-useint10.log.gz (37.2 KB, 116 views)
cedricv is offline   Reply With Quote
Old 06-21-10, 06:16 AM   #5
P.Kosunen
Registered User
 
Join Date: Jan 2009
Posts: 57
Default Re: Cannot load nVidia driver on U30JC (Optimus)

Quote:
Originally Posted by cedricv View Post
Does anyone have a workaround ?
Try to set SATA to compatibility mode from BIOS.

http://ubuntuforums.org/showpost.php...6&postcount=34
P.Kosunen is offline   Reply With Quote
Old 06-21-10, 07:03 AM   #6
cedricv
Registered User
 
Join Date: May 2010
Posts: 19
Default Re: Cannot load nVidia driver on U30JC (Optimus)

Thanks for the idea! Just tried it (on U30JC the menu is slightly different in Bios but can select IDE instead of AHCI) ... and unfortunately get same result

Logs below.
Attached Files
File Type: gz nvidia-bug-report-ide.log.gz (60.4 KB, 123 views)
cedricv is offline   Reply With Quote
Old 06-21-10, 08:11 AM   #7
cedricv
Registered User
 
Join Date: May 2010
Posts: 19
Default Re: Cannot load nVidia driver on U30JC (Optimus)

FWIW since it seems the issue might be related to vbios in some way I also tried the UseVBios=0 workaround... same result

Code:
nvidia 0000:01:00.0: Invalid ROM contents
NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:819)
NVRM: rm_init_adapter(0) failed

I said it could be related to vbios in some way since it seems the driver cannot detect/recognize its bios :

Code:
/proc/driver/nvidia/cards/0
Model: 		 GeForce 310M
IRQ:   		 16
Video BIOS: 	 ??.??.??.??.??
Card Type: 	 PCI-E
DMA Size: 	 32 bits
DMA Mask: 	 0xffffffff
Bus Location: 	 0000:01.00.0

log with UseVBios=0 below...
Attached Files
File Type: gz nvidia-bug-report-usevbios0.log.gz (38.8 KB, 156 views)

Last edited by cedricv; 07-30-10 at 04:05 AM.
cedricv is offline   Reply With Quote
Old 06-22-10, 12:02 AM   #8
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Cannot load nVidia driver on U30JC (Optimus)

Just an idea - try blacklisting the intel's video driver too (and disable kms in it too). See if it helps.
gradinaruvasile is offline   Reply With Quote

Old 06-22-10, 12:26 AM   #9
cedricv
Registered User
 
Join Date: May 2010
Posts: 19
Default Re: Cannot load nVidia driver on U30JC (Optimus)

As you can see in the logs there is no other video driver loaded at all, no kms, no intel, no i915, no nouveau etc...
cedricv is offline   Reply With Quote
Old 06-22-10, 12:21 PM   #10
dpeinado
Registered User
 
Join Date: Jun 2010
Posts: 3
Default Re: Cannot load nVidia driver on U30JC (Optimus)

I'm having the same problem. Well now, I'm having the same problem because I'm having all the problems that can be had installing the drivers for my nvidia G210 with ubuntu, fedora, debian. I've followed carefully all instructions from nvidia installer README, a lot of different posts, and I can not install the card. I need some 3D acceleration for paraview, so I think I will by an older nvidia card (drivers 173), and try to, because with this new nvidia cards, I can not find a solution. (I think that there is a lot of people having the same problems: new nvidia + new computers + new linux kernels = http://www.nvnews.net/vbulletin/imag...es/pirate1.gif)
But yes, I also have the problem of not recognizing the nvidia card bios. If you find a solution please let me know.

Thanks.
dpeinado is offline   Reply With Quote
Old 06-22-10, 12:54 PM   #11
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Cannot load nVidia driver on U30JC (Optimus)

I have a 210 and it works all right in Debian Squeeze/Ubuntu (always did)... Just disable nouveau+kms and make sure there are no nvidia packages installed.
gradinaruvasile is offline   Reply With Quote
Old 06-22-10, 04:27 PM   #12
cedricv
Registered User
 
Join Date: May 2010
Posts: 19
Default Re: Cannot load nVidia driver on U30JC (Optimus)

The problem is very likely _not_ related to the model (G210 or 310M) but to the particular "wiring" on laptops/mobos with an Intel IGD working at all times (Optimus-style) ...

Would be nice to have a word from NVidia about this, after checking nvidia-bug-report's logs below of course
cedricv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.