Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-31-10, 11:49 PM   #1
hyc
Registered User
 
Join Date: May 2010
Posts: 6
Default backlight problem after standby mode

I first noticed this problem in the 195 driver, but it's still present in 256.25 and 256.29.

I have a Dell Precision M4400 with Quadro 770M. After going into standby and resuming, the driver no longer turns off the backlight when the display goes idle. Instead, it goes to full brightness, and the framebuffer is all white. The same occurs if you just close the laptop lid - instead of turning off the backlight, it turns it on at full brightness and you can see bright white light shining thru the gap between the lid and the laptop body.

On a separate note, whenever I use the Nvidia Settings applet and select GPU 0 Thermal Settings the applet immediately crashes.

The applet bug is just a minor annoyance, the backlight bug is quite aggravating because it's a drain on the battery.
Attached Files
File Type: gz nvidia-bug-report.log.gz (125.3 KB, 69 views)
hyc is offline   Reply With Quote
Old 06-03-10, 01:58 PM   #2
hyc
Registered User
 
Join Date: May 2010
Posts: 6
Default Re: backlight problem after standby mode

Followup - it's not just after standby. It also happens after the notebook has been on for several hours. Nobody else is seeing this problem?
hyc is offline   Reply With Quote
Old 06-03-10, 02:37 PM   #3
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: backlight problem after standby mode

Hi hyc,

Did older versions of the driver work correctly? What was the last version that worked?

Do you get the same problem if you turn off DPMS with `xset dpms force off`? (Easier than suspending the machine or waiting for the display to shut off on its own.)
danix is offline   Reply With Quote
Old 06-04-10, 01:20 AM   #4
hyc
Registered User
 
Join Date: May 2010
Posts: 6
Default Re: backlight problem after standby mode

Yes, once it has started happening, "xset dpms force off" does the same thing, thanks for that tip.

Sorry, I don't know about any older driver versions because I haven't had this laptop for that long. I only know about 195.36.15, 256.25, and 256.29.
hyc is offline   Reply With Quote
Old 06-04-10, 01:27 AM   #5
hyc
Registered User
 
Join Date: May 2010
Posts: 6
Default Re: backlight problem after standby mode

I have gdm disabled, so I login to a plain tty and run startx to get a desktop session going. When this problem starts happening, if I logout of my session and run startx again, the problem remains.

If I logout and rmmod nvidia, then modprobe nvidia, and startx, the problem remains.

If I logout and do a warm boot, the problem remains. Is this perhaps a BIOS issue, not a driver issue? The only way to get things working again is to power cycle the laptop.
hyc is offline   Reply With Quote
Old 06-04-10, 04:27 PM   #6
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: backlight problem after standby mode

Thanks for the clarification. When you said you first noticed the problem in the 195 driver, I thought that you meant that you hadn't noticed it in driver version before that.

When you say that `xset force dpms off` does the same thing once it starts happening, do you mean that turning DPMS off when the machine has not been on for a very long time works normally, but after it has been on for a while, it will fail?

A quick experiment that might point to whether this issue exists in the NVIDIA driver is to run your X server with the vesa driver, and try to induce the problem.
danix is offline   Reply With Quote
Old 06-05-10, 02:24 AM   #7
hyc
Registered User
 
Join Date: May 2010
Posts: 6
Default Re: backlight problem after standby mode

Right. On a fresh cold boot, "xset dpms force off" turns off the backlight. When the problem starts happening, this command has the same effect - backlight on full, screen all white. I wish I could identify one specific cause of it, but so far no idea.

I could try the vesa driver, but it might take a few days for any problem to surface. Won't really have conclusive evidence one way or the other.

I also was wondering if this could somehow be related to VDPAU accelerated video playback, because nothing else I do on this machine is particularly relevant to the GPU. But I do occasionally watch H264 videos with mplayer and vdpau. But I haven't been able to reproduce it from that yet either.
hyc is offline   Reply With Quote
Old 06-27-10, 07:47 AM   #8
hyc
Registered User
 
Join Date: May 2010
Posts: 6
Default Re: backlight problem after standby mode

I've updated to 256.35 and the problem still occurs. It seems pretty definitely to be triggered by running mplayer with VDPAU playing FLV videos.
hyc is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.