Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-30-10, 10:49 PM   #61
andrewju
Registered User
 
Join Date: Nov 2007
Posts: 12
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by Stephen Warren View Post
andrewju,

Can you please provide an "nvidia bug report" (see forum sticky post), and also a copy of /proc/asound/card*/eld*, from when you are playing audio through MPlayer. Thanks.
Sure!

Code:
# cat /proc/asound/card*/eld*
monitor_present         1
eld_valid               1
monitor_name            SONY TV

connection_type         HDMI
eld_version             [0x2] CEA-861D or below
edid_version            [0x3] CEA-861-B, C or D
manufacture_id          0xd94d
product_id              0x8400
port_id                 0x20000
support_hdcp            0
support_ai              0
audio_sync_delay        0
speakers                [0x1] FL/FR
sad_count               1
sad0_coding_type        [0x1] LPCM
sad0_channels           2
sad0_rates              [0xe0] 44100 48000 88200
sad0_bits               [0xe0000] 16 20 24
Attached Files
File Type: gz nvidia-bug-report.log.gz (33.7 KB, 80 views)
andrewju is offline   Reply With Quote
Old 07-31-10, 03:11 AM   #62
andrewju
Registered User
 
Join Date: Nov 2007
Posts: 12
Default Re: Enable audio through HDMI on GT240

I discovered that adding '-srate 44100' or '-srate 48000' to mplayer run string, solves the problem of having no audio in the "problematic" files. This doesn't look like a good solution to me, though...
andrewju is offline   Reply With Quote
Old 07-31-10, 03:20 AM   #63
lintweaker
Registered User
 
Join Date: Oct 2004
Posts: 44
Lightbulb Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by andrewju View Post
Sure!

Code:
# cat /proc/asound/card*/eld*
monitor_present         1
eld_valid               1
monitor_name            SONY TV

connection_type         HDMI
eld_version             [0x2] CEA-861D or below
edid_version            [0x3] CEA-861-B, C or D
manufacture_id          0xd94d
product_id              0x8400
port_id                 0x20000
support_hdcp            0
support_ai              0
audio_sync_delay        0
speakers                [0x1] FL/FR
sad_count               1
sad0_coding_type        [0x1] LPCM
sad0_channels           2
sad0_rates              [0xe0] 44100 48000 88200
sad0_bits               [0xe0000] 16 20 24
I guess you are right about the mismatch betweens your clip's sample rate and the minimum your TV supports. I also have trouble playing sounds which do not have at least the minimum sample rate of 44100 (even when using plughw).

On my system there are several 22050 Hz files in /usr/share/sounds/purple which won't produce sound from HDMI out. Only after upconversion to 44100 I get sound (tested with sndfile-resample).
lintweaker is offline   Reply With Quote
Old 07-31-10, 07:20 AM   #64
andrewju
Registered User
 
Join Date: Nov 2007
Posts: 12
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by lintweaker View Post
I guess you are right about the mismatch betweens your clip's sample rate and the minimum your TV supports. I also have trouble playing sounds which do not have at least the minimum sample rate of 44100 (even when using plughw).
I never had such problems with an older card (8600GT). Is it possible that upconversion was somehow done by itself, without me specifying it in mplayer options?

Other question is what are the side effects of having an upconversion "by default". What will happen if I have a DD / DTS audio stream and try to upconvert it as well?


EDIT: In my mplayer log I posted earlier, it looks like mplayer detects a 32000 Hz stream in the file, but outputs only a 22050Hz stream (if I do not specifically tell it to upconvert to 44100). I think this might be the key... How do I find out why mplayer does this 32000 --> 22050 conversion?
andrewju is offline   Reply With Quote
Old 08-02-10, 10:16 AM   #65
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Enable audio through HDMI on GT240

andrewju, from your description, it sounds like MPlayer simply gives up and doesn't output any sound if the HW doesn't support the sample rate of the audio in the file. Perhaps somebody more familiar with MPlayer's internals can confirm/deny this behaviour.

Your TV doesn't support 22050/32000 directly, which is relevant, because digital audio is being sent directly to it with your new card. I think with your 8600, you were using the analog output from your sound-card and looping that into the 8600 using a cable? In that case, the sound card may have supported those other sample rates, which the 8600 then digitized at one of the TV's supported sample rates?
Stephen Warren is offline   Reply With Quote
Old 08-02-10, 10:55 AM   #66
andrewju
Registered User
 
Join Date: Nov 2007
Posts: 12
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by Stephen Warren View Post
andrewju, from your description, it sounds like MPlayer simply gives up and doesn't output any sound if the HW doesn't support the sample rate of the audio in the file. Perhaps somebody more familiar with MPlayer's internals can confirm/deny this behaviour.
If I understand mplayer log correctly, it does output sound. But it converts the sampling rate from 33000 to 22050 Hz, for some (unknown) reason.


Quote:
Originally Posted by Stephen Warren View Post
Your TV doesn't support 22050/32000 directly, which is relevant, because digital audio is being sent directly to it with your new card.
I played with 'speaker-test' a bit and it looks like my TV is able to decode 33000 Hz stream (I can hear the test noise), but not 22050 Hz one. So I think my sound could have been fine, if mplayer didn't change the sampling rate.

Quote:
Originally Posted by Stephen Warren View Post
I think with your 8600, you were using the analog output from your sound-card and looping that into the 8600 using a cable? In that case, the sound card may have supported those other sample rates, which the 8600 then digitized at one of the TV's supported sample rates?
I used an S/PDIF cable from my onboard audio to the 8600GT. So it wasn't analog, but still it was quite a different set up. Unfortunately I don't have any mplayer logs stored since that time, so I can't check how it was behaving in that configuration...
andrewju is offline   Reply With Quote
Old 08-03-10, 10:55 AM   #67
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Enable audio through HDMI on GT240

I wonder if the problem is this: From your "eld" file, your TV only supports 44100 48000 88200. However, from /proc/asound/card1/codec#1, the audio device exposes more rates: 32000 44100 48000 88200 96000 176400 192000. I guess for 22050/32000 audio, MPlayer or the ALSA library up-converts it to the lowest rate supported by the audio codec (32000) and the TV simply ignores any audio at this unsupported sample rate. I'll have to look into how this is meant to work...

Could you try one more test for me: Please try playing back a 96000Hz sample (use -srate to upconvert to that). I assume that'll also appear to succeed in MPlayer, but again you'll hear no audio?
Stephen Warren is offline   Reply With Quote
Old 08-03-10, 12:48 PM   #68
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Enable audio through HDMI on GT240

andrewju, I asked on the ALSA developers mailing list, and the ALSA driver is supposed to limit the list of supported sample rates to those that really are; basically what I said just above. However, this code isn't implemented yet, and I believe should be part of the core ALSA audio driver, rather than something NVIDIA-specific:

http://mailman.alsa-project.org/pipe...st/030109.html

Unfortunately, that probably means that NVIDIA isn't going to be able to do anything about this in the short-term.

That said, given ALSA's flexible configuration files, I wonder if this problem could be solved there; you'd probably want to ask about that on the alsa-users mailing list.
Stephen Warren is offline   Reply With Quote

Old 08-05-10, 01:29 PM   #69
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Enable audio through HDMI on GT240

andrewju, are you able to recompile the ALSA kernel driver yourself? If so, the patch linked below might help with your issue.

http://mailman.alsa-project.org/pipe...st/030209.html
Stephen Warren is offline   Reply With Quote
Old 08-06-10, 03:25 AM   #70
andrewju
Registered User
 
Join Date: Nov 2007
Posts: 12
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by Stephen Warren View Post
andrewju, are you able to recompile the ALSA kernel driver yourself? If so, the patch linked below might help with your issue.

http://mailman.alsa-project.org/pipe...st/030209.html
Ah, I'll give it a try! Thanks!

Will post here my results afterward.
andrewju is offline   Reply With Quote
Old 08-13-10, 08:24 AM   #71
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by zim2dive View Post
Ok, moving sideways
Code:
>more /etc/modprobe.d/sound.conf 
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2
at this point, I have working sound from 1,3... and I have sound from Rhythmbox.. the Sound preference panel refuses to launch. So does the Pulseaudio sound panel, they used to launch. I'm using
Code:
pcm.!default hdmi:NVidia
pcm:iec958 hdmi:NVidia
EDIT: Flash sound ok after all.
EDIT2: I got Sound panel and Pulseaudio volume working. .I had to edit /etc/pulse/default.pa and comment out the line
Code:
load-module module-alsa-sink device=hw:1,3
Now I can launch the panel and get system sounds out HDMI. Need to go back and test everything else (will be tomorrow).

Working: *maybe* everything
Is there anything about this setup that would prevent me getting audio out my on-board analog outputs?

ie. I'd like to use HDMI audio to my AVR, but also send the front left+right of the same audio out the analog 2-ch output on the mobo rear connector for use in Zone 2 (speakers outside on the back deck).

I have not been able to get *any* audio out that port... even when I specify speaker-test with 0,0.

I wasn't sure if the .asoundrc and/or modprobe could be redirecting everything away from 0,0 to my HDMI on 1,3.

I'm going to play with Alsa slave/copy over the weekend, but was surprised that 0,0 didn't work with speakertest (suggesting some more basic level issue)

thanks,
Mike
zim2dive is offline   Reply With Quote
Old 08-13-10, 10:27 AM   #72
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Enable audio through HDMI on GT240

andrewju,

FYI, the patch I mentioned is now in ALSA git: http://git.kernel.org/?p=linux/kerne...3382644257cfc3

Also, it's in the very latest snapshot file at ftp://ftp.kernel.org/pub/linux/kerne...a/alsa-driver/ (alsa-driver-snapshot.tar.bz2, not any of the dated versions yet)
Stephen Warren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.