Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-10-03, 07:33 AM   #1
Mark_krak
Registered User
 
Join Date: Nov 2003
Posts: 1
Unhappy NVIDIA's OpenGL solution - very slow...

I tried to accelerate graphics output (NVidia TNT2/Vanta, * MB) using current 1.0-4496 drivers taken directly from NVidia's site. Surprisingly, OpenGL output is MUCH SLOWER now, when comparing to the one before replacement of the OpenGL drivers shipped originally with XFree86...

Are the drivers broken, or there are any special settings to be included?

Debian Woody, XFree 4.2.1, kernel 2.4.22

XF86Config-4:
===============================
Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
FontPath "/usr/lib/X11/fonts/latin2/100dpi"
FontPath "/usr/lib/X11/fonts/latin2/75dpi"
FontPath "/usr/lib/X11/fonts/ucs/100dpi"
FontPath "/usr/lib/X11/fonts/ucs/75dpi"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/latin2/Type1"
FontPath "/usr/lib/X11/fonts/freefonts"
FontPath "/usr/lib/X11/fonts/kwintv"
FontPath "/usr/lib/X11/fonts/sharefonts"
FontPath "/usr/lib/X11/fonts/uni"
FontPath "/usr/lib/X11/fonts/latin2/misc"
FontPath "/usr/lib/X11/fonts/ucs/misc"
FontPath "/usr/lib/X11/fonts/mozilla-fonts"
FontPath "/usr/lib/X11/fonts/truetype"
EndSection

Section "Module"
# Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "pex5"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xie"
EndSection

Section "InputDevice" Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "pl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
# Driver "nv"
Driver "nvidia"
Option "NvAgp" "1"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28-50
VertRefresh 43-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "1024x768" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "800x600" "1024x768" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "1024x768" "640x480"
Virtual 1280 1024
EndSubSection
SubSection "Display Depth 24
Modes "800x600" "1024x768" "640x480"
Virtual 1280 1024
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

### END DEBCONF SECTION


===============================

Parts of /var/log/XFree86.0.log:

===============================
[..]
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
[..]
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Video Driver
[..]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(--) NVIDIA(0): Linear framebuffer at 0xD6000000
(--) NVIDIA(0): MMIO registers at 0xD4000000
(II) NVIDIA(0): NVIDIA GPU detected as: Vanta/Vanta LT
(--) NVIDIA(0): VideoBIOS: 02.05.13.00.00
(--) NVIDIA(0): VideoRAM: 8192 kBytes
(II) NVIDIA(0): Connected display device(s): CRT-0
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 8 bpp: 250 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 16 bpp: 250 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 32 bpp: 215 MHz
[..]
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) NVIDIA(0): Setting mode "800x600"

[..]
===============================
Mark_krak is offline   Reply With Quote
Old 11-10-03, 06:03 PM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

There is no GL driver shipped with X, there is software rendering support however. You get better performance with that? Were you able to run glxgears or glxinfo prior to installing the drive?

Have you tried using agpgart rather than nvagp? You might also consider disabling acpi, apic, and apm through kernel command line parameters.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-11-03, 02:28 AM   #3
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

The output of glxinfo would be quite usefull to see if you set up opengl correctly. Quite often some mesa files are present on systems which make opengl performance very slow.

Else if everything is really correct the amount of video memory might be a problem as it seems your card only contains 8MB.
Thunderbird is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL book Airstrip1 Software Development 2 08-12-12 08:55 AM
Evidon and Adobe Tag Manager Privacy Solution Launches! News Archived News Items 0 05-15-12 05:30 AM
NV30 name poll sancheuz NVIDIA GeForce 7, 8, And 9 Series 72 10-19-05 01:23 AM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 09:58 PM
Slow OpenGL on 7.3 kl899 NVIDIA Linux 1 08-04-02 07:58 PM

All times are GMT -5. The time now is 04:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.