Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-20-10, 01:02 PM   #1
nece228
Registered User
 
Join Date: Jun 2010
Posts: 9
Default Enabling blur in kwin slows down the desktop effects

hi,
we know that kde 4.5 will use blur again. So when i enable blur, the window movement becomes choppy, animations become laggier. Kwin developer said that its because GLSL usage, and its nvidia's driver foult. Any plans to fix this issue?
nece228 is offline   Reply With Quote
Old 08-10-10, 10:30 PM   #2
gqman69
Registered User
 
Join Date: Aug 2008
Posts: 35
Default Re: Enabling blur in kwin slows down the desktop effects

Ya what's up with this?

Using Compiz blur seems to work just fine!?!?!
gqman69 is offline   Reply With Quote
Old 08-11-10, 02:59 AM   #3
drhirsch
Registered User
 
Join Date: Jul 2005
Posts: 61
Default Re: Enabling blur in kwin slows down the desktop effects

It's slow for me too.

But I don't really buy that this is only nvidias fault.

There is an problem with the blur effect on ATI cards too http://osdir.com/ml/kwin/2010-06/msg00016.html and compiz blur works without big performance hits.

I read it as "its because of wrong GLSL usage"

Keep in mind, the blur effect was so bugged, that is was removed until kde 4.5.
drhirsch is offline   Reply With Quote
Old 08-11-10, 07:15 AM   #4
nece228
Registered User
 
Join Date: Jun 2010
Posts: 9
Default Re: Enabling blur in kwin slows down the desktop effects

Well the blur effect doesnt slow down effects in other nvidia cards. I can confirm that the slowdown is on geforce 9500gt, because i tried two different pcs with different distro. You dont see slowdown with compiz because it uses opengl 1.4, while kwin uses opengl 3, and it looks like nvidia doesnt support opengl 3 blur very well. According to Martin Graesslin this is 100% nvidia binary driver foult. So please developers fix that.
nece228 is offline   Reply With Quote
Old 08-11-10, 02:32 PM   #5
drhirsch
Registered User
 
Join Date: Jul 2005
Posts: 61
Default Re: Enabling blur in kwin slows down the desktop effects

Quote:
Well the blur effect doesnt slow down effects in other nvidia cards
I have a 8800GT and a slowdown/high cpu usage with blur.
drhirsch is offline   Reply With Quote
Old 08-11-10, 04:13 PM   #6
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Enabling blur in kwin slows down the desktop effects

Quote:
Originally Posted by nece228 View Post
You dont see slowdown with compiz because it uses opengl 1.4, while kwin uses opengl 3, and it looks like nvidia doesnt support opengl 3 blur very well.
OpenGL3 blur? Where did you grab this one?

- Clemens
Linuxhippy is offline   Reply With Quote
Old 08-12-10, 01:41 PM   #7
nece228
Registered User
 
Join Date: Jun 2010
Posts: 9
Default Re: Enabling blur in kwin slows down the desktop effects

ok ok sorry, thats my bad grammar. i meant that slowdown doesnt happen on all nvidia video cards, for some it works fine, for some it doesnt. and opengl 3 blur, well, its my grammar again. i just meant the whole opengl 3 technology.
nece228 is offline   Reply With Quote
Old 08-14-10, 12:33 PM   #8
Arup
Registered User
 
Join Date: May 2009
Posts: 122
Default Re: Enabling blur in kwin slows down the desktop effects

With a 8400GS it doesn't slow down but it definitely spikes up xorg cpu usage, one of my 8 cores in the dual xeon would regularly hit 34%+ till I turned off blur.
Arup is offline   Reply With Quote

Old 08-14-10, 03:30 PM   #9
Ralph
Registered User
 
Join Date: Jul 2007
Posts: 74
Default Re: Enabling blur in kwin slows down the desktop effects

GeForce 8400GS - CPU AMD64 AthlonX2.

KDE 4.5 - display FPS enabled in desktop effects.

Blur enabled: 30 FPS.
Blur disabled: 70 FPS.

I do not think the problem is related to nVidia drivers; the real problem is that whoever created the blur effect seems not a programming genius ...
Ralph is offline   Reply With Quote
Old 08-14-10, 03:53 PM   #10
nece228
Registered User
 
Join Date: Jun 2010
Posts: 9
Default Re: Enabling blur in kwin slows down the desktop effects

Quote:
Originally Posted by Ralph View Post
GeForce 8400GS - CPU AMD64 AthlonX2.

KDE 4.5 - display FPS enabled in desktop effects.

Blur enabled: 30 FPS.
Blur disabled: 70 FPS.

I do not think the problem is related to nVidia drivers; the real problem is that whoever created the blur effect seems not a programming genius ...
Personally i would trust a developer more than some nVidia lover or should I say "fanboy". The fact is that nvidia binary driver is far from perfection when you compare it with windows driver, so blaming nvidia driver for that is logical step i believe.
nece228 is offline   Reply With Quote
Old 08-14-10, 07:03 PM   #11
brucecadieux
Registered User
 
Join Date: Dec 2008
Posts: 78
Default Re: Enabling blur in kwin slows down the desktop effects

So are we to assume every time there is a bug in KDE kwin we should blame it on nvidia?

I mean seriously do you realize how ridiculous that sounds

Have been using KDE for a lot of years now and have seen some pretty funky behavior with a variety of different video cards and drivers over the years.

Far fewer with nvidia drivers then lets say ummm Intel, ATI, VIA CHROME, Matrox..............

That said, I have the blur effect disabled on all my macines two with nvidia, one with Intel, and one with ATI.

Blur effect is a resource pig.
brucecadieux is offline   Reply With Quote
Old 08-14-10, 10:59 PM   #12
hl_
Registered User
 
Join Date: Feb 2009
Posts: 138
Default Re: Enabling blur in kwin slows down the desktop effects

I've seen KDE/Qt devs point fingers more than enough (not only to NVidia).
They're not wrong, ever. Everyone else this. If something is done in accordance with a specification, it Must Work, and it is irrelevant if all major implementations actually don't support it well.
OK, I exaggerated a bit, but you get the point. I hate this kind of ignorance.
hl_ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:09 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.