Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-07-10, 05:22 AM   #25
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Poor 2D Performance

Does your GPU have dynamic clock setings (multiple performance levels)? Check in nvidia-settings -> PowerMizer.
gradinaruvasile is offline   Reply With Quote
Old 08-07-10, 02:57 PM   #26
progger1986
Registered User
 
Join Date: Aug 2008
Posts: 19
Default Re: Poor 2D Performance

It has just one performance level.
progger1986 is offline   Reply With Quote
Old 08-09-10, 01:35 AM   #27
Alejandro Nova
Registered User
 
Join Date: Sep 2006
Posts: 26
Default Re: Poor 2D Performance

Check again. I'm getting great results with the 256 series drivers. Also, you can mitigate the slowdowns by ensuring that the following options are DISABLED (one of them aggravates the leak, the other one replicates functionality present in the NVIDIA driver)

Option "TripleBuffer" "on" #it must be off
Option "BackingStore" "on" #ditto

Also, play with KWin settings. My best results are with Direct Rendering enabled. KDE 4.5 has done a serious bugfixing with that mode, and KDE 4.6 is set to revamp their entire compositing engine.
Alejandro Nova is offline   Reply With Quote
Old 08-09-10, 03:27 PM   #28
gisl
Registered User
 
Join Date: Jul 2010
Posts: 6
Default Re: Poor 2D Performance

I was also experiencing a very sluggish desktop (using KDE and some GTK apps). gtkperf reported some very slow 12.5s for 100 test rounds of everything.

Quote:
Originally Posted by gradinaruvasile View Post
Does your GPU have dynamic clock setings (multiple performance levels)? Check in nvidia-settings -> PowerMizer.
Taking a look there I noticed that nvidia-settings reported GPUPowerSource = 1 (Battery) even though I was on AC. The PowerMizer mode was set to "Adaptive". So I unplugged that cable, plugged it in again. nvidia-settings still showed to be on battery. I restarted nvidia-settings, and then 2d performance was suddenly great again! The tool still reports to be on battery, though.

I'm not sure what it was that did the trick (un- and re-plugging in the cable or restarting nvidia-settings, or both), but I'm happy that the system is usable again. gtkperf reports some reasonable 2.5s now.

EDIT: I'm not using the 256 driver yet, but 195.36.
gisl is offline   Reply With Quote
Old 08-11-10, 02:22 AM   #29
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: Poor 2D Performance

Quote:
Originally Posted by gisl View Post
EDIT: I'm not using the 256 driver yet, but 195.36.
do try the latest driver 256.44 as some PowerMizer issues have been fixed.
Licaon is offline   Reply With Quote
Old 08-13-10, 02:49 PM   #30
progger1986
Registered User
 
Join Date: Aug 2008
Posts: 19
Default Re: Poor 2D Performance

Problem seems to be fixed with 256.44
progger1986 is offline   Reply With Quote
Old 08-19-10, 05:14 AM   #31
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Re: Poor 2D Performance

I have a 8400GS with OpenSUSE 11.3.

I fixed the Firefox scrolling lag by going to Edit->Preferences->Advanced and unchecking "Smooth scrolling".

Hope it helps someone.
DeiF is offline   Reply With Quote
Old 08-19-10, 07:58 AM   #32
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: Poor 2D Performance

Quote:
Originally Posted by DeiF View Post
I have a 8400GS with OpenSUSE 11.3.

I fixed the Firefox scrolling lag by going to Edit->Preferences->Advanced and unchecking "Smooth scrolling".

Hope it helps someone.
I've never used smooth scrolling in Linux with my 8600m gt, it's always been super slow, no matter what dist/de/driver.
Fackamato is offline   Reply With Quote

Old 08-19-10, 09:50 AM   #33
hl_
Registered User
 
Join Date: Feb 2009
Posts: 138
Default Re: Poor 2D Performance

I guess you can blame Firefox for that, not X or the GPU driver.
hl_ is offline   Reply With Quote
Old 08-19-10, 09:52 AM   #34
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: Poor 2D Performance

Quote:
Originally Posted by hl_ View Post
I guess you can blame Firefox for that, not X or the GPU driver.
Maybe. I don't know, but of course, it's a possibility.
Fackamato is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.