Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-06-10, 10:49 AM   #25
dront78
Registered User
 
dront78's Avatar
 
Join Date: Nov 2007
Location: Moscow
Posts: 11
Default Re: 185.18.14 on Dell M1730 - SLI hangs

I'm really glad to see that SLI begans to work since i having such issues with Dell M1730 described here
http://www.nvnews.net/vbulletin/showthread.php?t=137719
Also i waiting for UseEvents to be fixed soon.

Regards!
dront78 is offline   Reply With Quote
Old 05-11-10, 01:59 AM   #26
wiresquire
Registered User
 
Join Date: Mar 2008
Posts: 81
Default Re: 185.18.14 on Dell M1730 - SLI hangs

Have you tried running SLI at 1920x1200 fullscreen? You will see some epilepsy inducing flickering.....

ws
wiresquire is offline   Reply With Quote
Old 05-18-10, 06:27 AM   #27
Nappers
Registered User
 
Join Date: Aug 2008
Posts: 11
Default Re: 185.18.14 on Dell M1730 - SLI hangs

Hi, I just noticed this thread and thought I'd throw in my two cents...
I have a Dell XPS M1730 with a 2.6.34 kernel and the 195.36.24 nvidia drivers (installed using nvidia-kernel-dkms in Debian). I was getting the flickering with SLI enabled (full screen flicker with AFR and lower half screen flicker with SFR). However, there is a workaround for avoiding the epileptic-fit-inducing flickering: disable the "Allow Flipping" setting in "OpenGL Settings" with the nvidia-settings utility... at least, that works for me. :-)

Cheers,
Nappers.
Nappers is offline   Reply With Quote
Old 05-27-10, 07:18 PM   #28
wiresquire
Registered User
 
Join Date: Mar 2008
Posts: 81
Default Re: 185.18.14 on Dell M1730 - SLI hangs

Just came across your reply. Thanks!

I tried this and setting Allow Flipping off does stop the flickering! It also stops Compiz from flickering when, eg using some special effect, but......
(you knew there would be a but, didn't you?)

Seems that the GL/3D performance of SLI on with Allow Flipping off is WORSE than using a single GPU with Allow Flipping on. I get ~ 12% increase in performance by going back to single gpu with Allow Flipping on.

So, for all intents and purposes, SLI on these machines is still useless.

Sigh
ws
wiresquire is offline   Reply With Quote
Old 05-28-10, 07:20 AM   #29
Nappers
Registered User
 
Join Date: Aug 2008
Posts: 11
Default Re: 185.18.14 on Dell M1730 - SLI hangs

Heh, yeah the frame rate is not as good as I'd expect from enabling SLI, though it's good enough for me most of the time. I've run a few "benchmarks" and get the following results (yes, I know glxgears is not a proper benchmark; NWN frame rates were measured at the same location in the game)...

with Option "SLI" "Auto" in xorg.conf without Allow Flipping :
glxgears with kwin compositing: ~2000FPS
glxgears without kwin compositing: ~9800FPS
glxgears -fullscreen with kwin compositing: ~410FPS
glxgears -fullscreen without kwin compositing: ~560FPS
compiz benchmark (sync to vblank disabled in compiz and nvidia-settings): ~240FPS
glxgears in compiz: ~4100FPS (whole display freezes but glxgears runs in the background until Esc is hit)
glxgears -fullscreen in compiz (unredirect fullscreen windows enabled): ~480FPS
glxgears -fullscreen in compiz (unredirect fullscreen windows disabled): ~410FPS
NWN with compiz 45-50FPS
NWN with kwin 45-50FPS
NWN with just X 45-50FPS

with Option "SLI" "Auto" in xorg.conf with Allow Flipping enabled in nvidia-settings (and getting epileptic fit inducing flickering of doom...) :
glxgears with kwin compositing: ~4000FPS (display freezes but glxgears runs in the background until Esc is hit)
glxgears without kwin compositing: ~9800FPS
glxgears -fullscreen with kwin compositing: ~420FPS
glxgears -fullscreen without kwin compositing: ~1800FPS
compiz benchmark (sync to vblank disabled in compiz and nvidia-settings): ~290FPS
glxgears in compiz: ~4100FPS (whole display freezes until Esc is hit)
glxgears -fullscreen in compiz (unredirect fullscreen windows enabled): ~1200FPS
glxgears -fullscreen in compiz (unredirect fullscreen windows disabled): ~430FPS
NWN with compiz 52-58FPS
NWN with kwin 52-58FPS
NWN with just X 52-58FPS

with Option "SLI" "no" in xorg.conf without Allow Flipping :
glxgears with kwin compositing: ~4000FPS
glxgears without kwin compositing: ~9800FPS
glxgears -fullscreen with kwin compositing: ~430FPS
glxgears -fullscreen without kwin compositing: ~550FPS
compiz benchmark: ~260FPS
glxgears in compiz: ~4600FPS
glxgears -fullscreen in compiz (unredirect fullscreen windows enabled): ~510FPS
glxgears -fullscreen in compiz (unredirect fullscreen windows disabled): ~430FPS
NWN with compiz 27-32FPS
NWN with kwin 45-50FPS
NWN with just X 47-52FPS

with Option "SLI" "no" in xorg.conf with Allow Flipping :
glxgears with kwin compositing: ~4300FPS
glxgears without kwin compositing: ~9800FPS
glxgears -fullscreen with kwin compositing: ~440FPS
glxgears -fullscreen without kwin compositing: ~1200FPS
compiz benchmark: ~320FPS
glxgears in compiz: ~4700FPS
glxgears -fullscreen in compiz (unredirect fullscreen windows enabled): ~1000FPS
glxgears -fullscreen in compiz (unredirect fullscreen windows disabled): ~450FPS
NWN with compiz 36-42FPS
NWN with kwin 45-50FPS
NWN with just X 47-52FPS

In summary, it appears that Option "SLI" "Auto" and Allow Flipping enabled gives the best frame rates, but that also gives the horrible flickering. The compiz benchmark is much better with Option "SLI" "no" and Allow Flipping enabled, however playing a game such as NWN seems to give about the same frame rate with Option "SLI" "Auto" and Allow Flipping disabled as with Option "SLI" "no" and Allow Flipping enabled. I'm not sure why the frames rates of NWN with compiz were so much lower than with kwin or just X; unredirect fullscreen windows was enabled in both cases, disabling it gives frame rates of 3-5FPS...

Cheers,
Nappers.
Nappers is offline   Reply With Quote
Old 09-16-10, 06:51 PM   #30
xps8700
Registered User
 
Join Date: Sep 2010
Posts: 45
Default Re: 185.18.14 on Dell M1730 - SLI hangs

wiresquire,

did you ever got an answer/solution??

do you have the patch for 185.18.36 to be installed under kernel 2.6.33.4??
xps8700 is offline   Reply With Quote
Old 09-17-10, 03:45 AM   #31
Nappers
Registered User
 
Join Date: Aug 2008
Posts: 11
Default Re: 185.18.14 on Dell M1730 - SLI hangs

xps8700, I tried to reply to your private message, but you have disabled receiving private messages... so I'm posting my reply here (sorry everyone else!)

My SLI is currently working, though I'm now running on a custom 2.6.35.4 kernel and the 195.36.24 nVidia driver built using nvidia-kernel-dkms from debian testing. Also, the flickering problem still exists with this version when "Allow Flipping" is enabled.
The nvidia-xconfig command you are using just sets some options in the /etc/X11/xorg.conf file. If you have the dual 8700M card, then you should have something like
Code:
Option         "SLI" "Auto" # valid options are "no","Auto","AFR","SFR","AA"
in either the "Screen" section or a "Device" section of this file. You shouldn't need the "multi-gpu" option unless you have multiple GPUs that are not set up in a SLI configuration (see http://http.download.nvidia.com/XFre...igoptions.html).
Once you get the nvidia driver to work, you can enable the tweaks that you make with nvidia-settings by running the command
Code:
nvidia-settings --load-config-only
once X is loaded. I do this by putting the following at the end of my ~/.bash_profile
Code:
if [[ -n "$DISPLAY" ]]
then
  xmodmap /home/nappers/.Xmodmap
  nvidia-settings --load-config-only
  nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
fi
You say that nvidia-settings only mentions the first GPU, perhaps the second GPU is being disabled by the "multi-gpu" option you enabled? You should have two 8700M controllers in lspci, e.g., I have
Code:
>lspci|grep -i nvidia
01:00.0 PCI bridge: nVidia Corporation Device 01b3 (rev a3)
02:00.0 PCI bridge: nVidia Corporation Device 01b3 (rev a3)
02:01.0 PCI bridge: nVidia Corporation Device 01b3 (rev a3)
03:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8700M GT] (rev a1)
04:00.0 3D controller: nVidia Corporation G84 [GeForce 8700M GT] (rev a1)
They should also show up in the X server log, e.g.,
Code:
>grep GPU-[0-9] /var/log/Xorg.0.log
(II) Sep 15 21:30:11 NVIDIA(0): NVIDIA GPU GeForce 8700M GT (G84) at PCI:3:0:0 (GPU-0)
(II) Sep 15 21:30:11 NVIDIA(0): NVIDIA GPU GeForce 8700M GT (G84) at PCI:4:0:0 (GPU-1)
and in dmesg
Code:
>grep -i nvidia /var/log/dmesg
[    7.282031] nvidia: module license 'NVIDIA' taints kernel.
[    8.001675] nvidia 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    8.001685] nvidia 0000:03:00.0: setting latency timer to 64
[    8.001840] nvidia 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    8.001845] nvidia 0000:04:00.0: setting latency timer to 64
[    8.001977] NVRM: loading NVIDIA UNIX x86 Kernel Module  195.36.24  Thu Apr 22 09:18:20 PDT 2010
I hope this helps. Good luck!
Nappers is offline   Reply With Quote
Old 09-17-10, 08:39 PM   #32
xps8700
Registered User
 
Join Date: Sep 2010
Posts: 45
Default Re: 185.18.14 on Dell M1730 - SLI hangs

Nappers/everybody else, we will use thread http://www.nvnews.net/vbulletin/showthread.php?t=155016 (this is my thread) just in case my issues are not the same as wiresquire's ....

thanks!
xps8700 is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.