Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-17-10, 01:51 AM   #1
soft_kitten
Registered User
 
Join Date: Sep 2010
Posts: 2
Default GTS 450 no HDMI audio in Ubuntu

I have a small issue with my Nvidia GTS 450 using Ubuntu 10.04 x86. When I use the mini-hdmi port in my Nvidia graphics card, the video is clear and good, but I do not get hdmi audio, nor can I find any way to enable hdmi audio in the sound settings. All I see is the motherboard audio line-out, which works fine. I am using proprietary nvidia drivers installed manually from the nvidia website version 260.19.06.

When I used an ati 5770 I could select hdmi audio in the sound settings, but that option is not available now.

I get hdmi audio through the video card when using windows 7 and nvidia drivers in the same computer.

Does anyone else have this problem with the newly released GTS 450?
Attached Thumbnails
Click image for larger version

Name:	Screenshot-1.jpg
Views:	339
Size:	83.5 KB
ID:	41120  Click image for larger version

Name:	Screenshot-2.jpg
Views:	245
Size:	81.0 KB
ID:	41121  
Attached Files
File Type: gz nvidia-bug-report.log.gz (72.4 KB, 95 views)

Last edited by soft_kitten; 09-17-10 at 01:55 AM. Reason: forgot log file
soft_kitten is offline   Reply With Quote
Old 09-17-10, 01:29 PM   #2
frenchy2k1
Registered User
 
Join Date: Aug 2002
Location: San Jose, CA
Posts: 449
Default Re: GTS 450 no HDMI audio in Ubuntu

the nvidia binary driver only does graphics on Linux.
Here is a thread talking about audio:
http://www.nvnews.net/vbulletin/show...ght=hdmi+audio
__________________
As the universe is curved, there cannot be a straight answer...
frenchy2k1 is offline   Reply With Quote
Old 09-20-10, 12:31 PM   #3
foo_bar_0001
Registered User
 
Join Date: Sep 2010
Posts: 1
Default Re: GTS 450 no HDMI audio in Ubuntu

Don't know anything about HDMI, but just wondering about the GTS 450, as mine will arrive tomorrow:

Does the 260.19 beta driver work will with the GTS 450? When searching for official Linux drivers on Nvidia's website it does not find anything, and Windows support only started with the 260.63 beta driver.

Thanks.
foo_bar_0001 is offline   Reply With Quote
Old 09-21-10, 01:04 PM   #4
razor1394
Random user
 
razor1394's Avatar
 
Join Date: Mar 2006
Posts: 13
Default Re: GTS 450 no HDMI audio in Ubuntu

For your information, your pictures are not working over here.

I would like to tell that I have the same problem in 10.10 beta amd64 with GTX 460. It works fine under Windows 7. It's not the same card as yours but from what I understand both these have sound onboard the graphics card.

edit:

I tried the latest Maverick mainline 2.6.36-rc5 kernel from the kernel-ppa repository and the HDMI audio chip is available in sound properties.
razor1394 is offline   Reply With Quote
Old 09-21-10, 04:20 PM   #5
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: GTS 450 no HDMI audio in Ubuntu

Quote:
Originally Posted by foo_bar_0001 View Post
Don't know anything about HDMI, but just wondering about the GTS 450, as mine will arrive tomorrow:

Does the 260.19 beta driver work will with the GTS 450? When searching for official Linux drivers on Nvidia's website it does not find anything, and Windows support only started with the 260.63 beta driver.

Thanks.
Read the link frenchy2k1 gave you. ALSA takes care of the audio portion.
Deanjo is offline   Reply With Quote
Old 09-27-10, 08:47 PM   #6
soft_kitten
Registered User
 
Join Date: Sep 2010
Posts: 2
Default Re: GTS 450 no HDMI audio in Ubuntu

Quote:
Originally Posted by razor1394 View Post
For your information, your pictures are not working over here.

I would like to tell that I have the same problem in 10.10 beta amd64 with GTX 460. It works fine under Windows 7. It's not the same card as yours but from what I understand both these have sound onboard the graphics card.

edit:

I tried the latest Maverick mainline 2.6.36-rc5 kernel from the kernel-ppa repository and the HDMI audio chip is available in sound properties.
My pictures you mean? That's odd. They work fine for me.

But its good that the latest kernel has the fix incorporated in it. While frenchy2k1 found a fix, I have absolutely no idea how to use git, and I am too much of a newbie to perform step 3 in Stephen Warren's instructions.

foo_bar, I am using 260.19 right now with my GTS 450, but after reading Stephen Warren's post and his links it seems that the fault lies with Canonical and not Nvidia for this problem.
soft_kitten is offline   Reply With Quote
Old 09-27-10, 09:36 PM   #7
farbird
Registered User
 
Join Date: Feb 2010
Posts: 15
Default Re: GTS 450 no HDMI audio in Ubuntu

try installing the linux backport drivers for alsa.

The backports drivers for alsa is more updated and the one included with the default version in 10.04

linux-backports-modules-alsa-2.6.32-25

The more recent alsa version will identify the newer nvidia cards such as ion2 and newer
farbird is offline   Reply With Quote
Old 09-29-10, 11:13 PM   #8
farbird
Registered User
 
Join Date: Feb 2010
Posts: 15
Default Re: GTS 450 no HDMI audio in Ubuntu

newer cards are not recognized well by the alsa drivers for hdmi audio...

try the backports I posted above.. if u are using ubuntu
farbird is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.