Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-21-10, 03:09 PM   #85
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: G210m Blank Laptop Display

The next release of the 256.xx drivers should have a fix for this. (256.35 does not have the fix.)
danix is offline   Reply With Quote
Old 07-30-10, 02:50 PM   #86
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: G210m Blank Laptop Display

Please try the 256.44 driver:

ftp://download.nvidia.com/XFree86/Linux-x86/256.44
ftp://download.nvidia.com/XFree86/Linux-x86_64/256.44
danix is offline   Reply With Quote
Old 07-31-10, 12:32 AM   #87
g2g591
Registered User
 
Join Date: Sep 2007
Posts: 5
Default Re: G210m Blank Laptop Display

256.44 DOES seem to partially fix this issue on my VPCF115FM which was affected by this (Now X works with the nvidia driver). However, now when I switch to the TTY the display gives me complete garbage (varying shades of white)
Distro: Arch Linux
Kernel: 2.6.34-ARCH , 64 bit
Attached Files
File Type: gz nvidia-bug-report.log.gz (63.5 KB, 131 views)

Last edited by g2g591; 07-31-10 at 12:57 AM. Reason: deciding to check on the tty, adding bug report
g2g591 is offline   Reply With Quote
Old 07-31-10, 07:00 PM   #88
damentz
Registered User
 
Join Date: Jan 2009
Posts: 59
Default Re: G210m Blank Laptop Display

256.44 fixed my LCD screen's detection!

But to be clear, like g2g591, I still can't view any VTs (ctrl+alt+f1 through f6) after loading X, my screen just turns off, goes blank whenever I switch. Fortunately, nothing crashes and hitting ctrl+alt+f7 gets me back to my desktop safely.

I attached my bug report too, in case any of the developers are curious about the TTY switch bug.
Attached Files
File Type: gz nvidia-bug-report.log.gz (45.6 KB, 111 views)
damentz is offline   Reply With Quote
Old 08-03-10, 11:07 AM   #89
alessandro_ufms
Registered User
 
Join Date: Jan 2009
Posts: 23
Default Re: G210m Blank Laptop Display

Hello, nvidia 256.44 solved the problem of IDID detection (330m). But, when I enter on NVIDIA X Server Settings, the screen blinks on the first time when I enter in option.

The brightness control still doesn't work. I need to install nvidia-bl module (https://launchpad.net/~mactel-support/+archive/ppa) to get control so.

On Xorg's log:

Initialized GPU GART.
ACPI display change hotkey events enabled: the X server is new enough to receive ACPI hotkey events.
ACPI: Error: Unable to find the brightness file path under /proc/acpi/video. The NVIDIA X driver will not be able to respond to ACPI brightness change hotkey events.
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (33.2 KB, 109 views)

Last edited by alessandro_ufms; 08-04-10 at 05:10 PM.
alessandro_ufms is offline   Reply With Quote
Old 08-21-10, 11:27 PM   #90
g2g591
Registered User
 
Join Date: Sep 2007
Posts: 5
Default Re: G210m Blank Laptop Display

Quote:
Originally Posted by g2g591 View Post
256.44 DOES seem to partially fix this issue on my VPCF115FM which was affected by this (Now X works with the nvidia driver). However, now when I switch to the TTY the display gives me complete garbage (varying shades of white)
Distro: Arch Linux
Kernel: 2.6.34-ARCH , 64 bit
any updates? any more info that you need?
g2g591 is offline   Reply With Quote
Old 08-23-10, 02:55 PM   #91
TaylorT
Registered User
 
Join Date: Oct 2009
Posts: 8
Default Re: G210m Blank Laptop Display

This did fix the EDID issue for me on my VPCCW17FX.

I'm not sure if it fixes the tty issue or not since I had already found a workaround for that. To do that I basically started using the uvesafb driver. If you are using Ubuntu 10.04 you can look for tutorials for fixing the Plymouth boot screens when using NVidia drivers.

edit: the first part of this tutorial should work.

Also, the resolution that you set uvesafb to isn't likely to be the native resolution of your LCD if it is non-standard. The native resolution of my laptop is 1366x768 but I had to use 1360x768 in order to get uvesafb to work.

Last edited by TaylorT; 08-23-10 at 03:02 PM. Reason: added tutorial link
TaylorT is offline   Reply With Quote
Old 08-24-10, 06:02 PM   #92
r3pek
Registered User
 
Join Date: Jul 2003
Posts: 40
Send a message via ICQ to r3pek
Default Re: G210m Blank Laptop Display

Just to confirm all other reports. EDID detection *DOES* work now, but VT switching still have problems.
Sony VPCCW1S1E here.
r3pek is offline   Reply With Quote

Old 09-27-10, 03:34 PM   #93
forevertheuni
Registered User
 
Join Date: Mar 2009
Posts: 13
Default Re: G210m Blank Laptop Display

VPCCW2S1E no more EDID in xorg.conf
When I install nvidia-bl the backlight works..but badly. When the AC cord is not plugged, if flickers to 0 backlight and I can't do anything else..Help!!
forevertheuni is offline   Reply With Quote
Old 09-27-10, 03:36 PM   #94
forevertheuni
Registered User
 
Join Date: Mar 2009
Posts: 13
Default Re: G210m Blank Laptop Display

Hi the most recent nvidia-256 series don't need EDID in my vpccw2s1e however the nvidia-260 completelly freeze my cmoputer(compiled or from ubuntu-x-swat repo).

When I install nvidia-bl it works.but I can't control it properly. When AC adapter is not plugged the backlight flickers and shuts down all the time so I can't see anything all the time. I need help on the config. Can someone give me a light?

Thanks.
forevertheuni is offline   Reply With Quote
Old 09-27-10, 03:48 PM   #95
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: G210m Blank Laptop Display

Quote:
Originally Posted by forevertheuni View Post
Hi the most recent nvidia-256 series don't need EDID in my vpccw2s1e however the nvidia-260 completelly freeze my cmoputer(compiled or from ubuntu-x-swat repo).

When I install nvidia-bl it works.but I can't control it properly. When AC adapter is not plugged the backlight flickers and shuts down all the time so I can't see anything all the time. I need help on the config. Can someone give me a light?

Thanks.
can you read http://www.nvnews.net/vbulletin/showthread.php?t=46678 and generate a good report with the debug info as instructed after the issue appears ?
Licaon is offline   Reply With Quote
Old 10-03-10, 06:59 PM   #96
lakerssuperman
Registered User
 
Join Date: Nov 2009
Posts: 2
Default Re: G210m Blank Laptop Display

I have the Sony VPCCW17FX laptop. I run Ubuntu 10.04 and have to use the edid hack to make my NVIDIA drivers work. I am running the 260 driver from the x-swat updates. It has the g210m chip in it. Has anyone tested this, or any similar laptops with the new Ubuntu 10.10 beta/release candidates and had any success? I would like to upgrade my laptop but I don't want to go ahead with it if it's going to be a problem to get the Nvidia drivers working.
lakerssuperman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.