Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-03-10, 04:19 PM   #13
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

Seeing this as well, with kernel 2.6.35 on Ubuntu Maverick RC x86-64, NVS 3100M, beta 260.19.06 driver (had to use beta b/c of performance probs with 256.53). Suspend does not work, and the SMP barrier errors in kernel log.
oyvind is offline   Reply With Quote
Old 10-03-10, 05:45 PM   #14
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

Quote:
Originally Posted by oyvind View Post
Seeing this as well, with kernel 2.6.35 on Ubuntu Maverick RC x86-64, NVS 3100M, beta 260.19.06 driver (had to use beta b/c of performance probs with 256.53). Suspend does not work, and the SMP barrier errors in kernel log.
Tested with mainline kernel 2.6.36-rc6, same SMP barrier error messages there. Although those disappear with 256.53, resume from suspend doesn't work properly (X session gets seriously laggy/freezy after resume and desktop is utterly unusable).
oyvind is offline   Reply With Quote
Old 10-03-10, 11:04 PM   #15
MakotoTheKnight
Registered User
 
Join Date: Sep 2010
Posts: 4
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

Similar symptoms observed in Ubuntu 10.04 x64, with drivers 260.19.06, NVIDIA GT 240. Bug report logs attached.
Attached Files
File Type: gz nvidia-bug-report.log.gz (66.4 KB, 105 views)
MakotoTheKnight is offline   Reply With Quote
Old 10-04-10, 11:04 AM   #16
Extender
Registered User
 
Join Date: Sep 2010
Posts: 6
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

260.19.06 are in Maverick repos now, with some debian patches, will try later
Extender is offline   Reply With Quote
Old 10-07-10, 12:43 AM   #17
Extender
Registered User
 
Join Date: Sep 2010
Posts: 6
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

With last maverick, I can change refresh rate (75 or 60 Hz), bug was fixed.
But random freeze is not fixed. I wait 2.6.35.5 in repos (kernel PPA+nv does not work at all)
Extender is offline   Reply With Quote
Old 10-12-10, 05:02 AM   #18
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

Here's a recent Ubuntu bug report for the problem:
https://bugs.launchpad.net/ubuntu/+s...rs/+bug/656279
oyvind is offline   Reply With Quote
Old 10-13-10, 05:09 AM   #19
geldonlan
Registered User
 
Join Date: Oct 2010
Posts: 1
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

Same problem here:
Ubuntu 10.10 64 bit, Geforce GT 240, 260.19.06 driver manually installed and a lot of unstoppable
Code:
[  113.868046] NVRM: os_raise_smp_barrier(), invalid context!
[  113.883483] NVRM: os_raise_smp_barrier(), invalid context!
[  114.367226] NVRM: os_raise_smp_barrier(), invalid context!
[  114.383765] NVRM: os_raise_smp_barrier(), invalid context!
[  169.747759] NVRM: os_raise_smp_barrier(), invalid context!
[  169.764219] NVRM: os_raise_smp_barrier(), invalid context!
[  172.249990] NVRM: os_raise_smp_barrier(), invalid context!
[  172.266397] NVRM: os_raise_smp_barrier(), invalid context!
[  217.456673] NVRM: os_raise_smp_barrier(), invalid context!
[  217.472105] NVRM: os_raise_smp_barrier(), invalid context!
[  260.992506] NVRM: os_raise_smp_barrier(), invalid context!
[  261.009947] NVRM: os_raise_smp_barrier(), invalid context!
[  265.496370] NVRM: os_raise_smp_barrier(), invalid context!
[  265.513801] NVRM: os_raise_smp_barrier(), invalid context!
[  381.096581] NVRM: os_raise_smp_barrier(), invalid context!
[  381.112014] NVRM: os_raise_smp_barrier(), invalid context!
[  383.597381] NVRM: os_raise_smp_barrier(), invalid context!
[  383.613812] NVRM: os_raise_smp_barrier(), invalid context!
[  429.636750] NVRM: os_raise_smp_barrier(), invalid context!
[  429.653130] NVRM: os_raise_smp_barrier(), invalid context!
geldonlan is offline   Reply With Quote
Old 10-14-10, 03:31 PM   #20
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

Bump.

Report at https://bugs.launchpad.net/ubuntu/+s...rs/+bug/656279 indicates that this is not fixed in latest official 260.19.12 driver release.
oyvind is offline   Reply With Quote

Old 10-15-10, 11:43 PM   #21
Extender
Registered User
 
Join Date: Sep 2010
Posts: 6
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

For me, 260.19.12 fixes all bugs.
Extender is offline   Reply With Quote
Old 10-16-10, 04:59 AM   #22
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

Fixed in 260.19.12.

Thanks a lot nvidia, things would be perfect if your communication would be as good as your work

Fuchs
NvFuchs is offline   Reply With Quote
Old 11-05-10, 03:41 AM   #23
mebitek
Registered User
 
Join Date: Nov 2010
Posts: 2
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

hello guys,
on my i5 system I find a little solution.
if i disable all logical cpu before suspend, all will work fine and smooth.

there is some ploblem connected to i5 / i7 kernel support?

this is a little script that enable/disable logical cpu. it must be launch by root

https://bugs.launchpad.net/ubuntu/+s...logical_cpu.sh

pleaser test it...
mebitek is offline   Reply With Quote
Old 11-05-10, 03:55 AM   #24
mebitek
Registered User
 
Join Date: Nov 2010
Posts: 2
Default Re: Lots of NVRM: os_raise_smp_barrier(), invalid context! in dmesg

hello guys,
on my i5 system I find a little solution.
if i disable all logical cpu before suspend, all will work fine and smooth.

there is some ploblem connected to i5 / i7 kernel support?

this is a little script that enable/disable logical cpu. it must be launch by root

https://bugs.launchpad.net/ubuntu/+s...logical_cpu.sh

please test it...
mebitek is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.