Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-16-10, 07:21 AM   #1
michele
Registered User
 
Join Date: Oct 2010
Posts: 4
Default nvidia drivers on 2.35.4 linux kernel

Hi to all,

I have just compiled my Linux Kernel to 2.6.35.4, and I tried to install new nVidia drivers for a 9600M GT. I downloaded the x86-185.18.36, I shut down X server and launched the script using --update as root.
The new 260.19.12 driver has been downloaded, the appropriate kernel module has been built and the installation process seemed to be successful.
When I restarted X server, everything went fine: the nVidia logo was displayed, glx drivers (by glxinfo) were loaded and KDE4 started with usual shade and transparency effects.

BUT: when I rebooted, after a fast blinking of nVidia logo, the X server crashed and no kdm logon window was displayed. The strange thing is that no error messages were displayed in /var/log/Xorg.0.log file
I tried to uninstall and reinstall nvidia drivers and, again, kdm started correctly.

Any suggestion?

Thank you all!

I've uploaded my Xorg.0.log file; this is my xorg.conf file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 260.19.12 (buildmeister@builder101) Fri Oct 8 13:54:10 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
Attached Files
File Type: log Xorg.0.log (28.1 KB, 58 views)
michele is offline   Reply With Quote
Old 10-16-10, 12:34 PM   #2
tadawson
Registered User
 
Join Date: May 2009
Posts: 44
Default Re: nvidia drivers on 2.35.4 linux kernel

Don't know what to tell you other than 256.52 had kernel 2.6.35.7 have been rock solid here on a pair of 9800GTX+ cards . . . seems like you might want/need to update your driver.

- Tim
tadawson is offline   Reply With Quote
Old 10-16-10, 01:03 PM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: nvidia drivers on 2.35.4 linux kernel

Please try running X from an SSH session to see if the X server is printing anything out that's not getting logged.
AaronP is offline   Reply With Quote
Old 10-23-10, 07:03 AM   #4
michele
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: nvidia drivers on 2.35.4 linux kernel

Quote:
Originally Posted by AaronP View Post
Please try running X from an SSH session to see if the X server is printing anything out that's not getting logged.
How can I startX server from an SSH session?
Anyway, I've updated Xorg to 1.7 version, I've installed 256.52 nvidia driver but nothing changed.

Actually, in the Xorg.0.log file two errors appeared about "kbd" and "mouse" modules, which have not been found..(see attached file). But after the first driver installation, X server starts without problems!! Glx drivers are loaded correctly, fb support seems to be present (by glxinfo)...

Anyway, I'm wondering if any daemon loaded before X server may negatively interact with it. In some posts I read some issues about hal and Xorg 1.7 for example..

Finally: I tried to substitute "Driver" value ("nvidia") in "Device" section with "nv": in this way I can log in (through graphical kdm interface), but after the first loading stage (in the KDE splash screen) the X server halts.

Any other suggestions?

P.S. Also forgot: I removed xserver-xgl package, since Xorg loaded those driver instead of "/modules/estensions" ones.
Attached Files
File Type: txt xorg-256-noKbd.txt (15.7 KB, 63 views)

Last edited by michele; 10-23-10 at 07:15 AM. Reason: I forgot...
michele is offline   Reply With Quote
Old 10-23-10, 10:20 AM   #5
michele
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: nvidia drivers on 2.35.4 linux kernel

Can nVidia TLS interfere with proprietary nVidia drivers?
michele is offline   Reply With Quote
Old 10-23-10, 11:30 AM   #6
michele
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: nvidia drivers on 2.35.4 linux kernel

Solved.

I uninstalled the nvidia-glx package and nvidia-cg-toolkit, previously installed. I think they were in conflict with new proprietary drivers. KDE has started with GLX and FB support.
Actually I'm using 256.52 driver on a 2.6.35.4 linux kernel, although the newest driver is the 260.x one. It should work, too, but I fear to lose another weekend trying to setting it up.. Next time!!

Thanks to all, anyway, for your support!
Bye.
michele is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:18 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.