Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-04-10, 06:51 PM   #1
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default Sync to VBlank killing performance for 60fps video

I'm seeing this message a a lot from mplayer on my nvidia based HTPC but not on my slower laptop with an onboard Intel gpu.


HTPC
2.66Ghz C2D (nForce mobo)
Nvidia 210
1920x1080 display @ 50Hz

Laptop
2.00Ghz C2D
Intel onboard
1200x800 display @ 60Hz

Example video (h.264 640x480 60fps)
http://sonichurricane.com/media/sfryuexh-evo2k9ohn8.mkv

mplayer -fs -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,ffvc1vdpau,ffwmv3vdpau, -ao pulse

System too slow message, audio out of sync yet cpu is < 10%

Switching to 1080p60 seems to help a little.
Dropping to 720p60, video plays fine
Switching to -vo xv, video stutters every few seconds
Switching to unscaled -vo x11, plays back fine
Switching -ao alsa/null, no difference


Any ideas? It was the same situation previously using the onboard nForce gpu before I upgraded to a 210.

Thanks
Attached Files
File Type: gz nvidia-bug-report.log.gz (98.0 KB, 66 views)

Last edited by thecapsaicinkid; 11-06-10 at 06:38 AM.
thecapsaicinkid is offline   Reply With Quote
Old 11-05-10, 05:31 AM   #2
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by thecapsaicinkid View Post
HTPC
2.66Ghz C2D (nForce mobo)
Nvidia 210
1920x1080 display @ 50Hz

[...]

Example video (h.264 640x480 60fps)
How do you expect this to work?

If the decoder outputs (nearly) 60 frames per second, but your screen only displays 50, wouldn't you expect video to fall back behind audio quickly?

I do know (from others' reports, I am on 85Hz) that it doesn't work very well on 60Hz either, but in your configuration, it simply can't play (satisfactorily).

Carl Eugen
cehoyos is offline   Reply With Quote
Old 11-05-10, 11:00 AM   #3
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default Re: Your system is too SLOW to play this!

It's currently set to 50Hz because 24fps runs better than at 60 and setting the output to 60Hz doesn't solve the problem for 60fps video completely as mentioned (probably wasn't clear), the video just hitches up every second or so.

Most playback software will keep audio sync by dropping/generating frames if the framerate doesn't match output, won't they? Genuine question.
thecapsaicinkid is offline   Reply With Quote
Old 11-05-10, 11:52 AM   #4
frenchy2k1
Registered User
 
Join Date: Aug 2002
Location: San Jose, CA
Posts: 449
Default Re: Your system is too SLOW to play this!

the Geforce G210 (GT218 chip) is a very low end chip.
Trying to push mp4 decoding and up-scaling at 1080p (be it 50 or 60 Hz) is really borderline for the chip.
Try for a lower resolution first (I mean, you are comparing your intel @ 1MP to the nvidia @2MP).
Also, check in mplayer if you have any image quality options (post processing) and disable most of those, as the chip just cannot perform them.
__________________
As the universe is curved, there cannot be a straight answer...
frenchy2k1 is offline   Reply With Quote
Old 11-05-10, 12:41 PM   #5
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by frenchy2k1 View Post
the Geforce G210 (GT218 chip) is a very low end chip.
The described problem has nothing to do with the performance of the GPU (my G210 happily decodes 1080@30 and 720@60), but only with MPlayer's inability to automatically drop frames with vo vdpau.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 11-05-10, 12:48 PM   #6
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by thecapsaicinkid View Post
Plays fine for me with -vc ffh264vdpau -speed 2 -framedrop -fs (on a G210), so I believe it should work for you with -framedrop.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 11-05-10, 02:51 PM   #7
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default Re: Your system is too SLOW to play this!

Double post, please delete.
thecapsaicinkid is offline   Reply With Quote
Old 11-05-10, 02:54 PM   #8
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default Re: Your system is too SLOW to play this!

Same video, display set to 1080p60, all videos unscaled/windowed

x11 = fine
xv = video/audio freezes every second or so, X process at 100% cpu usage (X at 7% on laptop)
vdpau = 'System too slow' message, 4% cpu usage.

Definitely something wrong with playback of 60fps video if it can't play a 640x480 60fps video, unscaled with xv/vdpau. Especially considering it works fine on my lower powered laptop with a crappy onboard intel gpu.
thecapsaicinkid is offline   Reply With Quote

Old 11-05-10, 06:52 PM   #9
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default Re: Your system is too SLOW to play this!

Disabling 'Sync to VBlank' in nvidia-settings resolves the issue (must be at 60Hz not 50) Can anyone explain what might be going on here?

VDPAU always seems to have an A-V sync in mplayer hovering around 0.200 permanently, is this down to a slight mismatch in framerate and display refresh? XV doesn't do the same and sticks to A-V 0.00.

The only video that plays slow now is a 1080p 60fps, I'm guessing this is a bit much for a G210? Even though CPU usage is no more than 25%?


Thanks
thecapsaicinkid is offline   Reply With Quote
Old 11-05-10, 08:07 PM   #10
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by thecapsaicinkid View Post
The only video that plays slow now is a 1080p 60fps, I'm guessing this is a bit much for a G210?
Not just G210, for every (pre-Fermi?) Nvidia GPU.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 11-06-10, 06:35 AM   #11
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by cehoyos View Post
Not just G210, for every (pre-Fermi?) Nvidia GPU.

Carl Eugen
Silly question time, how come the cpu is sitting around twiddling its thumbs while the gpu is choking on 1080p60?

Just tried the 'killa birds sampler' h.264 and that runs fine at 1080p 50fps (supposedly 100mbps+)


Do you have any idea why Sync to VBlank is killing my performance for 60fps video?

Thanks
thecapsaicinkid is offline   Reply With Quote
Old 11-06-10, 08:03 AM   #12
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Your system is too SLOW to play this!

Quote:
Originally Posted by thecapsaicinkid View Post
Silly question time, how come the cpu is sitting around twiddling its thumbs while the gpu is choking on 1080p60?
At least on pre-Fermi GPU's, the limit for H264 is approximately 1080@50 (probably depending on the bit-rate).
Quote:
Just tried the 'killa birds sampler' h.264 and that runs fine at 1080p 50fps (supposedly 100mbps+)
It works fine for me, but I believe it shows significantly less than 50 frames per seconds.
Quote:
Do you have any idea why Sync to VBlank is killing my performance for 60fps video?
I already tried to explain to you that the primary reasons for your problems are 1) you try to play 60Hz content on a 50Hz screen and 2) MPlayer does not support automatic framedrop in this case, you have to manually activate it (in which case your use-case works fine for me).

Carl Eugen

Last edited by cehoyos; 11-06-10 at 08:13 AM. Reason: 50fps seems possible and killa sample works fine with G210
cehoyos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:15 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.