Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-26-10, 03:47 PM   #1
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

I am running xorg-server 1.9.2 on Gentoo Linux using Nvidia's driver 260.19.21. I have been encountering issues with random lags where the X server freezes temporarily and then comes back. Some times, it never comes back.

With Nvidia's 260.19.12 driver, I could not recover from this condition. Either my system would be rendered inaccessible over the network or its ping times would spike from less than 1ms to anywhere from 500ms to 3000ms. Attempts to ssh into the system when in either state would fail. With the current driver, I was able to ssh into my system and restart xdm.

As a consequence, I was able to capture information regarding this condition in my x server log, which I have attached to this post.
Attached Files
File Type: log Xorg.0.log (15.9 KB, 268 views)
ShiningArcanine is offline   Reply With Quote
Old 11-26-10, 03:50 PM   #2
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

I forgot to run nvidia-bug-report.sh. I realized that after I restarted xdm. I just ran it and attached nvidia-bug-report.log.gz. I hope that this information is still useful.
Attached Files
File Type: gz nvidia-bug-report.log.gz (45.1 KB, 175 views)
ShiningArcanine is offline   Reply With Quote
Old 11-26-10, 06:45 PM   #3
schuay
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

Same issue here:

Archlinux
nvidia 260.19.21
xorg-server 1.9.2

Identical stack trace.
Happens real frequently lately, requiring a hard reboot most of the time.
Would love to figure out how to solve this.

Some more info:
Kernel 2.6.36.1
GeForce 8800 Ultra

Will add nvidia-bug-report output when it happens again.

Edit:

nvidia-bug-report.log doesn't seem to contain anything useful:
Date: Sat Nov 27 11:48:28 CET 2010
uname: Linux jsrv64 2.6.36-ARCH #1 SMP PREEMPT Wed Nov 24 00:39:57 CET 2010 x86_64 Intel(R) Core(TM)2 Duo CPU E6850 @ 3.00GHz GenuineIntel GNU/Linux

This was taken while the system was stuttering. The screen seems to refresh every few seconds or so, and commands take AGES to execute. Took me 10 minute to get nvidia-bug-report executed from the ssh login.
schuay is offline   Reply With Quote
Old 11-26-10, 09:29 PM   #4
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

When it happens again, could you ssh into your system and run "nvidia-bug-report.sh" to capture a snapshot of the system state at the time of the issue? I would have done that, but I did not think of it at the time. I imagine that a snapshot at the time of the incident would be more helpful to Nvidia in fixing this than a snapshot after xdm has been restarted.
ShiningArcanine is offline   Reply With Quote
Old 11-27-10, 06:00 AM   #5
schuay
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

Added the nvidia-bug-report output, I'm afraid it won't be very helpful.
A good way to trigger this seems to be running WoW. It does happen in other circumstances (no games, only "normal" non graphics intensive apps) but it's way more frequent and severe like this.
schuay is offline   Reply With Quote
Old 11-27-10, 08:31 AM   #6
ruz
Registered User
 
Join Date: Nov 2010
Posts: 2
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

I have a similar issue under archlinux with xorg 1.9.2 and the newest beta driver. But in my case its just freezing while i play games. My desktop doesn't use any 3d stuff at all.
Attached Files
File Type: gz nvidia-bug-report.log.gz (53.6 KB, 157 views)
ruz is offline   Reply With Quote
Old 11-27-10, 11:25 AM   #7
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

Quote:
Originally Posted by schuay View Post
Added the nvidia-bug-report output, I'm afraid it won't be very helpful.
A good way to trigger this seems to be running WoW. It does happen in other circumstances (no games, only "normal" non graphics intensive apps) but it's way more frequent and severe like this.
In my case, this seems to be triggered by compositing. There is always some sort of activity on the screen when the freezes occur.

I am not sure if it is related to this issue, but if I were to run Runescape in my web browser and leave it running in either a foreground or background tab, xorg-server becomes very laggy and kwin will eventually kill compositing citing slowness being detected. This has been an issue since version 1.7.x when I started using Linux. The recent freezes could be a more extreme case of this. They have been an issue since the upgrade to xorg-server 1.9.x.
ShiningArcanine is offline   Reply With Quote
Old 11-27-10, 12:03 PM   #8
schuay
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

I forgot to add that - even though nothing else works - the mouse pointer remains fully responsive.

Somehow this seems to have gotten worse. After a crash and a reboot, even the BIOS screen was displayed with artifacts, and I can't really enter X anymore without immediately getting artifact + a freeze.
schuay is offline   Reply With Quote

Old 11-27-10, 01:04 PM   #9
holckamaniac
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

I have a similar issue, I think, with a Mythbuntu 10.04 installation (using Xorg 1.7.6). I've attached the bug report file. An additional piece of information that might be useful is that I get the following message in /var/log/messages:

NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context


For what it's worth:

1. The nouveau drivers work fine. Unfortunately you can't use VDPAU with it so it's not a long term solution for me.
2. The 195.XX driver that Mythbuntu makes available locks up worse than the 260.XX driver
3. I tried upgrading to Mythbuntu 10.10 using the 260.XX driver and had the same problem.

Any help out there!?!
Attached Files
File Type: gz nvidia-bug-report.log.gz (44.5 KB, 149 views)
holckamaniac is offline   Reply With Quote
Old 11-27-10, 04:06 PM   #10
sillium
Registered User
 
Join Date: Sep 2008
Posts: 27
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

Hi,

let me just note that this problem seems to be the same:
http://www.nvnews.net/vbulletin/showthread.php?t=157345
I've also seen the mi EQ overflowing message.

For the moment i'm using nouveau and probably I'll stay with it..
sillium is offline   Reply With Quote
Old 11-27-10, 04:27 PM   #11
schuay
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

OK, my card seems to be broken. This is a 3 year old 8800 Ultra (ultraexpensive) which was not stressed by frequent gaming or similar uses.
I'm now getting the same artifacts and unresponsiveness in using nouveau and even in Windows. I can't say whether the xorg crashes (+ identical stack trace to ShiningArcanine) were caused by a broken card or the broken card caused by the errors. But the timing on this is strange and somehow left a bad aftertaste..

Again, my symptoms:

* Display artifacts, geometrical shapes of the screen replaced by purple pixels. These got worse as time went on.
* Immediately afterwards a lack of responsiveness from applications and keyboard
* Then what seems like almost a complete freeze, with just the mouse pointer responding to actions. Applications and keyboard lights do not respond.
* Stack trace as posted by ShiningArcanine

This seems to happen more frequently when running 3d games.

I'm a bit hesitant to get a replacement card in case that one breaks too..
schuay is offline   Reply With Quote
Old 11-27-10, 05:16 PM   #12
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: "[mi] EQ overflowing. The server is probably stuck in an infinite loop."

Quote:
Originally Posted by schuay View Post
I forgot to add that - even though nothing else works - the mouse pointer remains fully responsive.

Somehow this seems to have gotten worse. After a crash and a reboot, even the BIOS screen was displayed with artifacts, and I can't really enter X anymore without immediately getting artifact + a freeze.
The mouse pointer does not remain responsive for me when this happens and everything associated with xorg server will freeze.
ShiningArcanine is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.