Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-18-10, 01:28 PM   #1
Alex Angelini
Registered User
 
Join Date: Dec 2010
Posts: 6
Default NVS 3100m Large Slow Downs

Hi Everyone,

I have a Thinkpad T510, with an NVIDIA NVS 3100m Graphics card, currently running Linux Mint 10 (based off of Ubuntu's 10.10) And the following issue has arisen with the kernel provided by Mint 2.6.35 and the one I compiled and installed yesterday 2.6.36.2

I have used both the driver offered by the distribution and 260.19.29 obtained from NVIDIA's website.

I should also mention this is a 64bit machine with 4 gigs of ram and a mobile Core i5.

This issue is: When performing general computing (such as work in Netbeans, watching flash videos, general Chrome performance and other things) my performance is perfect and just how I would expect it to be. And then every so often it hits a big slow down where:

Scroll rates in Chrome and Netbeans are horrendous
Flash videos are no longer able to play in fullscreen as they freeze up the entire system
And general video quality becomes very choppy

Yet a system restart will bring the system just back to normal, until another slow down happens. I am currently trying to pinpoint the original cause of these slowdowns but do not know where I should be checking.

Is this a known bug and/or do you have any suggestions for debugging or fixing this.

Thanks a ton

Edit: Attached the output of nvidia-bug-report.sh

Edit #2: I also noticed today (while continuing to search for an answer that, http://www.nvidia.com/object/linux-d...29-driver.html for this driver under supported products NVS 3100M is not there... Does this have anything to do with the performance issues I am having??
Attached Files
File Type: gz nvidia-bug-report.log.gz (76.5 KB, 178 views)
Alex Angelini is offline   Reply With Quote
Old 12-18-10, 04:11 PM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: NVS 3100m Large Slow Downs

Can you run nvidia-bug-report.sh after you've started experiencing a slowdown? Right now your log seems perfectly OK, except you are running nouveau and nvidiafb modules and I highly recommend blacklisting/erasing them.

And if only it works for you try running NVIDIA kernel module with MSI (add "options nvidia NVreg_EnableMSI=1" without quotes to /etc/modprobe.d/local.conf).
artem is offline   Reply With Quote
Old 12-18-10, 04:49 PM   #3
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: NVS 3100m Large Slow Downs

Check powermizer. Does it still go into all power levels? There are frequent reports that [something] causes the GPU to get stuck in the lowest power mode.
ledoc is offline   Reply With Quote
Old 12-18-10, 04:59 PM   #4
Alex Angelini
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: NVS 3100m Large Slow Downs

Thanks for the replies, I have checked powermizer and manually set it to the highest power mode during one of these slowdowns, and it did not change the performance.

Also I have now removed any trace of nouveau from my computer and when I run nvidia-bug-report.sh and pipe the results through grep I still get:

Kernel modules: nvidia, nouveau, nvidiafb

Also even before that my first post I have always had these lines in /etc/modprobe.d/blacklist.conf :

blacklist nouveau
blacklist nvidiafb

I have also added "options nvidia NVreg_EnableMSI=1" to /etc/modprobe.d/local.conf like was suggested (had to create that file though)

And finally the initial bug report I submited was taken during one of these slow downs...

Thanks again for all the help
Alex Angelini is offline   Reply With Quote
Old 12-18-10, 05:49 PM   #5
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: NVS 3100m Large Slow Downs

What window manager/desktop environment are you using? A week or two ago there was a guy with mysterious slowdowns partially linked to compiz (I have never had trouble with nvidia+compiz though).
ledoc is offline   Reply With Quote
Old 12-18-10, 05:55 PM   #6
Alex Angelini
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: NVS 3100m Large Slow Downs

I am running Compiz and Gnome, is this a known bug? And if so I am willing to upgrade to the latest version of Compiz to see if that helps in any way, or has there only been a few minor cases

And is there any log specific for Compiz that I should be looking through
Alex Angelini is offline   Reply With Quote
Old 12-18-10, 07:14 PM   #7
Alex Angelini
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: NVS 3100m Large Slow Downs

I also just noticed, it always happens when it wakes up from suspend

Here is the bug report right after I opened my laptop:

Edit: In my attempt to finally figure this out I seem to have gone to far and the OS is now royally screwed, even when reinstalling the driver, compositing no longer works and most of Gnome is gone... Will be wiping the slate clean tonight and throwing on a distro...
Attached Files
File Type: gz nvidia-bug-report.log.gz (79.8 KB, 149 views)
Alex Angelini is offline   Reply With Quote
Old 12-19-10, 03:54 AM   #8
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: NVS 3100m Large Slow Downs

Confirming this, I have noticed this as well after waking from suspend. Every so often, graphics will be noticeably slower after resume from suspend, and everything suffers, from scrolling in browser, to 3D stuff.

For me, the issue started with Ubuntu Lucid kernel 2.6.32-26. Earlier kernels did not have the problem. Also seen on 2.6.35-based kernel.

I have a very reliable work-around though: disable hyper-threading processors before suspending, re-enable them after resume is finished. If I do this, the slowdown never occurs.

So I have this little script in /etc/pm/sleep.d/ which does the job for my Core i7 620 M:

Code:
#!/bin/sh
# Disable hyper-threading processor cores on suspend and hibernate, re-enable them
# on resume. Presumably helps for buggy nvidia behaviour.
# This file goes into /etc/pm/sleep.d/

case $1 in
        hibernate|suspend)
                echo 0 > /sys/devices/system/cpu/cpu1/online
                echo 0 > /sys/devices/system/cpu/cpu3/online
                ;;

        thaw|resume)
                echo 1 > /sys/devices/system/cpu/cpu1/online
                echo 1 > /sys/devices/system/cpu/cpu3/online
                ;;
esac
If you have a multi-core CPU with hyper-threading, you can try this and see if it removes the problem. The script needs to be adapted to CPU type (i.e. which processor ids need disabling/enabling, usually only the odd numbers from 1 to N-1, where N is the total number of logical processors that Linux sees when hyperthreading is enabled. It definitely works for me.

I don't know what the cause of problem is, maybe some race condition or IRQ issue. I've a Dell E6510 with Nvidia NVS 3100M and a Core i7 CPU (with hyper-threading enabled in BIOS). Using 195.36.24 nvidia driver (no later version of the nvidia driver works reliably on my laptop with Ubuntu Lucid 64bit :/ ). Also using Gnome+Compiz combo.

Related bug reports from Launchpad:
https://bugs.launchpad.net/ubuntu/+s...rs/+bug/656279 (several people mention slowdowns after suspend)
https://bugs.launchpad.net/ubuntu/+s...ux/+bug/671932 (I reported this, directly related to the issue)
oyvind is offline   Reply With Quote

Old 12-19-10, 04:07 AM   #9
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: NVS 3100m Large Slow Downs

Quote:
Originally Posted by oyvind View Post
[...] For me, the issue started with Ubuntu Lucid kernel 2.6.32-26. Earlier kernels did not have the problem. Also seen on 2.6.35-based kernel. [...]
Of course, I should mention: this isn't necessarily the fault of the nvidia driver, the kernel itself might be the culprit, or perhaps some unfortunate interaction between kernel and the nvidia driver. Anyway, it's a strange and annoying problem. I haven't really been able to check if more recent nvidia drivers resolve this problem, as they are too unstable after resume (problem with long hangs and ominous NVRM errors).
oyvind is offline   Reply With Quote
Old 12-19-10, 07:50 AM   #10
Alex Angelini
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: NVS 3100m Large Slow Downs

Well I just reinstalled with ubuntu 10.10 and am having the same issue so I will give this script a try

In my /sys/devices/systems/

there are cpu0 - cpu1 - cpu2 - cpu3

So I will try like you did and turn off 0 and 1
Alex Angelini is offline   Reply With Quote
Old 12-19-10, 11:00 AM   #11
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: NVS 3100m Large Slow Downs

Quote:
Originally Posted by Alex Angelini View Post
Well I just reinstalled with ubuntu 10.10 and am having the same issue so I will give this script a try

In my /sys/devices/systems/

there are cpu0 - cpu1 - cpu2 - cpu3

So I will try like you did and turn off 0 and 1
Try CPU id 1 and 3, just like the script does (just use the script without modification).
oyvind is offline   Reply With Quote
Old 12-19-10, 05:07 PM   #12
Alex Angelini
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: NVS 3100m Large Slow Downs

Quote:
Originally Posted by oyvind View Post
Try CPU id 1 and 3, just like the script does (just use the script without modification).
Hahah sorry, that is exactly what I did (should not be posting early in the morning). Anyways ever since I can say I have not seen any slow downs, I can't say I understand 100% why that fix works, but so far it does

Thanks
Alex Angelini is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.