Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-07-10, 09:29 AM   #1
ThomasC
Registered User
 
Join Date: Jan 2009
Posts: 10
Default Backlight/Brightness control not working

Hi Forum,

I write this thread because my backlight control auf my DELL Vostro 3700 doesn't work like it should do.

I can control it with the hardware keys FN+Up/Down... but this was most time a litte bit buggy - sometimes I have to set the backlight to the lowest value and than when I scale it up again its reacting first time or it react right (to make it complete bright)

But now I found, that I have to set

Code:
Option	"RegistryDwords"	"EnableBrightnessControl=1"
in Xorg.conf section of the driver, which I also did.

The main problem is, that I can not control the brightness per software with as example:
Code:
echo 0 | sudo tee /sys/devices/virtual/backlight/acpi_video0/brightness
#or
echo 0 | sudo tee /sys/class/backlight/acpi_video0/brightness
#or
echo 6 | sudo tee /proc/acpi/video/PEGP/LCD/brightness
None of them let the backlight react.

When I monitor all values with

Code:
watch -n1 "cat /sys/class/backlight/acpi_video0/brightness && cat /sys/devices/virtual/backlight/acpi_video0/brightness && cat /proc/acpi/video/PEGP/LCD/brightness"
and use the function keys to change the brightness I can see that all values get changed...

Any Idea what I can do?

I use Ubuntu Lucid Lynx with Nvidia driver 260.19.12 and kernel 2.6.36

Regards,
Thomas
ThomasC is offline   Reply With Quote
Old 11-08-10, 04:13 AM   #2
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: Backlight/Brightness control not working

Hi, you can try set backlight over hal:

first set
Code:
Option          "RegistryDwords" "EnableBrightnessControl=1"
in xorg.conf

then in file /usr/share/hal/fdi/information/10freedesktop/10-laptop-panel-hardware.fdi add this code:

Code:
<match key="/org/freedesktop/Hal/devices/computer:system.hardware.vendor" string="Sony Corporation">
  <match key="/org/freedesktop/Hal/devices/computer:system.hardware.product" contains_outof="VPCF11M1E">
          <merge key="laptop_panel.brightness_in_hardware" type="bool">false</merge>
  </match>
</match>
Values of system.hardware.{vendor,product} you can detect with:
Code:
lshal | grep system.hardware.vendor
lshal | grep system.hardware.product
that's working for me
XjCook is offline   Reply With Quote
Old 12-27-10, 05:43 PM   #3
xificurk
Registered User
 
Join Date: Dec 2010
Posts: 4
Default Re: Backlight/Brightness control not working

Hi, I have Dell Vostro 3700 too and I'm experiencing the same problem. I'm using Gentoo with latest stable kernel (2.6.36) and nvidia-drivers (260.19.29).

Furthermore I've tried nvidia-bl module provided by mactel, which was a partial success - I can control the brightness from command line via /sys/devices/virtual/backlight/nvidia_backlight/brightness. The remaining problem is that when I switch on/off compositing in KDE4, "something" resets the brightness level to the value that was set by Fn keys last time (my wild guess is that nvidia-driver remembers what was set by Fn keys and resets it).
xificurk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:53 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.