Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-21-03, 11:14 AM   #1
ByteWarrior
Registered User
 
Join Date: Nov 2003
Location: Belgium
Posts: 21
Default Drivers don't load ...

Well, I'm still having problems with my Geforce2 400 MX -card.

I can't run 'glxgears' or 'tuxracer' because it crashes immediately, so I think there's something wrong with the driver.
I already tried installing the driver with different methods.

Sometimes everything crashes and the scroll-lock and the caps-lock start blinking.

glxinfo returns this:
Code:
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync, 
    GLX_SGIX_swap_group, GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_NV_float_buffer
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 MX Integrated GPU/AGP/SSE/3DNOW!
OpenGL version string: 1.4.0 NVIDIA 44.96
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_point_parameters, 
    GL_ARB_texture_compression, GL_ARB_texture_cube_map, 
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat, 
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, 
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_S3_s3tc, GL_EXT_abgr, 
    GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_minmax, 
    GL_EXT_blend_subtract, GL_EXT_clip_volume_hint, 
    GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements, 
    GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, 
    GL_EXT_paletted_texture, GL_EXT_point_parameters, GL_EXT_rescale_normal, 
    GL_EXT_secondary_color, GL_EXT_separate_specular_color, 
    GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, 
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map, 
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add, 
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, 
    GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod, 
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array, 
    GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square, 
    GL_NV_fence, GL_NV_fog_distance, GL_NV_light_max_exponent, 
    GL_NV_packed_depth_stencil, GL_NV_pixel_data_range, GL_NV_point_sprite, 
    GL_NV_register_combiners, GL_NV_texgen_reflection, 
    GL_NV_texture_env_combine4, GL_NV_texture_rectangle, 
    GL_NV_vertex_array_range, GL_NV_vertex_array_range2, GL_NV_vertex_program, 
    GL_NV_vertex_program1_1, GL_NVX_ycrcb, GL_SGIS_generate_mipmap, 
    GL_SGIS_multitexture, GL_SGIS_texture_lod
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x21 24 tc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x22 24 dc  0 32  0 r  y  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x2a 24 tc  0 32  0 r  y  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x2b 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
0x2c 24 tc  0 32  0 r  .  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x2d 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
0x2e 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x2f 24 dc  0 32  0 r  .  .  8  8  8  0  0 24  8 16 16 16 16  0 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x31 24 dc  0 32  0 r  y  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x32 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x33 24 dc  0 32  0 r  .  .  8  8  8  0  0 16  0 16 16 16 16  0 0 None
0x34 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  0 16 16 16 16  0 0 None
0x35 24 dc  0 32  0 r  y  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x36 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
0x37 24 dc  0 32  0 r  .  .  8  8  8  0  0  0  0 16 16 16 16  0 0 None
0x38 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 None
If I type lsmod when the system has just booted, I don't see the nvidia driver.
When I do 'modprobe nvidia', the module loads.

So I tried to make it so that it will load everytime. I typed 'insmod /path/to/nvidia.o'.
But that says that this module is already loaded

Here is my lsmod:
Code:
Module                  Size  Used by    Tainted: P  
nls_iso8859-1           3484   1  (autoclean)
nls_cp437               5116   1  (autoclean)
vfat                   12844   1  (autoclean)
fat                    38328   0  (autoclean) [vfat]
nvidia               1764992   0  (unused)
parport_pc             18756   1  (autoclean)
lp                      8868   0  (autoclean)
parport                36480   1  (autoclean) [parport_pc lp]
autofs                 12948   0  (autoclean) (unused)
ipt_REJECT              3896   6  (autoclean)
iptable_filter          2380   1  (autoclean)
ip_tables              14648   2  [ipt_REJECT iptable_filter]
keybdev                 2880   0  (unused)
mousedev                5428   0  (unused)
hid                    21700   0  (unused)
input                   5792   0  [keybdev mousedev hid]
ehci-hcd               19592   0  (unused)
usb-ohci               21160   0  (unused)
usbcore                77696   1  [hid ehci-hcd usb-ohci]
ext3                   69984   4 
jbd                    51220   4  [ext3]
I think it's strange that the 'tainted' column lists '(unused)' for the nvidiadriver...


Could anybody give some help? Some ideas that I could help? Because I really what my GeForce2-card to work...
__________________
AMD Athlon 2400+ 256 MB RAM
ASUS A7N8X with GeForce4 400 MX AGP 8X
HD 60 GB
RedHat 9 (Shrike) - kernel 2.4.20
My system logs
My qualification: Linux beginner
ByteWarrior is offline   Reply With Quote
Old 11-22-03, 03:51 AM   #2
ByteWarrior
Registered User
 
Join Date: Nov 2003
Location: Belgium
Posts: 21
Default

Meanwhile, I tried some other things. After a reboot, I tried 'insmod nvidia' and it worked. But after a reboot, the nvidia driver disappeared again.

Do I have to recompile something or edit a config file to get the drivers loaded automatically with the kernel?

Anther problem that I ran up against.
When the driver was loaded (and listed in lsmod), the agp status is disabled (I ran cat /proc/driver/nvidia/agp/status).

Is there a reason for this? Can I enable AGP on my videocard??
__________________
AMD Athlon 2400+ 256 MB RAM
ASUS A7N8X with GeForce4 400 MX AGP 8X
HD 60 GB
RedHat 9 (Shrike) - kernel 2.4.20
My system logs
My qualification: Linux beginner
ByteWarrior is offline   Reply With Quote
Old 11-22-03, 10:38 AM   #3
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Quote:
Originally posted by ByteWarrior
After a reboot, I tried 'insmod nvidia' and it worked.
What worked? The module inserted without error? X started and functioned as you expected?

Quote:
Originally posted by ByteWarrior

Do I have to recompile something or edit a config file to get the drivers loaded automatically with the kernel?
You shouldn't have to, but your system may not be autoloading necessary modules. I actually don't know how to correct this at this time, I know I've come across it in the past tho. As a workaround, you could add a line to /etc/rc.d/rc.local to have the module loaded at the end of regular sysV init tasks.
/sbin/modprobe nvidia

Quote:
Originally posted by ByteWarrior

Anther problem that I ran up against.
When the driver was loaded (and listed in lsmod), the agp status is disabled (I ran cat /proc/driver/nvidia/agp/status).

Is there a reason for this? Can I enable AGP on my videocard??
Not sure why that is, what agp driver option were you using in the config?
Option "NvAGP" "1"? While the agpgart support should be running enabled agp too, the nvagp stuff might do the trick. Are you running a custom kernel or a distro version?
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-22-03, 11:36 AM   #4
ByteWarrior
Registered User
 
Join Date: Nov 2003
Location: Belgium
Posts: 21
Default

Quote:
Originally posted by LordMorgul
What worked? The module inserted without error? X started and functioned as you expected?
Well, if I use 'insmod', the module successfully loades. I can always start X (with or without the module loaded), but my X still crashes randomly. I thought the crashes had something to do with the driver not getting loaded properly.

It could also be a GLX problem.
When I installed the nvidia-driver, I uninstalled the Mesa-libs. But now I can't run glxgears or tuxracer. If I try that, the system just reboots or crashes

Quote:
You shouldn't have to, but your system may not be autoloading necessary modules. I actually don't know how to correct this at this time, I know I've come across it in the past tho. As a workaround, you could add a line to /etc/rc.d/rc.local to have the module loaded at the end of regular sysV init tasks.
/sbin/modprobe nvidia
Okay, I'll try that.

Quote:
Not sure why that is, what agp driver option were you using in the config?
Option "NvAGP" "1"? While the agpgart support should be running enabled agp too, the nvagp stuff might do the trick. Are you running a custom kernel or a distro version?
Yes, I have "NvAGP" "1" in my XF86Config. But I don't think that's the reason.
My system always boots with runlevel 3. So XF86Config isn't loaded when I do cat /proc/driver/nvidia/agp/status.
Therefore I don't think it hat something to do with the NvAGP option.
__________________
AMD Athlon 2400+ 256 MB RAM
ASUS A7N8X with GeForce4 400 MX AGP 8X
HD 60 GB
RedHat 9 (Shrike) - kernel 2.4.20
My system logs
My qualification: Linux beginner
ByteWarrior is offline   Reply With Quote
Old 11-23-03, 12:27 PM   #5
ByteWarrior
Registered User
 
Join Date: Nov 2003
Location: Belgium
Posts: 21
Default

Quote:
Originally posted by ByteWarrior

It could also be a GLX problem.
When I installed the nvidia-driver, I uninstalled the Mesa-libs. But now I can't run glxgears or tuxracer. If I try that, the system just reboots or crashes
A few hours ago I added mem=nopentium to grub.conf. Now glxgears doesn't crash the whole computer anymore. But it won't run either. I just shows me a black window. I can close that window.

I still have troubles with xscreensaver and with some programs (like tuxracer) and I suspect GLX...

How do I know if GLX is running like it must? (Yeah, glxgears won't run ).

Is there another option so that I at least have a stable system (now my computer reboots frequently)? I already tried the open 'nv' driver, but that doesn't work with my videocard...

PS. I just noticed AGPGART isn't loaded in the kernel. I also can't insert it with insmod (not even with agp_try_unsupported=1). Is that a problem?
__________________
AMD Athlon 2400+ 256 MB RAM
ASUS A7N8X with GeForce4 400 MX AGP 8X
HD 60 GB
RedHat 9 (Shrike) - kernel 2.4.20
My system logs
My qualification: Linux beginner

Last edited by ByteWarrior; 11-23-03 at 01:18 PM.
ByteWarrior is offline   Reply With Quote
Old 11-23-03, 08:15 PM   #6
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

You should not be able to insert agpgart while the nvidia module is already loaded. If it is not, and you can't insert it, that might be a problem, you need either that or the nvidia.o module to have agp support.

Its interesting the 'nv' doesn't work, it should support your card properly, with or without an agp module loaded. That seems to show the system is getting to an odd configuration from tweaking around to get this working. It might help to remove / reinstall the entire XFree86 distro packages, updating if they're not the newest available. As well, reinstalling the kernel and kernel-source (again maybe update) should help bring your system back into a reasonable condition. The 'nv' driver should work, and glxgears should run with Mesa. When this works, remove Mesa and install the nVidia GLX.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Mandrake 9 and nVidia drivers HunterA3 NVIDIA Linux 9 10-09-02 02:54 AM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 09:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.