Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-10, 04:19 PM   #1
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Question X server terminating unexpectedly

let me say upfront that I currently have no indication as to whether the bug is situated within the nvidia module & libs, or elsewhere. All i know is that I have three machines on the same software level, and only the machine with the GT240 and the nvidia driver shows the problem. So if anyone can point me in the right direction, that would be most welcome.

The system was mostly stable, on slackware 13.1++ for x86_64 architecture, with selfmade kernel 2.6.36 and multilibs. I had already done an intermediate upgrade.

There was some rare issue with video playback, and the other machines in the house needed the upgrade (intel video, i say no more), so in order to stay consistent I upgraded everything to slackware current. I tried nvidia 260.19.12 (same as before) and 260.19.21 (latest). both showed the problem:

a few seconds after logging on from kdm the user session is terminated and the kdm logon re-appears. kdm logs "X server terminated unexpectedly" or so, but there is no other indication in the logs. at first i suspected the wireless mouse and keyboard due to (EE) lines in Xorg.log, but cable-bound devices are the same. this happens both with a compositing and non-compositing window manager (KDE). It is not fully deterministic, but usually happens sooner rather than later.

I'll try and list the difference in software releases:

Code:
                         before      after
--------------------------------------------------
xorg                     1.7.7       1.9.2
xf86-input-evdev         2.3.3       2.5.0
libdrm                   2.4.20      2.4.22
mesa                     7.8.1       7.9
cairo                    1.8.8       1.10.0
kde                      4.5.1       4.5.1    (!)
...
if anybody has an idea, please come forward.

Thanks,

Martin
maro is offline   Reply With Quote
Old 11-20-10, 05:16 PM   #2
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

I'm adding an nvidia-bug-report.log.gz. In this instance, however, the X server didn't even start up properly using
Code:
startx -- -logverbose 6
It was hung with a garbled nvidia logo. Reboot was required.

I'll try and catch the original issue now.
Attached Files
File Type: gz nvidia-bug-report.log.gz (57.0 KB, 71 views)
maro is offline   Reply With Quote
Old 11-24-10, 01:08 PM   #3
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

anybody?
maro is offline   Reply With Quote
Old 11-30-10, 02:45 PM   #4
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

OK, I have found out that the crash does not occur when you start the X server via startx in runlevel 3. It will occur reliably if you start via kdm in runlevel 4.

After a termination of the X server in runlevel 4 I ran nvidia-bug-report.sh. The log os attached. However, since kdm had restarted at that point I have probably logged the new session, not the one that had just crashed...
Attached Files
File Type: gz nvidia-bug-report.log.2.gz (40.3 KB, 66 views)
maro is offline   Reply With Quote
Old 11-30-10, 06:11 PM   #5
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: X server terminating unexpectedly

I would try using the nouveau driver on your GT240 for a while. If it still occurs there then you know it isn't a nvidia blob issue.
Deanjo is offline   Reply With Quote
Old 12-01-10, 06:04 PM   #6
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

Quote:
Originally Posted by Deanjo View Post
I would try using the nouveau driver on your GT240 for a while. If it still occurs there then you know it isn't a nvidia blob issue.
That looked like a good idea.

Since then I have spent the better part of the evening compiling the nouveaus xorg driver from the git repository, creating a libdrm distro package from git snapshot, only to realize that I need to patch the kernel as well. So I added the nouveau branch to my linus git repository. that's where I'm stuck at the moment.

I also realize that - if I get this going - I will have created a system configuration quite different from the original one, so the conclusions we can derive from the experiment will probably be limited.

But we'll see.
maro is offline   Reply With Quote
Old 12-04-10, 04:36 PM   #7
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

OK,I got a bit further with being able to boot into runlevel 3 (slackware) with nouveau doing the kernel mode switch and presenting a 1920x1080 framebuffer which is somewhat cool. However, upon startx I got a segfault which is currently logged in the relevant bugzilla.

Since the computer has some short-tempered users (ie. kids) ;-) I re-installed nvidia 260.19.21. Funnily this time I needed a minimal xorg.conf specifying the driver, but who cares. Unfortunately the bug remains: when started via startx, everything is fine. When started from kdm, the sesion either crashes back to kdm or hangs the computer wit a garbled nvidia logo (Alt-Sysreq still working).
maro is offline   Reply With Quote
Old 12-14-10, 03:47 PM   #8
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

Just a quick update: I upgraded the nvidia driver to 260.19.29, but the issue persists.
maro is offline   Reply With Quote

Old 01-02-11, 06:17 PM   #9
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

In the meantime i have done some upgrades, but the issue persists. I have attached strace to kdm and logged one of the crashes. Unfortunately the logfile is 60 MB in size and has nearly 800000 lines. Since I don't know what I'm looking for I am stuck. If someone wants to have a look, I uploaded it here (2 MB compressed):

http://rapidshare.com/files/44047701...strace.log.bz2

After the crash back to the greeter, i returned to runlevel 3. When I subsequently called startx, the machine hung with a garbled nvidia logo. I had to reboot via Alt-SysRequest. I have taken a screenshot of the logo with a camera, in case that is of any help:

http://rapidshare.com/files/440480108/garbled_logo.jpg

Any input would be appreciated. Thanks, and a belated happy new year to everybody. ;-)
maro is offline   Reply With Quote
Old 01-04-11, 11:24 AM   #10
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Lightbulb Solved: X server terminating unexpectedly

OK, analysing the log I found it: I had totally forgotten that I start an application via /etc/xprofile. Apparently it is incompatible with the upgraded xorg server.

So the whole problem was entirely my fault. I guess I have to eat my hat now. ;-)
maro is offline   Reply With Quote
Old 01-23-11, 03:11 PM   #11
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

Hi,

it's me again. Whilst the original problem is solved (presumably triggered, if not created by a VNC server in /etc/xprofile), I have recently seen the symptoms again.

First I need to explain that in recent months the system has not been working as it should: in run level 4 the system does not offer the "Shutdown", "Restart" options anymore in the K-Menu. Also, when logging out in run level 4, the kdm process an the X process will not die. The system hangs with a black screen and an X-shaped mouse cursor. Killing kdm and X from a console will result in a new logon session. In run level 3 everything appears to be fine: I can call startx and log out normally.

Using nv I find identical symptoms. In theory I should completely uninstall the nvidia libraries before making such a statement, but it appears the nvidia driver is not to blame for this strange behaviour.

However, I do find that after a few such sessions the system will hang with a garbled Nvidia logo, just like before when I had the issue with the VNC server! Maybe the hang is just related to an unclean exit by killing the X server?

as always, any feedback is welcome.
maro is offline   Reply With Quote
Old 01-29-11, 10:21 AM   #12
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Default Re: X server terminating unexpectedly

OK, final update (hopefully). I realized I was spending too much time on the issue so I*
bit the bullet and re-installed the complete system from scratch. I am happy to report, the issue is*
now gone. No idea what the reason might have been.
maro is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.