Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-01-11, 08:58 AM   #1
mibo
Registered User
 
Join Date: Jan 2011
Posts: 6
Default Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

Hi experts,

my notebook gets so slow that it is a pain to work with
The hardware - Dell Latitude D630 with Intel 2,5GHz dual core, 4GB RAM, Nvidia Quadro NVS135M and an 120GB OCZ Vertex2 SSD - should be able to run KDE smoothly, but "top" shows up to 100% CPU load from Xorg. So, when I switch between programs (press alt+tab) or switch desktops (press ctrl+F1...F4) the screen is updated very slowly - in these cases the CPU load of Xorg raises from a few% to up to 100%.

I'm using KDE4.5.5 (from official SUSE repository) atm, but the problem also appeared with the KDE4.4 that shipped with SUSE 11.3.
I tried different Nvidia drivers 256, 260 and now the 270beta - but the problem did not go away.
The KDE desktop effects are disabled. When I switch them on, KDE complains about my machine being too slow and switches the effects off.

I found some similar reports in this forum here, but there seems no solution to the problem so far? Is Nvidia aware of the problem? Are they working on it?

PS: If there is anything I should try or test, please tell me.
Attached Files
File Type: gz nvidia-bug-report.log.gz (58.3 KB, 57 views)
mibo is offline   Reply With Quote
Old 02-01-11, 09:28 AM   #2
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

Your GPU might be overheating. Try running "nvidia-settings -q gpucoretemp" when your system is slow. Then post the results here. Someone familiar with the thermal throttling threshold for your GPU should be able to tell you whether or not your GPU is overheating.
ShiningArcanine is offline   Reply With Quote
Old 02-01-11, 09:45 AM   #3
mibo
Registered User
 
Join Date: Jan 2011
Posts: 6
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

nvidia-settings -q gpucoretemp

Attribute 'GPUCoreTemp' (hnb318.site:0.0): 63.
'GPUCoreTemp' is an integer attribute.
'GPUCoreTemp' is a read-only attribute.
'GPUCoreTemp' can use the following target types: X Screen, GPU.

I ran the command several times. The 63C were shown just before the fan started spinning again. When the fan is spinning it shows 55C.
mibo is offline   Reply With Quote
Old 02-01-11, 03:28 PM   #4
AireTamStrm
Registered User
 
Join Date: Nov 2006
Posts: 49
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

I have this issue with KDE 4.6 on SuSE - resizing / moving / spawning / scrolling windows on one GPU, kills the video running on the other GPU.

This is not a thermal problem which has happened before in previous KDE releases. I will look into this and get back to you.

Edit: Please see the guide below.
http://userbase.kde.org/GPU-Performance
AireTamStrm is offline   Reply With Quote
Old 02-02-11, 09:26 AM   #5
mibo
Registered User
 
Join Date: Jan 2011
Posts: 6
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

@AireTamStrm: Thank you for the information.
Your link contains much more possible fixes than I have time for to try out. My main concern is that they refer to an old xorg.conf (I don't have this file anymore) and to old 177./180. Nvidia drivers. I do not expect these old drivers to work with my SUSE 2.6.34 kernel.
mibo is offline   Reply With Quote
Old 02-02-11, 09:57 AM   #6
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

Nvidia has been maintaining the 173.x.y drivers. They might work for you. I have been having performance issues with KDE too. I tried the 173.14.28 drivers on my laptop recently and performance was worse than it was with the 270.18 drivers.
ShiningArcanine is offline   Reply With Quote
Old 02-03-11, 09:56 AM   #7
mibo
Registered User
 
Join Date: Jan 2011
Posts: 6
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

Where do i get these 177. or 180. driver from?
On the Nvidia homepage I could find just 169. driver from 2007 and the next is a 195.36.31 from 2010. (I looked for an nvs135m 64 bit driver)
I tried the 195. driver but had the same slowdowns.

As KDE 4.6 is now available as an openSUSE repository, I will try KDE 4.6.
mibo is offline   Reply With Quote
Old 02-03-11, 04:11 PM   #8
AireTamStrm
Registered User
 
Join Date: Nov 2006
Posts: 49
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

I don't really consider rolling back the driver as an acceptable solution, seeing as alot of people are moving to the Fermi cards.

I'm still looking at this. Right now I'm playing around with the following options in Xorg:

Option "RenderAccel" "true"
Option "UseEvents" "false"
Option "TripleBuffer" "1"
Option "DamageEvents" "1"
Option "BackingStore" "1"
Option "PixmapCacheSize" "70000" # Varies
Option "OnDemandVBlankInterrupts" "true"

As well as the nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1 & option.

I will play with these and let you know what improves performance.

See the following source for these options:
http://techbase.kde.org/User:Lemma/KDE4-NVIDIA

Also: Do you have anti-aliased fonts enabled? I've heard they can improve/kill performance depending on what driver you're using.

NOTE ON KDE 4.6:
I've noticed that kdeinit4 will sometimes 'freak out' and consume 100% CPU of one core on 4.6, I wouldn't treat the 4.6 repo as stable software! I'm able to handle a few of these rogue processes as I have an 8 core server, but for those with dual and quad core you'll likely run into serious performance issues.

This issue looks like a repeat of the following threads:
http://www.nvnews.net/vbulletin/showthread.php?t=154563
http://www.nvnews.net/vbulletin/showthread.php?t=154661

Edit
It looks like one or more of the above X options fixed my performance difficulties. I'll do more testing and figure out which one pulled it off.
AireTamStrm is offline   Reply With Quote

Old 02-04-11, 04:47 PM   #9
mibo
Registered User
 
Join Date: Jan 2011
Posts: 6
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

Thanks for the links.
Today I used the suggested gtkperf-tool to analyze my notebook's performance.
I'm running KDE4.6.0 now with the Nvidia 260.19.36 driver (still SUSE 11.3 64bit). In the morning I could even activate the KDE desktop effects. In the afternoon (the notebook was not rebooted or sent to standby mode between the "morning" and "afternoon" measurement) KDE complaind about my notebook being too slow - and disabled the desktop effects. I later switched the notebook off (no standby, no suspend) and now switched it on again - so it's running just for 20 minutes, but feels veeeery slow. The good thing: gtkperf does show it!!!

In the morning (with desktop effects): 11.5
Afternoon (without effects): 5.something
Evening (very slow, without effects): 22.22

Especially the "GtkTextView" time went up.

Cheers,
mibo

---
gtkperf

(gtkperf:7465): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gtkperf:7465): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
GtkPerf 0.40 - Starting testing: Fri Feb 4 23:38:05 2011

GtkEntry - time: 0,11
GtkComboBox - time: 5,11
GtkComboBoxEntry - time: 4,28
GtkSpinButton - time: 0,35
GtkProgressBar - time: 0,42
GtkToggleButton - time: 0,61
GtkCheckButton - time: 0,23
GtkRadioButton - time: 0,37
GtkTextView - Add text - time: 7,63
GtkTextView - Scroll - time: 0,19
GtkDrawingArea - Lines - time: 0,41
GtkDrawingArea - Circles - time: 1,29
GtkDrawingArea - Text - time: 0,53
GtkDrawingArea - Pixbufs - time: 0,69
---
Total time: 22,22
mibo is offline   Reply With Quote
Old 02-04-11, 05:22 PM   #10
mibo
Registered User
 
Join Date: Jan 2011
Posts: 6
Default Re: Slow KDE4 in SUSE 11.3 64bit on NVS135M Notebook

One last test for today.
Somebody hinted that I should play with the Nvidia PixmapCache value - the problem seems to sit there.
So, I ran gtkperf three times.

First, on my slow system (as posted a minute ago) - it got even a bit worse:
Total time: 29,77

Secondly, I entered: nvidia-settings -a PixmapCache=0
(response: Attribute 'PixmapCache' (hnb318.site:0.0) assigned value 0.)
Total time: 11,94

Last command: nvidia-settings -a PixmapCache=1
(response: Attribute 'PixmapCache' (hnb318.site:0.0) assigned value 1.)
Total time: 5,59

Full results are listed below.

Good night,
mibo


gtkperf

(gtkperf:7773): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gtkperf:7773): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
GtkPerf 0.40 - Starting testing: Sat Feb 5 00:13:42 2011

GtkEntry - time: 0,05
GtkComboBox - time: 11,23
GtkComboBoxEntry - time: 5,95
GtkSpinButton - time: 0,29
GtkProgressBar - time: 0,24
GtkToggleButton - time: 0,54
GtkCheckButton - time: 0,26
GtkRadioButton - time: 1,50
GtkTextView - Add text - time: 5,09
GtkTextView - Scroll - time: 3,21
GtkDrawingArea - Lines - time: 0,41
GtkDrawingArea - Circles - time: 0,33
GtkDrawingArea - Text - time: 0,36
GtkDrawingArea - Pixbufs - time: 0,32
---
Total time: 29,77

GtkPerf 0.40 - Starting testing: Sat Feb 5 00:14:26 2011

GtkEntry - time: 0,12
GtkComboBox - time: 3,86
GtkComboBoxEntry - time: 1,69
GtkSpinButton - time: 0,48
GtkProgressBar - time: 0,66
GtkToggleButton - time: 0,83
GtkCheckButton - time: 0,35
GtkRadioButton - time: 0,49
GtkTextView - Add text - time: 0,86
GtkTextView - Scroll - time: 0,79
GtkDrawingArea - Lines - time: 0,34
GtkDrawingArea - Circles - time: 0,36
GtkDrawingArea - Text - time: 0,47
GtkDrawingArea - Pixbufs - time: 0,64
---
Total time: 11,94

GtkPerf 0.40 - Starting testing: Sat Feb 5 00:14:52 2011

GtkEntry - time: 0,03
GtkComboBox - time: 2,09
GtkComboBoxEntry - time: 0,95
GtkSpinButton - time: 0,13
GtkProgressBar - time: 0,15
GtkToggleButton - time: 0,18
GtkCheckButton - time: 0,07
GtkRadioButton - time: 0,11
GtkTextView - Add text - time: 0,65
GtkTextView - Scroll - time: 0,26
GtkDrawingArea - Lines - time: 0,29
GtkDrawingArea - Circles - time: 0,30
GtkDrawingArea - Text - time: 0,31
GtkDrawingArea - Pixbufs - time: 0,05
---
Total time: 5,59
mibo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.