Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-29-11, 04:14 AM   #1
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Exclamation GF100 - 270.18 - VDPAU mixers performance is really not good

Hello,

On Ubuntu Maverick 10.10, 64 bit, up-to-date, with an NVIDIA GPU Quadro 5000M (GF100GL) and 270.18:

ON-DEMAND CPU Governor - ADAPTIVE perf for the GPU

Code:
qvdpautest 0.5.1
Intel(R) Core(TM) i7 CPU       Q 840  @ 1.87GHz
NVIDIA GPU Quadro 5000M (GF100GL) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  270.18  Tue Jan 18 22:05:47 PST 2011

SURFACE GET BITS: 673.407 M/s
SURFACE PUT BITS: 748.643 M/s

MPEG DECODING (1920x1080): 78 frames/s
MPEG DECODING (1280x720): 175 frames/s
H264 DECODING (1920x1080): 44 frames/s
H264 DECODING (1280x720): 88 frames/s
VC1 DECODING (1440x1080): 62 frames/s
MPEG4 DECODING (1920x1080): 53 frames/s

MIXER WEAVE (1920x1080): 24 frames/s
MIXER BOB (1920x1080): 40 fields/s
MIXER TEMPORAL (1920x1080): 10 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 11 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 19 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 7 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 5 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 8 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 19 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 12 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 22 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 13 fields/s
1.87 GHz CPU Governor - Prefer Max Perf on the GPU

Code:
qvdpautest 0.5.1
Intel(R) Core(TM) i7 CPU       Q 840  @ 1.87GHz
NVIDIA GPU Quadro 5000M (GF100GL) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  270.18  Tue Jan 18 22:05:47 PST 2011

SURFACE GET BITS: 483.521 M/s
SURFACE PUT BITS: 472.236 M/s

MPEG DECODING (1920x1080): 78 frames/s
MPEG DECODING (1280x720): 174 frames/s
H264 DECODING (1920x1080): 44 frames/s
H264 DECODING (1280x720): 88 frames/s
VC1 DECODING (1440x1080): 61 frames/s
MPEG4 DECODING (1920x1080): 53 frames/s

MIXER WEAVE (1920x1080): 23 frames/s
MIXER BOB (1920x1080): 41 fields/s
MIXER TEMPORAL (1920x1080): 10 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 10 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 19 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 6 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 5 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 8 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 18 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 12 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 39 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 13 fields/s
Needless to say, this is not great... Especially for the deinterlacers.

I have seen perfs issues like that around this forum, but no real pointers to a solution.

Am I missing something?

Thanks!

Nico
Attached Files
File Type: gz nvidia-bug-report.log.gz (54.0 KB, 147 views)
File Type: gz qvdpautest_vdpau_trace_and_debug.txt.gz (56.2 KB, 127 views)

Last edited by camelreef; 01-30-11 at 03:08 AM. Reason: Add the attachments - Adjusted title
camelreef is offline   Reply With Quote
Old 01-29-11, 12:51 PM   #2
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: GF100 VDPAU performance is really not good

Ya there is something defiantly funky going on with your system. Not sure what is going on there but GF1XX series should give you smoking performance.

Quote:

qvdpautest 0.5.1
AMD Phenom(tm) II X6 1090T Processor
NVIDIA GPU GeForce GTX 580 (GF110) at PCI:4:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 270.18 Tue Jan 18 22:05:47 PST 2011

SURFACE GET BITS: 1196.81 M/s
SURFACE PUT BITS: 1327.85 M/s

MPEG DECODING (1920x1080): 101 frames/s
MPEG DECODING (1280x720): 237 frames/s
H264 DECODING (1920x1080): 66 frames/s
H264 DECODING (1280x720): 140 frames/s
VC1 DECODING (1440x1080): 83 frames/s
MPEG4 DECODING (1920x1080): 72 frames/s

MIXER WEAVE (1920x1080): 375 frames/s
MIXER BOB (1920x1080): 551 fields/s
MIXER TEMPORAL (1920x1080): 236 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 202 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 296 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 118 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 107 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 131 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 329 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 219 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 107 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 222 fields/s
Deanjo is offline   Reply With Quote
Old 01-31-11, 11:51 AM   #3
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: GF100 VDPAU performance is really not good

camelreef,

When you're running those VDPAU tests, can you also run nvidia-settings, open the PowerMizer page, and see what performance level your GPU is in. Thanks.
Stephen Warren is offline   Reply With Quote
Old 01-31-11, 12:04 PM   #4
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Stephen,

Thanks for the reply.

I have the following table under PowerMizer:

perf level - gfx clock - mem clock - Proc clock
0 - 50 MHz - 135 MHz - 101 MHz
1 - 67 MHz - 324 MHz - 135 MHz
2 - 405 MHz - 1200 MHz - 810 MHz


When preferred mode "Adaptive" is selected, it goes from level 0 to level 1 when running the tests.

When preferred mode "Prefer Maximum Performance" is selected, it just stays at level 1.

I have never seen level 2 used.



Nico

Last edited by camelreef; 01-31-11 at 12:07 PM. Reason: Added screenshot
camelreef is offline   Reply With Quote
Old 01-31-11, 12:08 PM   #5
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: GF100 VDPAU performance is really not good

That's probably the issue then. Are you plugged into AC power, or running on battery? Second, if you run glxgears, does that cause level 2 to be used? If so, presumably that makes VDPAU tests at the same time run faster? Thanks.
Stephen Warren is offline   Reply With Quote
Old 01-31-11, 12:14 PM   #6
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Stephen,

I am plugged into AC power, and nvidia-settings knows about it, at least enough to show it in the GUI.

I have run glxgears, and no, still does not go to level 2.

http://youplala.net/~will/Screenshot-glx-gears.png

Thanks!

Nico

Last edited by camelreef; 01-31-11 at 12:16 PM. Reason: just a link for the screenshot...
camelreef is offline   Reply With Quote
Old 01-31-11, 12:40 PM   #7
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: GF100 VDPAU performance is really not good

I've filed internal report #786655 to track this; we will try to reproduce your problem.
Stephen Warren is offline   Reply With Quote
Old 01-31-11, 12:46 PM   #8
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Thank you Stephen!

Let me know if you need more data /tests.

Nico
camelreef is offline   Reply With Quote

Old 02-05-11, 03:52 AM   #9
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Hello Stephen,

Any luck? Did you manage to reproduce the issue on your side?

Nico
camelreef is offline   Reply With Quote
Old 02-10-11, 03:18 AM   #10
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Any update?

Thanks!

Nico
camelreef is offline   Reply With Quote
Old 02-15-11, 12:34 PM   #11
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: GF100 VDPAU performance is really not good

We have repro'd this issue, but it is not yet fixed.
Stephen Warren is offline   Reply With Quote
Old 02-15-11, 01:50 PM   #12
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Good enough update for me, thanks!

I'm not a weirdo and it is not my system There is hope!

Nico

Last edited by camelreef; 02-15-11 at 01:51 PM. Reason: typo
camelreef is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.