Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-14-11, 01:50 PM   #1
jamoody
Registered User
 
Join Date: Feb 2011
Posts: 2
Default Failed to Initialize the NVIDIA graphics device - Samsung TV LN46A650

I'm running Fedora 12 kernel 2.6.32.26-175 and can't get Xorg to initialize my Samsung TV LN46A650. No nVidia splash screen, just a black screen with fast blinking cursor. The system does boot and Xwindows is running - I can VNC in to a full GUI desktop.
nvidia-bug-report is attached.

Here are my system details:

$ lspci -nn | grep 'VGA\|NV'
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 9500 GT [10de:0640] (rev a1)

$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86 Kernel Module 195.36.31 Tue Jun 1 22:08:27 PDT 2010
GCC version: gcc version 4.4.4 20100630 (Red Hat 4.4.4-10) (GCC)

$ lsmod | grep nouveau
$ lsmod | grep nvidia
nvidia 9972549 0
i2c_core 21774 26 dvb_usb_dib0700,dib7000p,dib7000m,dib0070,dvb_usb, dib3000mc,dib8000,dibx000_common,lgdt330x,cx88_vp3 054_i2c,tuner_simple,wm8775,tda9887,tda8290,tea576 7,tuner,cx25840,cx8800,ivtv,cx88xx,v4l2_common,vid eodev,nvidia,i2c_algo_bit,tveeprom,i2c_i801

$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 260.19.06 (mockbuild@) Sun Oct 10 17:39:46 EDT 2010

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Option "CustomEDID" "DFP-0:/etc/X11/edid.modified.bin"
Option "UseEvents" "True"
SubSection "Display"
Modes "nvidia-auto-select"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

I tried both nvidia-xconfig and livna-config-display as the xorg.conf file shows.

My Fedora 10 system works fine to the same TV and I do recall having to do something special to get the video working but I don't recall what. Can anyone help?
Attached Files
File Type: gz nvidia-bug-report.log.gz (57.5 KB, 53 views)
jamoody is offline   Reply With Quote
Old 02-15-11, 06:38 AM   #2
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: Failed to Initialize the NVIDIA graphics device - Samsung TV LN46A650

can you try a newer nVidia driver too, like 270.18 ?

see the MTRR uncachable fix too: http://www.nvnews.net/vbulletin/show...8&postcount=39

also see this: http://forums.gentoo.org/viewtopic-p...570622#5853353 as you get the same vmalloc error in the logs
Licaon is offline   Reply With Quote
Old 02-21-11, 09:17 PM   #3
jamoody
Registered User
 
Join Date: Feb 2011
Posts: 2
Default Re: Failed to Initialize the NVIDIA graphics device - Samsung TV LN46A650

Updating kernel boot parm to vmalloc=256M did the trick (default is 128M). Looks like the new system went just over the prior limit of 128M. Thanks much for the pointer.

/proc/mtrr still reports several lines as uncachable:
reg00: base=0xbff00000 (3071MB), size= 1MB: uncachable, count=1
reg01: base=0xc0000000 (3072MB), size=1024MB: uncachable, count=1
reg02: base=0xbfbab000 (3067MB), size= 4KB: write-back, count=1
I added kernel boot parm enable_mtrr_cleanup with no change. Any additional suggestions on how to resolve uncachable MTRR?
jamoody is offline   Reply With Quote
Old 02-22-11, 01:39 AM   #4
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: Failed to Initialize the NVIDIA graphics device - Samsung TV LN46A650

not really, if it does not cause any other problems just ignore it
Licaon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:48 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.