Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-28-11, 01:50 PM   #1
taril
Registered User
 
Join Date: Jan 2009
Posts: 8
Default KDE Desktop is frozen during cube rotation with direct rendering

Version: 1.0 (using KDE 4.6.0)
OS: Linux - openSuSE

NVIDIA driver 260.36 (tried with different versions with the same result, beta too)

Enable desktop effects, enable desktop cube (direct rendering is enabled by
default). Press Ctrl+F11 to get desktop cube effect, and rotate the cube with
the mouse. After press 'space'.
The desktop effects will be disabled after a while, you cant do anything, only
mouse works. If you turn off 'Direct Rendering' on the 'Special' tab of the
Desktop Effects Settings, everything works normally.

Reproducible: Always

Steps to Reproduce:
1. enable desktop effects
2. enable desktop cube effect
3. press CTRL+F11 and rotate the cube
4. press 'space' to get back the workspace

Actual Results:
The desktop is unmanageable, mouse works, but not continuously, after a while
the desktop effects will be disabled because of "slow animation" (bubble note)

Expected Results:
Desktop effects with direct rendering

OS: Linux (x86_64) release 2.6.37-22-desktop
Compiler: gcc

SOURCE: https://bugs.kde.org/show_bug.cgi?id=266182
Attached Files
File Type: gz nvidia-bug-report.log.gz (52.2 KB, 78 views)
taril is offline   Reply With Quote
Old 02-28-11, 02:56 PM   #2
xrx
Registered User
 
Join Date: Jun 2005
Posts: 3
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

At last somebody with the same behavior i thought i was the only one

I have the same issues with the following drivers:
NVIDIA-Linux-x86_64-260.19.29
NVIDIA-Linux-x86_64-260.19.36
NVIDIA-Linux-x86_64-270.18
NVIDIA-Linux-x86_64-270.26
NVIDIA-Linux-x86_64-270.29

I'm using Kubuntu Maverick with KDE 4.6.0 / twinview
My card is an GT-430 (GV-N4300C-1GL)
I have the same issues with:
- EN8600GT
- EN8500GT

Last edited by xrx; 02-28-11 at 03:04 PM. Reason: update
xrx is offline   Reply With Quote
Old 02-28-11, 03:02 PM   #3
ihateregistrati
*BANNED*
 
ihateregistrati's Avatar
 
Join Date: Feb 2011
Posts: 3
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

if it's related to kde bug https://bugs.kde.org/show_bug.cgi?id=261323 it's likely in sth. triggerred by glXWaitGL or glFinish - see attached backtraces
ihateregistrati is offline   Reply With Quote
Old 03-05-11, 02:36 AM   #4
taril
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

With ATI and INTEL based system this bug is not existed.
taril is offline   Reply With Quote
Old 03-15-11, 11:19 AM   #5
absinthos
Registered User
 
Join Date: Mar 2011
Posts: 1
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

I have the same problem with the new KDE 4.6.00 and 260.19.36 driver.

The problem did not exist on previous KDE versions.
Attached Files
File Type: gz nvidia-bug-report.log.gz (60.1 KB, 72 views)
absinthos is offline   Reply With Quote
Old 03-16-11, 06:59 AM   #6
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

Quote:
Originally Posted by absinthos View Post
I have the same problem with the new KDE 4.6.00 and 260.19.36 driver.

The problem did not exist on previous KDE versions.
tried the latest 270.30 too?
Licaon is offline   Reply With Quote
Old 03-16-11, 07:01 AM   #7
taril
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

Quote:
Originally Posted by Licaon View Post
tried the latest 270.30 too?
The same.
taril is offline   Reply With Quote
Old 03-16-11, 05:39 PM   #8
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

I managed to get the cube to crash, but only when I set "OpenGL mode" to "Fallback" in the advanced tab. Since this option wasn't specifically called out in your problem description, can you clarify what OpenGL mode you're using? (The default was "Texture From Pixmap".) The crash I saw could be related, but it's hard to be sure...

Can you attach a debugger to kwin and post the backtrace when it crashes? It would be interesting to see if the call stack is similar in your case. (I'm assuming that kwin is crashing in your case too, but if it's a different bug, then that might not be the case...)
danix is offline   Reply With Quote

Old 03-17-11, 03:18 PM   #9
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

Ignore my previous question: the issue I observed seems to be unrelated to what you're describing here. After further testing with other configurations, I was able to observe an issue that sounds more like what you're describing.
danix is offline   Reply With Quote
Old 03-19-11, 04:46 AM   #10
vavoli
Registered User
 
Join Date: Mar 2011
Posts: 1
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

Quote:
Originally Posted by danix View Post
I managed to get the cube to crash, but only when I set "OpenGL mode" to "Fallback" in the advanced tab. Since this option wasn't specifically called out in your problem description, can you clarify what OpenGL mode you're using? (The default was "Texture From Pixmap".) The crash I saw could be related, but it's hard to be sure...

Can you attach a debugger to kwin and post the backtrace when it crashes? It would be interesting to see if the call stack is similar in your case. (I'm assuming that kwin is crashing in your case too, but if it's a different bug, then that might not be the case...)
Hi, I think the problem is not completely opengl related. I managed to rotate cube without freezing in this manner:
1) open desktop effects tab advanced;
2) in opengl options uncheck "enable direct render" (I have italian language so I hope it's the right translation).
I'm on archlinux with nvidia driver 270.18 and kde 4.6.1
vavoli is offline   Reply With Quote
Old 05-11-11, 07:55 AM   #11
evilhog
Registered User
 
Join Date: Apr 2010
Posts: 2
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

According to KDE bugzilla the issue has been solved in KDE 4.6.3

(commit)
evilhog is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.