Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-21-11, 04:41 AM   #1
ddozza
Registered User
 
Join Date: Feb 2011
Posts: 3
Default Black screen when switching to any virtual console on VAIO VPCS12L9E with GeForce310M

I've a Sony Vaio VPCS12L9E with Nvidia GeForce310M with OpenSuse 11.4 64bit.

I'm using lastest Nvidia drivers (x86_64-260.19.44) and when I switch to any of virtual console (ALT-CTRL-Fn) I get black screens.

The console is present because I can login and executing commands (blind login), and by switching ALT-F7 I can return in graphical mode.

I had the same problem also with previous driver versions with OpenSuse 11.3.

I've tried to use vga=normal as boot option in grub and also NVreg_UseVBios=0 as nvidia module parameter but they didn't help.

I've tried to follow this thread useless .

Any suggestion to solve such very annoying issue?
Attached Files
File Type: gz nvidia-bug-report.log.gz (77.4 KB, 78 views)

Last edited by ddozza; 03-21-11 at 05:53 AM. Reason: Added nvidia-bug-report
ddozza is offline   Reply With Quote
Old 03-22-11, 09:50 AM   #2
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Black screen when switching to any virtual console on VAIO VPCS12L9E with GeForce

Quote:
Originally Posted by ddozza View Post
I've a Sony Vaio VPCS12L9E with Nvidia GeForce310M with OpenSuse 11.4 64bit.

I'm using lastest Nvidia drivers (x86_64-260.19.44) and when I switch to any of virtual console (ALT-CTRL-Fn) I get black screens.

The console is present because I can login and executing commands (blind login), and by switching ALT-F7 I can return in graphical mode.

I had the same problem also with previous driver versions with OpenSuse 11.3.

I've tried to use vga=normal as boot option in grub and also NVreg_UseVBios=0 as nvidia module parameter but they didn't help.

I've tried to follow this thread useless .

Any suggestion to solve such very annoying issue?
Are you facing same issue with "Nouveau" driver which comes with OS? Please confirm.
sandipt is offline   Reply With Quote
Old 03-25-11, 06:57 AM   #3
ddozza
Registered User
 
Join Date: Feb 2011
Posts: 3
Default Re: Black screen when switching to any virtual console on VAIO VPCS12L9E with GeForce

Quote:
Originally Posted by sandipt View Post
Are you facing same issue with "Nouveau" driver which comes with OS? Please confirm.
I cannot confirm. With nouveau virtual consoles run correctly.
Is it a problem related to NVIDIA Drivers?
ddozza is offline   Reply With Quote
Old 03-25-11, 08:56 AM   #4
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Black screen when switching to any virtual console on VAIO VPCS12L9E with GeForce

Quote:
Originally Posted by ddozza View Post
I cannot confirm. With nouveau virtual consoles run correctly.
Is it a problem related to NVIDIA Drivers?
Not sure may be OS issue as well.

Uninstall nvidia driver, remove file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

OR delete following lines from the file that you are using to blacklist nouveau driver and reboot OS.

--
blacklist nouveau
options nouveau modeset=0
--


If you are facing problem for above steps then install fresh OS and check virtual console working OR not for nouveau driver. After that install nvidia driver and check again.

If issue is reproduced then please attach nvidia-bug-report by running nvidia-bug-report.sh as root.
sandipt is offline   Reply With Quote
Old 03-28-11, 06:50 AM   #5
ddozza
Registered User
 
Join Date: Feb 2011
Posts: 3
Default Re: Black screen when switching to any virtual console on VAIO VPCS12L9E with GeForce

Quote:
Originally Posted by sandipt View Post
Not sure may be OS issue as well.

Uninstall nvidia driver, remove file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

OR delete following lines from the file that you are using to blacklist nouveau driver and reboot OS.

--
blacklist nouveau
options nouveau modeset=0
--


If you are facing problem for above steps then install fresh OS and check virtual console working OR not for nouveau driver. After that install nvidia driver and check again.

If issue is reproduced then please attach nvidia-bug-report by running nvidia-bug-report.sh as root.
Done. I've removed NVIDIA drivers and I've verified that such problem is not present by using nouveau drivers.
Then I've reinstalled NVIDIA drivers and I've verified the problem is still present.

The only thing I've not done is reinstalling OS. It's necessary?
Attached Files
File Type: gz nvidia-bug-report.log.gz (75.2 KB, 60 views)
ddozza is offline   Reply With Quote
Old 03-30-11, 01:45 AM   #6
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Black screen when switching to any virtual console

Internally NVIDIA filed bug to track this issue Bug ID: 809412. We will try to reproduce this issue in house and update.
sandipt is offline   Reply With Quote
Old 03-30-11, 03:38 AM   #7
artem
Registered User
 
Join Date: Jun 2006
Posts: 704
Default Re: Black screen when switching to any virtual console

I once had this problem on my desktop. It turned out text console was run/managed by the embedded Intel GPU, so ... it might be the case for you too.
artem is offline   Reply With Quote
Old 03-30-11, 05:02 PM   #8
DarkShadow70
Registered User
 
Join Date: Apr 2008
Posts: 17
Default Re: Black screen when switching to any virtual console

I've encountered this issue with 2 AGP (7600GT and 7800GS) cards, and nvidia has not even answered to my bug reports (and I've sent 3 or 4) once in 4 years, nor have they fixed this annoying problem. So, their support is crap.

Additionally, Nvidia's driver suffers from memory allocation problems, leaving you with black windows when using compiz or crashing applications using XVideo. A laptop took 2 minutes to resume from hibernation, reason was the nvidia driver while nouveau did it just fine. I'll never buy a nvidia card again.

You might get away with using the nouveau driver though, maybe they do it better.

Good luck.
DarkShadow70 is offline   Reply With Quote

Old 04-04-11, 12:30 PM   #9
Lauwenmark78
Registered User
 
Join Date: Mar 2005
Posts: 33
Default Re: Black screen when switching to any virtual console on VAIO VPCS12L9E with GeForce

Quote:
Originally Posted by ddozza View Post
I've a Sony Vaio VPCS12L9E with Nvidia GeForce310M with OpenSuse 11.4 64bit.

I'm using lastest Nvidia drivers (x86_64-260.19.44) and when I switch to any of virtual console (ALT-CTRL-Fn) I get black screens.

The console is present because I can login and executing commands (blind login), and by switching ALT-F7 I can return in graphical mode.

I had the same problem also with previous driver versions with OpenSuse 11.3.

I've tried to use vga=normal as boot option in grub and also NVreg_UseVBios=0 as nvidia module parameter but they didn't help.

I've tried to follow this thread useless .

Any suggestion to solve such very annoying issue?
This seems to be the exact same problem I have with my Vaio VPCS13V9E, as described there. So far, I haven't found a way to make the VTs to work with X and the nvidia binary driver - as soon as X starts, VTs are blackened until next reboot.

At least you got more lucky than I was - one of NVidia guys answered you, while they never even acknowledged my existence .
__________________
CPU: AMD Athlon 3500+, MB: Asus A8N-SLI Deluxe (BIOS rev.1014), GFX:: Point-of-View 6600GT 128MB, Mem: 2x512MB DDR400 Kingston CL2.5, HDDs: 2x80GB Maxtor DiamondMax SATA + 1x160GB Hitachi/IBM SATA, OS:Windows Xp Pro Sp2 fr/ForceWare 78.05, Debian Linux AMD64 Sid/NVIDIA-7676
Lauwenmark78 is offline   Reply With Quote
Old 04-04-11, 09:20 PM   #10
Lauwenmark78
Registered User
 
Join Date: Mar 2005
Posts: 33
Default Re: Black screen when switching to any virtual console

Mmm... It looks like I found a way to keep VTs from turning black!

My solution is to load the uvesafb module after the nvidia one, but before starting X. I haven't yet tested with uvesafb compiled in the kernel instead of as a module.

This could work, ddozza - try and tell me if it changed anything!
__________________
CPU: AMD Athlon 3500+, MB: Asus A8N-SLI Deluxe (BIOS rev.1014), GFX:: Point-of-View 6600GT 128MB, Mem: 2x512MB DDR400 Kingston CL2.5, HDDs: 2x80GB Maxtor DiamondMax SATA + 1x160GB Hitachi/IBM SATA, OS:Windows Xp Pro Sp2 fr/ForceWare 78.05, Debian Linux AMD64 Sid/NVIDIA-7676
Lauwenmark78 is offline   Reply With Quote
Old 04-05-11, 08:17 AM   #11
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Black screen when switching to any virtual console

We reproduced this issue in house. NVIDIA will updates you once its got fixed.
sandipt is offline   Reply With Quote
Old 05-18-11, 04:46 AM   #12
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Re: Black screen when switching to any virtual console

There are other posts on this and similar models. I have had this issue with this computer.

Sony VPCF 1290X with nVidia 310M 512MB.

Current kernel: 2.6.38.6
nVidia Driver: 270.41.06

noiveau driver permits vt switching fine as does x-supplied nv driver.

I tried loading uvesafb after nvidia driver, no go. Attached are nvidia-bug-report and lshw.
Attached Files
File Type: gz nvidia-bug-report.log.gz (64.8 KB, 48 views)
File Type: gz sonyvaioF12.txt.gz (4.2 KB, 50 views)
pete4nv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.