Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-15-11, 02:37 PM   #13
freaksworth
Registered User
 
Join Date: Oct 2008
Posts: 8
Default Re: LG TV no video when no audio; when audio active, video works

... sorry, had to check some things first.
Attached Files
File Type: gz nvidia-bug-report.log.gz (88.0 KB, 67 views)
freaksworth is offline   Reply With Quote
Old 02-16-11, 04:29 AM   #14
kumy
Registered User
 
Join Date: Feb 2011
Posts: 5
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by Stephen Warren View Post
Everyone,

You mentioned the same problem. Are you all driving a single display device from a single connector on the GPU?
Yes, basic connection: 32LD350 <=> giada slim n10 on mythbuntu 10.10

(I don't have tested 270.* drivers yet...)

For now as a workaround, I've disabled EDIDs, and forced a modeline (which give me image but no audio => no audio is normal as I've read in another thread that disable EDID disable sound). I've also plugged my old 2.1 sound system directly on the PC jack output.

Attached is my xorg.conf
Attached Files
File Type: gz xorg.conf.tar.gz (1,020 Bytes, 92 views)
kumy is offline   Reply With Quote
Old 02-16-11, 06:05 AM   #15
kumy
Registered User
 
Join Date: Feb 2011
Posts: 5
Default Re: LG TV no video when no audio; when audio active, video works

Forgot to say that I've tried to plug my Giada Slim to another TV (Samsung) and it has well worked. So this issue really seems to be related to LG TVs.
kumy is offline   Reply With Quote
Old 02-19-11, 09:21 AM   #16
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Stephen, yes straight from my Myth box to the LG fails the same way. It's just less convenient to test because you need some other way to control the myth box than through the HDMI port! (It looks like the Nvidia card uses the EDID for the TV it finds first on the splitter and the result shows in the NVidia Control panel. I was able to try it so it finds the LG first and the Panasonic first. Both resulted in the Panasonic working and the LG only working when audio was playing.)

And yes, I had tried the 270.18 before posting. (It should have occurred to me to do the report with the latest installed but I started with the latest and worked backward only doing the report when I realized the fix was not something I could do myself.)

Thanks for looking into it. And if you come up with anything you want me to test, my Myth box is available for testing - it's not my primary Myth box so breaking it isn't a big deal! Hopefully you can get ahold of an LG TV that shows the symptoms.

And thanks to everyone else for sharing your issues too.
ktbos is offline   Reply With Quote
Old 02-24-11, 08:38 PM   #17
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by kumy View Post
For now as a workaround, I've disabled EDIDs, and forced a modeline
Interesting finding, kumy.

Can you check what happens if you save the EDID from the "broken" TV (use nvidia-settings, go to the pane for the display, and click "Acquire EDID" to save a file) and force it on the "working" TV (use the CustomEDID X config option for this; e.g. 'Option "CustomEDID" "DFP-1:/path/to/edid.bin"' in the "Screen" section, obviously replacing DFP-1 with whatever your HDMI port is - see Appendix B of the README for more details)

The same experiment in reverse (supplying the "working" TV's EDID to the "broken" TV) would be interesting as we..
danix is offline   Reply With Quote
Old 02-24-11, 09:17 PM   #18
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by danix View Post
Interesting finding, kumy.

Can you check what happens if you save the EDID from the "broken" TV (use nvidia-settings, go to the pane for the display, and click "Acquire EDID" to save a file) and force it on the "working" TV (use the CustomEDID X config option for this; e.g. 'Option "CustomEDID" "DFP-1:/path/to/edid.bin"' in the "Screen" section, obviously replacing DFP-1 with whatever your HDMI port is - see Appendix B of the README for more details)

The same experiment in reverse (supplying the "working" TV's EDID to the "broken" TV) would be interesting as we..
Isn't this kind of the same thing as my test with the HDMI splitter? Regardless of whether the nvidia driver thought it was driving the Panasonic or the LG based on the EDID, the Panasonic always worked right and the LG always needed the audio to get the video working. That seems like the same kind of thing as getting an EDID for a different TV and using it on the LG.
ktbos is offline   Reply With Quote
Old 02-24-11, 09:21 PM   #19
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: LG TV no video when no audio; when audio active, video works

Thanks, ktbos - I hadn't noticed your comment about the EDIDs on the splitter earlier. You would probably get a similar result swapping EDID files, but I'm not 100% sure.
danix is offline   Reply With Quote
Old 02-26-11, 09:43 AM   #20
telping
Registered User
 
Join Date: Feb 2011
Posts: 1
Default Re: LG TV no video when no audio; when audio active, video works

hello, the same problem goes for philips lcd tv.

if i turn off the audio(mute) on ubuntu my screen start to flash with video next no video next again video and so untill i enable audio on the mixer of ubuntu.

driver linux-x86 270.29

best regards
telping is offline   Reply With Quote

Old 04-05-11, 07:25 AM   #21
kumy
Registered User
 
Join Date: Feb 2011
Posts: 5
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by danix View Post
Interesting finding, kumy.

Can you check what happens if you save the EDID from the "broken" TV (use nvidia-settings, go to the pane for the display, and click "Acquire EDID" to save a file) and force it on the "working" TV (use the CustomEDID X config option for this; e.g. 'Option "CustomEDID" "DFP-1:/path/to/edid.bin"' in the "Screen" section, obviously replacing DFP-1 with whatever your HDMI port is - see Appendix B of the README for more details)

The same experiment in reverse (supplying the "working" TV's EDID to the "broken" TV) would be interesting as we..
Hi,

sorry for didn't reply, I didn't saw notification mail before
I'll try to do the those tests shortly.
kumy is offline   Reply With Quote
Old 04-05-11, 11:48 AM   #22
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by kumy View Post
Hi,

sorry for didn't reply, I didn't saw notification mail before
I'll try to do the those tests shortly.
There's no need to do that; we have reproduced the issue and we understand the problem now.
danix is offline   Reply With Quote
Old 04-05-11, 11:55 AM   #23
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by danix View Post
There's no need to do that; we have reproduced the issue and we understand the problem now.
That's great news. Can you share some insight into the nature of the problem? And whether it is something that is fixable?
ktbos is offline   Reply With Quote
Old 04-16-11, 12:56 AM   #24
proskelley
Registered User
 
Join Date: Apr 2009
Posts: 5
Post Re: LG TV no video when no audio; when audio active, video works

same symptoms occur with an asus 1201n and a lg 32ld450 using the 270.41.03 driver.
proskelley is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.