Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-12-11, 09:59 AM   #1
djgera
Registered User
 
Join Date: Apr 2011
Posts: 2
Default [SOLVED] 270.41.03 does not work with MSI interrupts

Loading module with NVreg_EnableMSI=1. No issues with previous version (260.19.29). I can remember some time ago was happens something similar issue with one driver version a was fixed.

Only x86_64 tested at this time.

Code:
nvidia 0000:01:00.0: setting latency timer to 64
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  270.41.03  Sat Apr  9 00:06:19 PDT 2011
nvidia 0000:01:00.0: irq 42 for MSI/MSI-X
do_IRQ: 0.121 No irq handler for vector (irq -1)
do_IRQ: 0.121 No irq handler for vector (irq -1)
NVRM: RmInitAdapter failed! (0x12:0x2b:1716)
NVRM: rm_init_adapter(0) failed
Attached Files
File Type: gz nvidia-bug-report.log.gz (43.9 KB, 59 views)

Last edited by djgera; 04-13-11 at 11:07 AM.
djgera is offline   Reply With Quote
Old 04-12-11, 11:08 AM   #2
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 270.41.03 does not work with MSI interrupts

It must be specific to your hardware. I'm on 270.41.03 and MSI is still working for me on several systems.

Code:
 54:       6278     423188          0          0   PCI-MSI-edge      nvidia
mooninite is offline   Reply With Quote
Old 04-13-11, 03:55 AM   #3
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: 270.41.03 does not work with MSI interrupts

It also works here:
Code:
 61:       1532          0          0          0   PCI-MSI-edge      nvidia
OpenGL version string: 3.3.0 NVIDIA 270.41.03
artem is offline   Reply With Quote
Old 04-13-11, 05:21 AM   #4
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: 270.41.03 does not work with MSI interrupts

Works here too,

You often need a full reboot because the previous module might not be able to release the msi.
A patch was reported on this forum to fix the msi release on module unload with recent kernel.

Hopefully this was added to this new driver
kwizart is offline   Reply With Quote
Old 04-13-11, 08:37 AM   #5
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: 270.41.03 does not work with MSI interrupts

BTW, does (using) MSI make any difference?
artem is offline   Reply With Quote
Old 04-13-11, 10:22 AM   #6
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: 270.41.03 does not work with MSI interrupts

Quote:
Originally Posted by artem View Post
BTW, does (using) MSI make any difference?
MSI is more stable and safe than traditional PIC or APIC. And it offloads PIC's/APIC's interrupt less than 16/24 so other devices which are not MSI capable can use it.

Of course hardware/driver implementation of MSI must be bug free. For example my Geforce 8200 mainboard supports well MSI for onboard SATA, Ethernet and audio. The only device which hangs after minutes of use in MSI mode is Geforce 8200 integrated GPU. I do not know if this is GPU hw failure or Nvidia binary driver is buggy.
zbiggy is offline   Reply With Quote
Old 04-13-11, 11:06 AM   #7
djgera
Registered User
 
Join Date: Apr 2011
Posts: 2
Default Re: 270.41.03 does not work with MSI interrupts

Quote:
Originally Posted by kwizart View Post
Works here too,

You often need a full reboot because the previous module might not be able to release the msi.
A patch was reported on this forum to fix the msi release on module unload with recent kernel.

Hopefully this was added to this new driver
Thanks. Doing a full reboot/reset the system, works fine again.
djgera is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:44 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.