Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-16-11, 03:45 PM   #25
proskelley
Registered User
 
Join Date: Apr 2009
Posts: 5
Lightbulb Re: LG TV no video when no audio; when audio active, video works

also, after acquiring the EDID and stripping the HDMI extensions using the utility provided by Phoronix I do get a stable video signal, but obviously no audio is transmitted.
thanks for all your hard work!
proskelley is offline   Reply With Quote
Old 04-18-11, 02:22 PM   #26
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: LG TV no video when no audio; when audio active, video works

This turned out to be a bug in the audio driver. It should be fixed in the 2.6.39-rc3 and 2.6.38.3 kernels: http://git.kernel.org/?p=linux/kerne...e8aa89a2511b09
AaronP is offline   Reply With Quote
Old 04-20-11, 10:51 AM   #27
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by AaronP View Post
This turned out to be a bug in the audio driver. It should be fixed in the 2.6.39-rc3 and 2.6.38.3 kernels: http://git.kernel.org/?p=linux/kerne...e8aa89a2511b09
Great news, thanks Aaron! And thanks for the link to the bug; very interesting.

I'll try getting the updated kernel now and I'll report back.
ktbos is offline   Reply With Quote
Old 04-20-11, 05:41 PM   #28
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by AaronP View Post
This turned out to be a bug in the audio driver. It should be fixed in the 2.6.39-rc3 and 2.6.38.3 kernels: http://git.kernel.org/?p=linux/kerne...e8aa89a2511b09
Quote:
Originally Posted by ktbos View Post
Great news, thanks Aaron! And thanks for the link to the bug; very interesting.

I'll try getting the updated kernel now and I'll report back.
Aaron, I have upgraded to Ubuntu 11 (using "update-manager -d") but still get the same issue with my TV. I suspect that I just don't have the right fixed code yet but I don't know what to do to get it.

Here is what I get with uname -a
Code:
Linux Myth1 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux
Will that kernel be sufficient to include the fix? What might I be missing?
ktbos is offline   Reply With Quote
Old 04-20-11, 06:03 PM   #29
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: LG TV no video when no audio; when audio active, video works

I think the "-8" part of that version is an Ubuntu thing, so probably not. The latest stable release is 2.6.38.3.
AaronP is offline   Reply With Quote
Old 04-20-11, 06:40 PM   #30
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by AaronP View Post
I think the "-8" part of that version is an Ubuntu thing, so probably not. The latest stable release is 2.6.38.3.
Yeah, since I posted last I went to kernel.org and found the numbering different. So I'll try to figure out how to get the latest kernel in an Ubuntu-like method. I'll write back again. Thanks, Aaron.
ktbos is offline   Reply With Quote
Old 04-21-11, 11:21 AM   #31
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by ktbos View Post
Yeah, since I posted last I went to kernel.org and found the numbering different. So I'll try to figure out how to get the latest kernel in an Ubuntu-like method. I'll write back again. Thanks, Aaron.
Outstanding! It works!! Not that I doubted that you had found the bug but for it to be as simple as just getting the new kernel is very very exciting.

The upgrade to Ubuntu 11.04 only got me the 2.6.38 kernel. To get the kernel with the fix in it, I needed to download the source from kernel.org and build it and install it. I followed this guide which worked pretty well for me.

With LIRC now set up and my JP1 remotes working, I have a fully functioning MythTV setup visible on two TVs and controllable from both rooms.

Big thanks to AaronP, danix, Stephen Warren, and everybody at NVIDIA for being so responsive. It's rare to find such a thing these days and I can say without any pandering that it truly does make me more loyal to NVIDIA!

PM me with an address so I know where to send the beer!
ktbos is offline   Reply With Quote
Old 04-21-11, 11:24 AM   #32
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by ktbos View Post
Outstanding! It works!! Not that I doubted that you had found the bug but for it to be as simple as just getting the new kernel is very very exciting.
The bug I debugged was definitely fixed. The risk, of course, was that the bug you were seeing was not actually caused by the same thing, so I'm glad you tested it. Thanks for doing that.
AaronP is offline   Reply With Quote

Old 04-21-11, 04:14 PM   #33
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Oh, sure, Aaron - and not just testing but putting it right to use! Thanks again.

For anyone interested in doing something similar who also shares my lack of knowledge about kernel upgrading, I compiled the steps I took into a blog post.
ktbos is offline   Reply With Quote
Old 04-28-11, 06:47 PM   #34
freaksworth
Registered User
 
Join Date: Oct 2008
Posts: 8
Default Re: LG TV no video when no audio; when audio active, video works

I have build kernels (from kernel.org) 2.6.38.4 tried with 270.30, and 2.6.39-rc1 from git with your patch (for fun, I think it's already done in rc5) with 270.41.03, each worked.
Thanks for working this out.
freaksworth is offline   Reply With Quote
Old 11-06-11, 11:32 AM   #35
bdmillan
Registered User
 
Join Date: Nov 2011
Posts: 2
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by AaronP View Post
This turned out to be a bug in the audio driver. It should be fixed in the 2.6.39-rc3 and 2.6.38.3 kernels: http://git.kernel.org/?p=linux/kerne...e8aa89a2511b09
Sorry to resurrect this thread......so after updating to Ubuntu Oneiric which uses a kernel based upon 3.0.5, this problem is back again......actually, I never had an Ubuntu fix this. I had to compile 2.6.39 from kernel.org. Wouldn't it have made it in to 3.0 by now though?
bdmillan is offline   Reply With Quote
Old 11-06-11, 04:10 PM   #36
ktbos
Registered User
 
Join Date: Feb 2011
Posts: 11
Default Re: LG TV no video when no audio; when audio active, video works

Quote:
Originally Posted by bdmillan View Post
Wouldn't it have made it in to 3.0 by now though?
It did make it into later versions of the 2.6 kernel exactly as NVidia had described in this thread. I was able to use those versions and confirm that the problem was fixed. I later rebuilt my whole system using Mythbuntu 11.04 which uses kernel "2.6.38-11-generic" that had the bug fix out of the box.

That being said, I have no knowledge about kernel 3.
ktbos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.