Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-10-11, 02:46 PM   #25
pcdoctor
Registered User
 
Join Date: May 2011
Posts: 5
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

This bug affects me too!
I'm using Debian 6.01 (stable) kde 4.4.5 and GeForce 7200GS/7300.
For now, I've gone back to 260.19.44.
Lesson learned, don't delete the previous Nvidia driver until you are sure the new one works.
pcdoctor is offline   Reply With Quote
Old 05-10-11, 04:03 PM   #26
eddieg780
Registered User
 
Join Date: May 2011
Posts: 2
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I am having the same problem in Kubuntu 11.04 with a go7300 and xorg1.10. I started having problems when there was an upgrade to 270 in 10.10 with xorg1.9 and it appears to have not changed. I downgraded to 260 and all was well until the 11.04 upgrade. Driver 260.19.44 does not work with xorg 1.10 and 270.41.06 does not work with xorg1.9. As soon as the boot screen comes up and I see the nvidia splash screen then the Kubuntu screen where it starts loading everything with the icons and goes fine until it gets to the K and as soon as it starts fading in the screen freezes but it appears that the computer is booting fully. The sound plays, mouse moves and my wifi light flashes. I sure hope someone figures this out fast. My business runs on Linux. The log file shows nothing wrong.
eddieg780 is offline   Reply With Quote
Old 05-11-11, 10:47 AM   #27
Oceanwatcher
A Norwegian in Brazil
 
Oceanwatcher's Avatar
 
Join Date: May 2011
Location: Minas Gerais, Brazil
Posts: 1
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I am running Kubuntu 11.04 and KDE 4.6.3 - fresh install on a Dell XPS M1210 with nVidia GeForce GO 7400.

Today, I decided to try the binary driver by installing the current nVidia driver and got exactly the same problem described here. Hoping there will be a solution to this soon.
__________________
Regards,

Oceanwatcher
Kubuntu 11.04 - KDE 4.6.3 - Intel dual core 2.0 GHz - 2GB RAM - nVidia GeForce GO 7400
Oceanwatcher is offline   Reply With Quote
Old 05-15-11, 08:18 AM   #28
antero_h__
Registered User
 
Join Date: May 2011
Posts: 1
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

Quote:
Originally Posted by eddieg780 View Post
I am having the same problem in Kubuntu 11.04 with a go7300 and xorg1.10. I started having problems when there was an upgrade to 270 in 10.10 with xorg1.9 and it appears to have not changed. I downgraded to 260 and all was well until the 11.04 upgrade. Driver 260.19.44 does not work with xorg 1.10 and 270.41.06 does not work with xorg1.9. As soon as the boot screen comes up and I see the nvidia splash screen then the Kubuntu screen where it starts loading everything with the icons and goes fine until it gets to the K and as soon as it starts fading in the screen freezes but it appears that the computer is booting fully. The sound plays, mouse moves and my wifi light flashes. I sure hope someone figures this out fast. My business runs on Linux. The log file shows nothing wrong.
The Ubuntu bug about this issue has a workaround, downgrade Xorg to 1.9 and nvidia drivers to 260..:
https://bugs.launchpad.net/ubuntu/+s...32/comments/22

HTH,
- Antero
antero_h__ is offline   Reply With Quote
Old 05-15-11, 11:32 AM   #29
pcxz
Registered User
 
Join Date: Jan 2005
Posts: 50
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

In ArchLinux i solve also downgrade Xserver 1.9 ..only i continue to use last nvidia driver 270
pcxz is offline   Reply With Quote
Old 05-18-11, 12:16 PM   #30
s4ncho
Registered User
 
Join Date: May 2011
Posts: 2
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

i've the same. Geforce 7300LE , debian testing, kde 4.6.2, compiz 0.8.4-4
It happend just after update do 270.46.06-1

i've got GLX extensions on (more detail on my bug report in debian - link below) but when turning on compiz or kde effects xserver freezes.
Code:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=627119
without effects screen doesn't freeze
Attached Files
File Type: gz nvidia-bug-report.log.gz (51.9 KB, 89 views)
s4ncho is offline   Reply With Quote
Old 05-18-11, 01:05 PM   #31
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I can confirm this problem in KDE4, although similarly problem has GNOME 3 (after resume from suspend gnome-shell freeze).

I had to migrate from KDE4->GNOME3->XFCE+COMPIZ, fortunately this configuration is working right with latest Xorg and nvidia drivers.

Where is problem, in nvidia driver or Xorg server? Has someone tried to downgrade Xorg?
Attached Files
File Type: gz nvidia-bug-report.log.gz (51.6 KB, 94 views)
XjCook is offline   Reply With Quote
Old 05-19-11, 03:18 PM   #32
s4ncho
Registered User
 
Join Date: May 2011
Posts: 2
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

workaround for debian wheezy wasn't so easy.
First of all i'd to downgrade xserver to 1.7-7.13 (to be able to downgrade nvidia to 260.19.44. it needs xserver-xorg-core <1.7.7).

I've add 3 repos (1 for nvidia, 2 xorg, 3 just in case for nvidia-common) from snapshot.debian.org. It was probalby those 3:
deb http://snapshot.debian.org/archive/d...10507T092547Z/ testing main
deb http://snapshot.debian.org/archive/d...10317T092833Z/ sid non-free
deb http://snapshot.debian.org/archive/d...110316T215302Z sid contrib
and turned off other debian repos

then there's a time problem with refreshing that repos. Refresh needs to be done like that:
Quote:
sudo aptitude -o 'Acquire::Check-Valid-Until=false' update
after that i've deleted all nvidia-* libglx-whatever libgl1-something, and all xserver-xorg packages.

after installation (from snapshot repos) xserver-xorg and nvidia drivers there still was error with mismatch nvidia with nvidia kernel module.
Quote:
sudo modeprobe -r nvidia
finnaly finished my war with nvidia drivers
s4ncho is offline   Reply With Quote

Old 05-20-11, 04:37 PM   #33
rang501
Registered User
 
Join Date: Apr 2011
Posts: 9
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I played around with latest prerelease (270.41.19). No help at all.

Performance seems to be better, but there's no blurring with kde, which is weird because it worked with 170.xxx drivers and even without direct rendering enabled (i mean that checkbox at kde desktop effects settings).

I'm seeing these errors from .xsession-errors file:

Quote:
kwin(1455): Failed to compile shader: "
kwin(1455): Failed to compile shader: "
rang501 is offline   Reply With Quote
Old 05-26-11, 10:09 AM   #34
bastian_knight
Registered User
 
Join Date: May 2008
Posts: 6
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I can confirm that the problem still exists for GeForce 7300 cards. My configuration:
VGA compatible controller: nVidia Corporation G72 [GeForce 7300 LE] (rev a1)
Dirver version: 270.41.06
Xorg version: 1.10.1
bastian_knight is offline   Reply With Quote
Old 05-27-11, 03:48 AM   #35
davegriffiths62
Registered User
 
Join Date: Apr 2011
Posts: 5
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I can also confirm that with the latest 275.09 beta driver I still get the desktop freeze in KDE 4.6.3 on openSUSE 11.4. However, NVIDIA have released 173.14.30 with updates for Xorg 1.10 and this driver works with my 7300GS and allows compositing effects. I think, but am not entirely sure, that in the case of openSUSE 11.4 the problem may be that Xorg is still at version 1.9. In the mean time, at least for me, the 173.14.30 driver from May 3rd works.

HTH someone.

Dave
davegriffiths62 is offline   Reply With Quote
Old 05-27-11, 05:43 AM   #36
bastian_knight
Registered User
 
Join Date: May 2008
Posts: 6
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

Thank you for a suggestion. Composition enabled desktops (KDE) work with legacy drivers. But I cannot watch flash videos with this driver

There's a question to NVIDIA: will this bug be corrected or GeForce 7300 users should start to use legacy drivers?
bastian_knight is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.